summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-03-21 16:01:44 +0100
committerDavid Seifert <soap@gentoo.org>2020-03-21 16:01:44 +0100
commitaf066c6b63a89f834a736181d7c892ebc453fecd (patch)
treef51724184a798740d680f2ddb16da9e55306c3df /net-p2p
parentnet-firewall/firewalld: fix ipset path (diff)
downloadgentoo-af066c6b63a89f834a736181d7c892ebc453fecd.tar.gz
gentoo-af066c6b63a89f834a736181d7c892ebc453fecd.tar.bz2
gentoo-af066c6b63a89f834a736181d7c892ebc453fecd.zip
net-p2p/ctorrent: Add missing <sys/types.h> include
Closes: https://bugs.gentoo.org/713752 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ctorrent/ctorrent-3.3.2-r4.ebuild9
-rw-r--r--net-p2p/ctorrent/files/ctorrent-3.3.2-sys-types_h.patch11
2 files changed, 16 insertions, 4 deletions
diff --git a/net-p2p/ctorrent/ctorrent-3.3.2-r4.ebuild b/net-p2p/ctorrent/ctorrent-3.3.2-r4.ebuild
index 000a6838b530..85457d846cf6 100644
--- a/net-p2p/ctorrent/ctorrent-3.3.2-r4.ebuild
+++ b/net-p2p/ctorrent/ctorrent-3.3.2-r4.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
MY_P="${PN}-dnh${PV}"
@@ -14,16 +14,17 @@ SLOT="0"
KEYWORDS="amd64 arm ppc ~s390 ~sh ~sparc x86"
IUSE="libressl"
-S="${WORKDIR}/${MY_P}"
-
RDEPEND="
libressl? ( dev-libs/libressl:0= )
!libressl? ( dev-libs/openssl:0= )
"
DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
PATCHES=(
"${FILESDIR}"/${PN}-CVE-2009-1759.patch
"${FILESDIR}"/${P}-negative-ints.patch
"${FILESDIR}"/${P}-empty-path-components.patch
+ "${FILESDIR}"/${P}-sys-types_h.patch
)
diff --git a/net-p2p/ctorrent/files/ctorrent-3.3.2-sys-types_h.patch b/net-p2p/ctorrent/files/ctorrent-3.3.2-sys-types_h.patch
new file mode 100644
index 000000000000..bf93cb2a3bb3
--- /dev/null
+++ b/net-p2p/ctorrent/files/ctorrent-3.3.2-sys-types_h.patch
@@ -0,0 +1,11 @@
+--- a/compat.c
++++ b/compat.c
+@@ -8,6 +8,8 @@
+ #include <sys/param.h>
+ #endif
+
++#include <sys/types.h>
++
+ #include "compat.h"
+
+ #ifndef HAVE_CLOCK_GETTIME