summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-01-03 08:51:11 -0500
committerAnthony G. Basile <blueness@gentoo.org>2016-01-03 08:52:28 -0500
commitb77845e33211c442dc34713a386fdd40e657b7bb (patch)
tree5fe1a2b1541503c3c99c447f3fc203266a6753fb /net-p2p
parentnet-p2p/litecoin-qt: fix RWX GNU stack (diff)
downloadgentoo-b77845e33211c442dc34713a386fdd40e657b7bb.tar.gz
gentoo-b77845e33211c442dc34713a386fdd40e657b7bb.tar.bz2
gentoo-b77845e33211c442dc34713a386fdd40e657b7bb.zip
net-p2p/litecoind: fix RWX GNU stack
Package-Manager: portage-2.2.24
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/litecoind/files/litecoind-0.10.2.2-fix-gnustack.patch17
-rw-r--r--net-p2p/litecoind/litecoind-0.10.2.2-r4.ebuild (renamed from net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild)3
2 files changed, 19 insertions, 1 deletions
diff --git a/net-p2p/litecoind/files/litecoind-0.10.2.2-fix-gnustack.patch b/net-p2p/litecoind/files/litecoind-0.10.2.2-fix-gnustack.patch
new file mode 100644
index 000000000000..cbaf66ea93e1
--- /dev/null
+++ b/net-p2p/litecoind/files/litecoind-0.10.2.2-fix-gnustack.patch
@@ -0,0 +1,17 @@
+diff -Naur litecoin-0.10.2.2.orig/src/secp256k1/src/field_5x52_asm.asm litecoin-0.10.2.2/src/secp256k1/src/field_5x52_asm.asm
+--- litecoin-0.10.2.2.orig/src/secp256k1/src/field_5x52_asm.asm 2015-06-15 04:51:30.000000000 -0400
++++ litecoin-0.10.2.2/src/secp256k1/src/field_5x52_asm.asm 2016-01-03 08:35:26.438350565 -0500
+@@ -466,4 +466,12 @@
+ jmp common_exit_norm
+ end
+
+-
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
++%ifidn __OUTPUT_FORMAT__,elf32
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
++%ifidn __OUTPUT_FORMAT__,elf64
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
diff --git a/net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild b/net-p2p/litecoind/litecoind-0.10.2.2-r4.ebuild
index c7f70686e16c..9b2dea415f0f 100644
--- a/net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild
+++ b/net-p2p/litecoind/litecoind-0.10.2.2-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -46,6 +46,7 @@ src_prepare() {
epatch "${FILESDIR}"/0.9.0-sys_leveldb.patch
epatch "${FILESDIR}"/litecoind-0.10.2.2-memenv_h.patch
epatch "${FILESDIR}"/litecoin-miniupnpc-abi.patch
+ epatch "${FILESDIR}"/litecoind-0.10.2.2-fix-gnustack.patch
eautoreconf
rm -r src/leveldb
}