summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-05-15 16:11:13 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-05-15 16:11:58 +0300
commitc43a5330d7ff7c1bd47a4e14bb5d6e4f6d545d03 (patch)
tree6abebe04266ceb59d2b7986568d6b35159ff2147 /net-p2p
parentdev-perl/Data-ShowTable: Remove old (diff)
downloadgentoo-c43a5330d7ff7c1bd47a4e14bb5d6e4f6d545d03.tar.gz
gentoo-c43a5330d7ff7c1bd47a4e14bb5d6e4f6d545d03.tar.bz2
gentoo-c43a5330d7ff7c1bd47a4e14bb5d6e4f6d545d03.zip
net-p2p/qbittorrent: Version bump (v4.3.5)
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.3.5.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 438350a3757d..624d9aca5356 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,3 +1,4 @@
DIST qbittorrent-4.3.1.tar.gz 7836727 BLAKE2B aca72922c2fef567eaa8ecc54774f6ec7417d3b15fc9ef1aef87a5b5f0a96ec332e3ab59c49b1c62e85e73c8a8e61cd1da2e172290df8581b909ee3ad336b34e SHA512 078efb45ec65d7e1342624e71d11fc93516925b08084907266cb6154623bc8b817ecae0ce99489c48b294f8c94f5f6c5ea3f24a9a6ad005fe3249e2a67d0b815
DIST qbittorrent-4.3.3.tar.gz 8044667 BLAKE2B 574193e22529e57f69cfe0892f6076aa6ac7162457bf5e405d24427ebf27b934d3b819451eeba6acfe935e3327491c5d6f3ca8dc13b7e7c1ff491ddda96264be SHA512 58898760814a42b81ffbc7e108a29d8ea6a3f1603b84967ceb9fa489683eb67679e4e8d5e54581a01f8452e68c8385ce3991cc489b7bb13a8bb82169e3059bc4
DIST qbittorrent-4.3.4.1.tar.gz 8057119 BLAKE2B a5e59aab555feaa2638c3ff60df97ae0214871bc85a97fad956b2f0d990eb3ca8a54a9bb5ddf4bade73f70393bd3f522ec5bf2a39d15f50db01f098602875e0b SHA512 f1f2d6dd445b37b7397f38f965221d2f440e3aae208f19508d9b68c507f2461216bba7240f1ead21fa5ab4c08c437dc9f2b4030daca6c27a20ad0c4e66c6ecc0
+DIST qbittorrent-4.3.5.tar.gz 8128281 BLAKE2B 656b64cfcddba37197b7a87ff3281168649d51e127a69dd489c89f11d8ff6cca7de722f4a5188742cf4efb592e0acbf3b1be69dd804d52d25d8c3e13fdf39e32 SHA512 7bfc9e280e70093b74dafae9a6f921cf27f6828ea03ac3510c3419131b40a1610090d335a831697c9b690f47e396700f7b5a4b14dec47a9f12f4ed797f30d0dd
diff --git a/net-p2p/qbittorrent/qbittorrent-4.3.5.ebuild b/net-p2p/qbittorrent/qbittorrent-4.3.5.ebuild
new file mode 100644
index 000000000000..df56a568b980
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.3.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org
+ https://github.com/qbittorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S="${WORKDIR}/qBittorrent-release-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtxml:5
+ >=net-libs/libtorrent-rasterbar-1.2.12:0=
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+src_configure() {
+ econf \
+ $(use_enable dbus qt-dbus) \
+ $(use_enable debug) \
+ $(use_enable webui) \
+ $(use_enable X gui)
+}
+
+src_install() {
+ emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}