summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-02-04 08:35:20 -0500
committerCraig Andrews <candrews@gentoo.org>2020-02-04 08:36:24 -0500
commitca985c2870da0a745d572e8675be42b836d7750f (patch)
tree4553aae926419507ce524212e4458a5691779ceb /net-p2p
parentprofiles/base: Mask dev-python/zeep[tornado] due to broken deps (diff)
downloadgentoo-ca985c2870da0a745d572e8675be42b836d7750f.tar.gz
gentoo-ca985c2870da0a745d572e8675be42b836d7750f.tar.bz2
gentoo-ca985c2870da0a745d572e8675be42b836d7750f.zip
net-p2p/cpuminer-opt: 3.11.9 version bump
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.11.9.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 0020eee2a797..355bba24df73 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -2,3 +2,4 @@ DIST cpuminer-opt-3.11.5.tar.gz 1927342 BLAKE2B 92f5bc74e6ef31ff320e502807d884dd
DIST cpuminer-opt-3.11.6.tar.gz 1927145 BLAKE2B 8cb90a3a419011b98c5105e80aafcf0918934f9648fc2719d876430e6d706e7010a78c01c2b281f7c371a06be9df514dad0bad0c6b8eff456fe14ba9d74ac3f0 SHA512 bfe2df3ba577195781f92b4d96c34a5ea991217b59a5de4f1931458a8475ff630bd9779965110484b2540def1aea5c84de6136203a82c664e968c195a0e494ee
DIST cpuminer-opt-3.11.7.tar.gz 1926765 BLAKE2B 710dc5f03c5df8645170acafae0db01728120202cab6ec4840b590e48d14d5d3ddf611faec394dbade0fed6158120c5e9468ca0bfbb110f06d1d7ab705a6204c SHA512 c6f57598731683f5c3a68bd7ce39c1ed95694249cf5c65dac98ea4cbafe515e272587a93d43b16cc21d53ef9cb74c3db86863705b020e8941e3518f31f3a59d3
DIST cpuminer-opt-3.11.8.tar.gz 1887415 BLAKE2B c15467648edbb06da9edb0d2b9d451306d119f85b2aff46ced4b5d909682082352edbab9dd14d9772fb98cabd717102c6fb1e343c43c4e41e78f74dbfc2585f5 SHA512 5a6cf6a2540a530f3f9796bc8a3d57cc3662615777c8328d822c69348584ad342b123753a95e3d0bb39596294d24cbb7acbe6d3cec597e4dcc945906b0ead777
+DIST cpuminer-opt-3.11.9.tar.gz 1871215 BLAKE2B 3cd19225d4e2b4ab26721069d83f6d568c48ca12fa94ced35024420429000099f8db0e8c69e46617738238d9ab969ef39e3ef555731c4618a7b7b6c88d438c58 SHA512 d1a8f18769970a05df8da454f1755fda593dc0dfb2484855fb447dca25484254cefdbd31e19917b13195519c0e5cbf91fbe644f2d27300ad2db6c1ae52d5125b
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.11.9.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.11.9.ebuild
new file mode 100644
index 000000000000..a5d436b3b8b8
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.11.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}