summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-04-17 18:50:19 +0100
committerMarek Szuba <marecki@gentoo.org>2020-04-17 18:57:29 +0100
commite3a69b9e068c2e919d14f4a848711919fe1ea7ed (patch)
tree07dcb5663306728c7b27689332bd30ef63991e36 /net-p2p
parentnet-p2p/syncthing: remove old (diff)
downloadgentoo-e3a69b9e068c2e919d14f4a848711919fe1ea7ed.tar.gz
gentoo-e3a69b9e068c2e919d14f4a848711919fe1ea7ed.tar.bz2
gentoo-e3a69b9e068c2e919d14f4a848711919fe1ea7ed.zip
net-p2p/syncthing: work around ppc64 test failure
For some reason one of the Syncthing tests - TestIssue5063 - times out on our ppc64 buildhost, with 100% reproducibility. Upstream were not aware of the problem because apparently they have never run the test suite on such a system, that said their suggestion to adjust the time-out threshold appears to do the trick. Make it 20 s i.e. twice what it originally is, hopefully this will prevent the problem from resurfacing any time soon. Closes: https://bugs.gentoo.org/717108 See-also: https://github.com/syncthing/syncthing/issues/6539 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/syncthing/files/syncthing-1.3.4-TestIssue5063_timeout.patch18
-rw-r--r--net-p2p/syncthing/syncthing-1.3.4-r1.ebuild4
-rw-r--r--net-p2p/syncthing/syncthing-1.4.2.ebuild4
3 files changed, 26 insertions, 0 deletions
diff --git a/net-p2p/syncthing/files/syncthing-1.3.4-TestIssue5063_timeout.patch b/net-p2p/syncthing/files/syncthing-1.3.4-TestIssue5063_timeout.patch
new file mode 100644
index 000000000000..3148dc8a976c
--- /dev/null
+++ b/net-p2p/syncthing/files/syncthing-1.3.4-TestIssue5063_timeout.patch
@@ -0,0 +1,18 @@
+As of early April 2020, running the Syncthing test suite on the Gentoo ppc64
+buildhost fails due to TestIssue5063 timing out. Increase the time-out
+threshold for this test to allow it to pass.
+
+Other arches we currently support (i.e. amd64, arm and x86) shouldn't be
+affected by the change because thay have always passed so far anyway.
+
+--- a/lib/model/model_test.go
++++ b/lib/model/model_test.go
+@@ -914,7 +914,7 @@
+ }()
+ select {
+ case <-finished:
+- case <-time.After(10 * time.Second):
++ case <-time.After(20 * time.Second):
+ pprof.Lookup("goroutine").WriteTo(os.Stdout, 1)
+ t.Fatal("Timed out before all devices were added")
+ }
diff --git a/net-p2p/syncthing/syncthing-1.3.4-r1.ebuild b/net-p2p/syncthing/syncthing-1.3.4-r1.ebuild
index 57a69fe4269c..8027187afc57 100644
--- a/net-p2p/syncthing/syncthing-1.3.4-r1.ebuild
+++ b/net-p2p/syncthing/syncthing-1.3.4-r1.ebuild
@@ -292,6 +292,10 @@ RDEPEND="acct-group/syncthing
DOCS=( README.md AUTHORS CONTRIBUTING.md )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.4-TestIssue5063_timeout.patch
+)
+
src_prepare() {
# Bug #679280
xdg_environment_reset
diff --git a/net-p2p/syncthing/syncthing-1.4.2.ebuild b/net-p2p/syncthing/syncthing-1.4.2.ebuild
index 7b3436014f4d..5047b42159ab 100644
--- a/net-p2p/syncthing/syncthing-1.4.2.ebuild
+++ b/net-p2p/syncthing/syncthing-1.4.2.ebuild
@@ -306,6 +306,10 @@ RDEPEND="acct-group/syncthing
DOCS=( README.md AUTHORS CONTRIBUTING.md )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.4-TestIssue5063_timeout.patch
+)
+
src_prepare() {
# Bug #679280
xdg_environment_reset