summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-11-07 11:42:18 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-07 14:48:48 +0100
commitefed9d385d28cb6656c310bd60f842cb120617bc (patch)
tree428b7780750bb92c663d071f1f7abe803d67f92c /net-p2p
parentsys-apps/dbus: Added sys-devel/autoconf-archive to DEPEND. (diff)
downloadgentoo-efed9d385d28cb6656c310bd60f842cb120617bc.tar.gz
gentoo-efed9d385d28cb6656c310bd60f842cb120617bc.tar.bz2
gentoo-efed9d385d28cb6656c310bd60f842cb120617bc.zip
net-p2p/airdcpp-webclient: bump to 2.2.1, fixes a remote crash
See https://airdcpp-web.github.io/2017/10/13/version-2.2.1.html Package-Manager: Portage-2.3.13, Repoman-2.3.4 Closes: https://github.com/gentoo/gentoo/pull/6143
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index ad7df2341b24..2a07aea183af 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,2 +1,3 @@
DIST airdcpp-webclient-2.1.0.tar.gz 844435 SHA256 a8d8a33e3974d23009359709da0bee85e8983e3ea1fe78f21a867078f93b81fa SHA512 755555d30183e772ad5d2e38a813f548e3322ca034b759200f289a834ae21b64f56102f57a13832a837e8a11324efe74a860e941a0f28a02d1f843aed92a328f WHIRLPOOL 5a0a61bcf0ad1de1706786fc2080aeba0ae634386957876a20d1ca638d3fc8b724f5c866d59588f4958a6010fc192d474f1cfe7ff04d4403106ba631b800739b
DIST airdcpp-webclient-2.2.0.tar.gz 844968 SHA256 77cde1acd8730370e87e3546f9895bb993a459ad8f70e1713803ec3ba0a849cb SHA512 a7fc608109ee5823f844bd575d9355d0cbb4094c89e5dcba522018685d969974e82d3dea56bd334591a424010e0b43858f227e2bb66d738c0151c1456175800d WHIRLPOOL 040076d1fd2d7973ccaa6dd0935c0f2b1828c6e4d3bff6de362fd53656d54bf9a9c5733c23fbee35fd6ece897fd5a2ca2b277ceeda51b03c66277f2c81759eb3
+DIST airdcpp-webclient-2.2.1.tar.gz 845507 SHA256 19286ab01fab6be27dbb5ccbcbc09bcc9dacc3108fb3b285916803933e36421e SHA512 97c5b32e590b2fc735fe4978c1a173272c55f84fe97212f7cd1e8bd4a279553c1d992573185781aeceafbbe6bb51303ddb2cd164c748fa798993a661f3abfb81 WHIRLPOOL 6aca14b4af57a1138cd98fe68b7eb49c4d13da6bdf4e4e47ce6f26810d17516376d6e7599ca88c9a364208d9ba1d41436816bcc3ec0177875f72ae6c40a1842b
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.1.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.1.ebuild
new file mode 100644
index 000000000000..fd8f46fe630b
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+
+inherit cmake-utils python-any-r1 user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/geoip
+ dev-libs/leveldb:=
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc:=
+ sys-libs/zlib:=
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}