summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2018-10-03 10:33:25 +0100
committerMarek Szuba <marecki@gentoo.org>2018-10-03 10:35:00 +0100
commitfefe285c0cc24ced261b92a7aea8b6ace90fb030 (patch)
tree01d4722d1dbd1529dd7c6a220f323ae79a91eb8a /net-p2p
parentnet-misc/networkmanager-openvpn: bump to 1.8.6 (diff)
downloadgentoo-fefe285c0cc24ced261b92a7aea8b6ace90fb030.tar.gz
gentoo-fefe285c0cc24ced261b92a7aea8b6ace90fb030.tar.bz2
gentoo-fefe285c0cc24ced261b92a7aea8b6ace90fb030.zip
net-p2p/syncthing: bump to 0.14.51
Also migrate from versionator to eapi7-ver. Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/syncthing/Manifest1
-rw-r--r--net-p2p/syncthing/syncthing-0.14.51.ebuild123
2 files changed, 124 insertions, 0 deletions
diff --git a/net-p2p/syncthing/Manifest b/net-p2p/syncthing/Manifest
index a709f42dafbc..9df8af58f216 100644
--- a/net-p2p/syncthing/Manifest
+++ b/net-p2p/syncthing/Manifest
@@ -2,3 +2,4 @@ DIST syncthing-0.14.38.tar.gz 8246629 BLAKE2B 93c01750fedd57cc07bffa14fe65d98fc1
DIST syncthing-0.14.46.tar.gz 10200015 BLAKE2B 679b82af8ee5dad769ef01b77d0d3545d953ec2f2889faa129c433863094f431bf3e44a633109d944cbcaba6486a8b51257557eddfc20a2fb3f0cd8a77861b96 SHA512 ebf8491d1ac1dda90df35b8a9dafb808a9171d4a8083f0f24ac1c9b3aa8d2baac6cef61c5cd897a88c3fb93b114d79a31a341168859f091ed2cdef529321178c
DIST syncthing-0.14.47.tar.gz 10278343 BLAKE2B 8aace6ae059af3317a4f1aabfc06ff21140168428fa5a808dbb3aacbb27fdbfbe56ff910124b5b4c5b54637d444178ddc31492a59ec0bbd7fa4012a2e59ce997 SHA512 16718528fd4c618ea0e0eab1971405870d72ac60d391c27a06313a6ce9b9d023301eac052cfc00aab51e2b1f7c65800becfb822c5bca2d467fcb267b77ba55a9
DIST syncthing-0.14.49.tar.gz 10952008 BLAKE2B a5c5b59720585a6a444d4c0a25c22639263330c1a1987471149773b257a3a0975428c3d63885f567fefbeb7cdf690f0a7ac3296448a2ca070d8ce53e3d657879 SHA512 7a9974e0d45582c5f184165456ea8fcaca0f7ba07a01b9f8eb2de1e1f0410ca36dc978ddde9c725a2b9d08bae8286fc2ce67595a0e510cbfe22fde9cdd9fc694
+DIST syncthing-0.14.51.tar.gz 10970620 BLAKE2B ba41debaddf217069b47901d0c43f163ff0ae3ca4aadb8689401195cfc9f11a3ed641d2d96a590821adac62d12d0ff83df26a4a336ca09476d755b8230a63c87 SHA512 d670b1df341c8da95d38170e03b40deb19dfcdf0c0df9b4630c74b4fcc979bd9a863c0ca0510e28739bac14b1aad51ce40abe695765186acad78ea0d7eb3a20c
diff --git a/net-p2p/syncthing/syncthing-0.14.51.ebuild b/net-p2p/syncthing/syncthing-0.14.51.ebuild
new file mode 100644
index 000000000000..ada15a2f82f9
--- /dev/null
+++ b/net-p2p/syncthing/syncthing-0.14.51.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/${PN}/${PN}"
+
+inherit golang-vcs-snapshot systemd user eapi7-ver
+
+DESCRIPTION="Open Source Continuous File Synchronization"
+HOMEPAGE="https://syncthing.net"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="selinux tools"
+
+RDEPEND="selinux? ( sec-policy/selinux-syncthing )"
+
+DOCS=( README.md AUTHORS CONTRIBUTING.md )
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+
+ if use tools ; then
+ # separate user for the relay server
+ enewgroup strelaysrv
+ enewuser strelaysrv -1 -1 /var/lib/strelaysrv strelaysrv
+ # and his home folder
+ keepdir /var/lib/strelaysrv
+ fowners strelaysrv:strelaysrv /var/lib/strelaysrv
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i \
+ 's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/strelaysrv|' \
+ src/${EGO_PN}/cmd/strelaysrv/etc/linux-systemd/strelaysrv.service \
+ || die
+}
+
+src_compile() {
+ export GOPATH="${S}:$(get_golibdir_gopath)"
+ cd src/${EGO_PN} || die
+ go run build.go -version "v${PV}" -no-upgrade install \
+ $(usex tools "all" "") || die "build failed"
+}
+
+src_test() {
+ cd src/${EGO_PN} || die
+ go run build.go test || die "test failed"
+}
+
+src_install() {
+ pushd src/${EGO_PN} >& /dev/null || die
+ doman man/*.[157]
+ einstalldocs
+
+ dobin bin/syncthing
+ if use tools ; then
+ exeinto /usr/libexec/syncthing
+ local exe
+ for exe in bin/* ; do
+ [[ "${exe}" == "bin/syncthing" ]] || doexe "${exe}"
+ done
+ fi
+ popd >& /dev/null || die
+
+ # openrc and systemd service files
+ systemd_dounit src/${EGO_PN}/etc/linux-systemd/system/${PN}{@,-resume}.service
+ systemd_douserunit src/${EGO_PN}/etc/linux-systemd/user/${PN}.service
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+
+ keepdir /var/{lib,log}/${PN}
+ fowners ${PN}:${PN} /var/{lib,log}/${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ if use tools ; then
+ # openrc and systemd service files
+ systemd_dounit src/${EGO_PN}/cmd/strelaysrv/etc/linux-systemd/strelaysrv.service
+ newconfd "${FILESDIR}/strelaysrv.confd" strelaysrv
+ newinitd "${FILESDIR}/strelaysrv.initd" strelaysrv
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/strelaysrv.logrotate" strelaysrv
+ fi
+}
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 2) -gt \
+ $(ver_cut 2 ${v}) ]]; then
+ ewarn "Version ${PV} is not protocol-compatible with version" \
+ "0.$(($(ver_cut 2) - 1)).x or lower."
+ ewarn "Make sure all your devices are running at least version" \
+ "0.$(ver_cut 2).0."
+ fi
+ ewarn "Syncthing OpenRC init script now uses the upstream default of"
+ ewarn ""
+ ewarn " /var/lib/${PN}/.config/${PN}"
+ ewarn ""
+ ewarn "as its configuration directory. Please set SYNCTHING_HOMEDIR"
+ ewarn "to /var/lib/${PN} in /etc/conf.d/${PN} if you wish to continue"
+ ewarn "using the old Gentoo default. Systemd users are not affected."
+ done
+
+ # check if user syncthing-relaysrv exists
+ # if yes, warn that it has been moved to strelaysrv
+ if [[ -n "$(egetent passwd syncthing-relaysrv 2>/dev/null)" ]]; then
+ ewarn
+ ewarn "The user and group for the relay server have been changed"
+ ewarn "from syncthing-relaysrv to strelaysrv"
+ ewarn "The old user and group are not deleted automatically. Delete them by running:"
+ ewarn " userdel -r syncthing-relaysrv"
+ ewarn " groupdel syncthing-relaysrv"
+ fi
+}