summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGioacchino Mazzurco <gio@eigenlab.org>2021-07-20 11:06:38 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-08-07 01:50:42 -0400
commitff5e87afa1e6030f4bfd2ca30e198bd728a13fda (patch)
treefd0da1af98eb7ed9efe3dcaaf54d526a4af94f4e /net-p2p
parentdev-util/cutter: drop 1.12.0 (diff)
downloadgentoo-ff5e87afa1e6030f4bfd2ca30e198bd728a13fda.tar.gz
gentoo-ff5e87afa1e6030f4bfd2ca30e198bd728a13fda.tar.bz2
gentoo-ff5e87afa1e6030f4bfd2ca30e198bd728a13fda.zip
net-p2p/retroshare: 0.6.6 version bump
Fixes a bunch of bugs fixed upstream in newer version and disabling components that are been obsoleted upstream in older versions Modernize 0.6.6 ebuild after ionenwks suggestions Bug: https://bugs.gentoo.org/779838 Bug: https://bugs.gentoo.org/798048 Bug: https://bugs.gentoo.org/798099 Closes: https://bugs.gentoo.org/785964 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Gioacchino Mazzurco <gio@altermundi.net> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/retroshare/Manifest1
-rw-r--r--net-p2p/retroshare/files/retroshare-0.6.6-fix-cxx17-compilation.patch79
-rw-r--r--net-p2p/retroshare/metadata.xml11
-rw-r--r--net-p2p/retroshare/retroshare-0.6.6.ebuild122
4 files changed, 209 insertions, 4 deletions
diff --git a/net-p2p/retroshare/Manifest b/net-p2p/retroshare/Manifest
index b3ae51167ebc..e636d71484b3 100644
--- a/net-p2p/retroshare/Manifest
+++ b/net-p2p/retroshare/Manifest
@@ -1 +1,2 @@
DIST retroshare-0.6.5.tar.gz 29377995 BLAKE2B 3a8909227080702e42e59b42301e873d4ece806e014a959080a3ae9df7d11564a6e6d915087a9ddd6d5c66d1e5c43895fa24dea8c0042fdce391c384a54182ee SHA512 a65fefb6baff42a81880a401c9005f73ac8180a247dd992a350f9bf5bac366ee6e809bf93cbbc31e80646156147a1d434306dadfbed1f69879ab61cfae3fddeb
+DIST retroshare-0.6.6.tar.gz 24140207 BLAKE2B 1328f2d36f6bc2d1123dd915698f2778e771e36089d8fd8d9ec44d1a8bfa0f56c625b73f62811936e4cee5dd1eca797f9fdf16fdb8defd66706294abc4dde419 SHA512 23ed7c633426caa910a5ae6f04cfd33c523ecaedae1e4044981706420622aadd67ba2772ffd17c9cc1c6193fad508837a31fdcfabe2aab309b8b4302335ede4d
diff --git a/net-p2p/retroshare/files/retroshare-0.6.6-fix-cxx17-compilation.patch b/net-p2p/retroshare/files/retroshare-0.6.6-fix-cxx17-compilation.patch
new file mode 100644
index 000000000000..c756937c1657
--- /dev/null
+++ b/net-p2p/retroshare/files/retroshare-0.6.6-fix-cxx17-compilation.patch
@@ -0,0 +1,79 @@
+From 8bed99cc9f3763269b6b1aada45a43c9993d7b80 Mon Sep 17 00:00:00 2001
+From: Gioacchino Mazzurco <gio@eigenlab.org>
+Date: Fri, 6 Aug 2021 12:15:34 +0200
+Subject: [PATCH] Fix compilation with C++17
+
+---
+ libretroshare/src/util/rsdir.cc | 42 +++++++++++++++++----------------
+ 1 file changed, 22 insertions(+), 20 deletions(-)
+
+diff --git a/libretroshare/src/util/rsdir.cc b/libretroshare/src/util/rsdir.cc
+index 8556b8198..1a6375297 100644
+--- a/libretroshare/src/util/rsdir.cc
++++ b/libretroshare/src/util/rsdir.cc
+@@ -4,8 +4,8 @@
+ * libretroshare: retroshare core library *
+ * *
+ * Copyright (C) 2004-2007 Robert Fernie <retroshare@lunamutt.com> *
+- * Copyright (C) 2020 Gioacchino Mazzurco <gio@eigenlab.org> *
+- * Copyright (C) 2020 AsociaciĆ³n Civil Altermundi <info@altermundi.net> *
++ * Copyright (C) 2020-2021 Gioacchino Mazzurco <gio@eigenlab.org> *
++ * Copyright (C) 2020-2021 AsociaciĆ³n Civil Altermundi <info@altermundi.net> *
+ * *
+ * This program is free software: you can redistribute it and/or modify *
+ * it under the terms of the GNU Lesser General Public License as *
+@@ -64,6 +64,26 @@
+ * #define RSDIR_DEBUG 1
+ ****/
+
++#if __cplusplus < 201703L
++bool std::filesystem::create_directories(const std::string& path)
++{
++ for( std::string::size_type lastIndex = 0; lastIndex < std::string::npos;
++ lastIndex = path.find('/', lastIndex) )
++ {
++ std::string&& curDir = path.substr(0, ++lastIndex);
++ if(!RsDirUtil::checkCreateDirectory(curDir))
++ {
++ RsErr() << __PRETTY_FUNCTION__ << " failure creating: " << curDir
++ << " of: " << path << std::endl;
++ return false;
++ }
++ }
++ return true;
++}
++#else
++# include <filesystem>
++#endif // __cplusplus < 201703L
++
+ std::string RsDirUtil::getTopDir(const std::string& dir)
+ {
+ std::string top;
+@@ -528,24 +548,6 @@ bool RsDirUtil::checkCreateDirectory(const std::string& dir)
+ return true;
+ }
+
+-#if __cplusplus < 201703L
+-bool std::filesystem::create_directories(const std::string& path)
+-{
+- for( std::string::size_type lastIndex = 0; lastIndex < std::string::npos;
+- lastIndex = path.find('/', lastIndex) )
+- {
+- std::string&& curDir = path.substr(0, ++lastIndex);
+- if(!RsDirUtil::checkCreateDirectory(curDir))
+- {
+- RsErr() << __PRETTY_FUNCTION__ << " failure creating: " << curDir
+- << " of: " << path << std::endl;
+- return false;
+- }
+- }
+- return true;
+-}
+-#endif // __cplusplus < 201703L
+-
+ std::string RsDirUtil::removeSymLinks(const std::string& path)
+ {
+ #if defined(WINDOWS_SYS) || defined(__APPLE__) || defined(__ANDROID__)
+--
+2.31.1
+
diff --git a/net-p2p/retroshare/metadata.xml b/net-p2p/retroshare/metadata.xml
index a2e56631bdb1..1d61cb0cbd88 100644
--- a/net-p2p/retroshare/metadata.xml
+++ b/net-p2p/retroshare/metadata.xml
@@ -18,14 +18,17 @@
RetroShare provides filesharing, chat, mails, forums and channels.
</longdescription>
<use>
- <flag name="cli">Enables the CLI version of RetroShare</flag>
+ <flag name="autologin">Enables potentially insecure autologin capability via <pkg>app-crypt/libsecret</pkg></flag>
+ <flag name="cli">Enables terminal login support for retroshare-service</flag>
<flag name="control-socket">Enables API via Unix socket support</flag>
- <flag name="gnome-keyring">Enables potentially insecure autologin capability via Gnome Keyring</flag>
+ <flag name="gnome-keyring">Enables potentially insecure autologin capability via <pkg>gnome-base/gnome-keyring</pkg></flag>
<flag name="jsonapi">Enables the new RetroShare JSON API</flag>
- <flag name="service">Enables the new RetroShare service controllable only through JSON API</flag>
+ <flag name="libupnp">Enables UPnP port forwarding via <pkg>net-libs/libupnp</pkg></flag>
+ <flag name="miniupnp">Enables UPnP port forwarding via <pkg>net-libs/miniupnpc</pkg></flag>
+ <flag name="service">Enables the new RetroShare service</flag>
<flag name="sqlcipher">Enables GXS database encryption via SQLCipher</flag>
<flag name="webui">Enables Web interface and API support</flag>
- <flag name="xapian">Enables GXS content indexing and search through Xapian</flag>
+ <flag name="xapian">Enables GXS content indexing and search via <pkg>dev-libs/xapian</pkg></flag>
</use>
<upstream>
<bugs-to>https://github.com/RetroShare/RetroShare/issues</bugs-to>
diff --git a/net-p2p/retroshare/retroshare-0.6.6.ebuild b/net-p2p/retroshare/retroshare-0.6.6.ebuild
new file mode 100644
index 000000000000..d331568ada6f
--- /dev/null
+++ b/net-p2p/retroshare/retroshare-0.6.6.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop qmake-utils xdg
+
+DESCRIPTION="P2P private sharing application"
+HOMEPAGE="https://retroshare.cc"
+SRC_URI="http://download.opensuse.org/repositories/network:/retroshare/Debian_Testing/retroshare-common_${PV}.orig.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/RetroShare"
+
+LICENSE="AGPL-3 Apache-2.0 CC-BY-SA-4.0 GPL-2 GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="autologin cli +gui +jsonapi libupnp +miniupnp +service +sqlcipher"
+
+REQUIRED_USE="
+ || ( gui service )
+ ?? ( libupnp miniupnp )
+ service? ( || ( cli jsonapi ) )"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-libs/openssl:0=
+ >=dev-libs/rapidjson-1.1.0
+ sys-libs/zlib
+ autologin? ( app-crypt/libsecret )
+ gui? (
+ dev-qt/qtcore:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtscript:5
+ dev-qt/qtxml:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ )
+ libupnp? ( net-libs/libupnp:= )
+ miniupnp? ( net-libs/miniupnpc:= )
+ service? ( dev-qt/qtcore:5 )
+ sqlcipher? ( dev-db/sqlcipher )
+ !sqlcipher? ( dev-db/sqlite:3 )"
+
+DEPEND="${RDEPEND}
+ dev-qt/qtcore:5
+ gui? ( dev-qt/designer:5 )"
+
+BDEPEND="dev-util/cmake
+ virtual/pkgconfig
+ jsonapi? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}/${P}-fix-cxx17-compilation.patch" )
+
+src_configure() {
+ local qconfigs=(
+ $(usex cli '' 'no_')rs_service_terminal_login
+ $(usex autologin '' 'no_')rs_autologin
+ $(usex gui '' 'no_')retroshare_gui
+ $(usex jsonapi '' 'no_')rs_jsonapi
+ $(usex service '' 'no_')retroshare_service
+ $(usex sqlcipher '' 'no_')sqlcipher
+ )
+
+ local qupnplibs="none"
+ use miniupnp && qupnplibs="miniupnpc"
+ use libupnp && qupnplibs="upnp ixml"
+
+ eqmake5 CONFIG+="${qconfigs[*]}" \
+ RS_MAJOR_VERSION=$(ver_cut 1) RS_MINOR_VERSION=$(ver_cut 2) \
+ RS_MINI_VERSION=$(ver_cut 3) RS_EXTRA_VERSION="-gentoo-${PR}" \
+ RS_UPNP_LIB="${qupnplibs}"
+}
+
+src_install() {
+ use gui && dobin retroshare-gui/src/retroshare
+ use service && dobin retroshare-service/src/retroshare-service
+
+ insinto /usr/share/retroshare
+ doins libbitdht/src/bitdht/bdboot.txt
+
+ dodoc README.asciidoc
+
+ if use gui; then
+ make_desktop_entry retroshare
+
+ for i in 24 48 64 128 ; do
+ doicon -s ${i} "data/${i}x${i}/apps/retroshare.png"
+ done
+ fi
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+
+ if ! use sqlcipher && ! has_version "net-p2p/retroshare[-sqlcipher]"; then
+ ewarn "You have disabled GXS database encryption, ${PN} will use SQLite"
+ ewarn "instead of SQLCipher for GXS databases."
+ ewarn "Builds using SQLite and builds using SQLCipher have incompatible"
+ ewarn "database format, so you will need to manually delete GXS"
+ ewarn "database (loosing all your GXS data and identities) when you"
+ ewarn "toggle sqlcipher USE flag."
+ fi
+
+ if [[ ${REPLACING_VERSIONS} ]]; then
+ if ver_test ${REPLACING_VERSIONS} -lt 0.6; then
+ ewarn "You are upgrading from Retroshare 0.5.* to ${PV}"
+ ewarn "Version 0.6.* is backward-incompatible with 0.5 branch"
+ ewarn "and clients with 0.6.* can not connect to clients that have 0.5.*"
+ ewarn "It's recommended to drop all your configuration and either"
+ ewarn "generate a new certificate or import existing from a backup"
+ break
+ fi
+ if ver_test ${REPLACING_VERSIONS} -ge 0.6.0 && ver_test ${REPLACING_VERSIONS} -lt 0.6.4; then
+ elog "Main executable has been renamed upstream from RetroShare06 to retroshare"
+ break
+ fi
+ fi
+}