summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-print/apsfilter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-print/apsfilter')
-rw-r--r--net-print/apsfilter/Manifest2
-rw-r--r--net-print/apsfilter/apsfilter-7.2.5.ebuild40
-rw-r--r--net-print/apsfilter/apsfilter-7.2.8.ebuild43
-rw-r--r--net-print/apsfilter/metadata.xml5
4 files changed, 90 insertions, 0 deletions
diff --git a/net-print/apsfilter/Manifest b/net-print/apsfilter/Manifest
new file mode 100644
index 000000000000..ad89e86ed802
--- /dev/null
+++ b/net-print/apsfilter/Manifest
@@ -0,0 +1,2 @@
+DIST apsfilter-7.2.5.tar.bz2 309436 SHA256 06fcd09080122c42d8ae7435f4065ea104b81268703498446e8e49f176ce949a
+DIST apsfilter-7.2.8.tar.bz2 310587 SHA256 9fb814b1d08725e318f200b06ab722eb72b218b56beb17d7ad3ab7bae835e2e9 SHA512 ca07e7eb620a95b08fb912e899520d5ff85613eb3d1f712e1d38a66cf5b84516dbb35e3e40ef75ac10d1e717cfc2f49930a0f0873fee451d495c8ae572072012 WHIRLPOOL 89196b120338cf3665d95768ce11e8357675f9dd89fa8f34e589dbf083c2646b926d2082f1bca63eb5cefe6e84861d4ef9fc26f8952c9e3cbc21601941bf6297
diff --git a/net-print/apsfilter/apsfilter-7.2.5.ebuild b/net-print/apsfilter/apsfilter-7.2.5.ebuild
new file mode 100644
index 000000000000..7727e55fe55e
--- /dev/null
+++ b/net-print/apsfilter/apsfilter-7.2.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Apsfilter Prints So Fine, It Leads To Extraordinary Results"
+HOMEPAGE="http://www.apsfilter.org"
+KEYWORDS="x86 ppc alpha sparc"
+IUSE="cups"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND="|| ( net-print/cups net-print/lprng )
+ app-text/ghostscript-gpl
+ >=app-text/psutils-1.17
+ >=media-gfx/imagemagick-5.4.5
+ >=app-text/a2ps-4.13b-r4
+ virtual/awk
+ virtual/mta"
+DEPEND="${RDEPEND}"
+
+SRC_URI="http://www.apsfilter.org/download/${P}.tar.bz2"
+S=${WORKDIR}/apsfilter
+
+src_compile() {
+ # assume thet lprng is installed if cups isn't USEd
+ use cups && \
+ myconf="--with-printcap=/etc/cups/printcap --with-spooldir=/var/spool/cups" || \
+ myconf="--with-printcap=/etc/lprng/printcap"
+ ./configure --prefix=/usr ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+ dosym /usr/share/apsfilter/SETUP /usr/bin/apsfilter
+ use cups && \
+ dosym /etc/cups/printcap /etc/printcap || \
+ dosym /etc/lprng/printcap /etc/printcap
+}
diff --git a/net-print/apsfilter/apsfilter-7.2.8.ebuild b/net-print/apsfilter/apsfilter-7.2.8.ebuild
new file mode 100644
index 000000000000..86bfaee35f11
--- /dev/null
+++ b/net-print/apsfilter/apsfilter-7.2.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Apsfilter Prints So Fine, It Leads To Extraordinary Results"
+HOMEPAGE="http://www.apsfilter.org"
+SRC_URI="http://www.apsfilter.org/download/${P}.tar.bz2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="cups"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND="|| ( net-print/cups net-print/lprng )
+ app-text/ghostscript-gpl
+ >=app-text/psutils-1.17
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ >=app-text/a2ps-4.13b-r4
+ virtual/awk
+ virtual/mta"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ # assume thet lprng is installed if cups isn't USEd
+ use cups && \
+ myconf="--with-printcap=/etc/cups/printcap --with-spooldir=/var/spool/cups" || \
+ myconf="--with-printcap=/etc/lprng/printcap"
+
+ # econf doesn't work here :(
+ ./configure --prefix=/usr --mandir=/usr/share/man \
+ --docdir=/usr/share/doc/${PF} --sysconfdir=/etc ${myconf} || die
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dosym /usr/share/apsfilter/SETUP /usr/bin/apsfilter
+ use cups && \
+ dosym /etc/cups/printcap /etc/printcap || \
+ dosym /etc/lprng/printcap /etc/printcap
+}
diff --git a/net-print/apsfilter/metadata.xml b/net-print/apsfilter/metadata.xml
new file mode 100644
index 000000000000..1fa0ca569505
--- /dev/null
+++ b/net-print/apsfilter/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>printing</herd>
+</pkgmetadata>