summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-02-11 23:38:12 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-02-11 23:39:28 +0100
commit2143eec4103aafa440e4fe8d5e9c646b3990db6b (patch)
tree7bc54001c542e9c115886c37239c7084420a7207 /net-print/cups-filters/cups-filters-9999.ebuild
parentsci-mathematics/diagrtb: EAPI 6 (diff)
downloadgentoo-2143eec4103aafa440e4fe8d5e9c646b3990db6b.tar.gz
gentoo-2143eec4103aafa440e4fe8d5e9c646b3990db6b.tar.bz2
gentoo-2143eec4103aafa440e4fe8d5e9c646b3990db6b.zip
net-print/cups-filters: Update live ebuild, add foomatic-rip compatibility symlink, bug 501466
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-print/cups-filters/cups-filters-9999.ebuild')
-rw-r--r--net-print/cups-filters/cups-filters-9999.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/net-print/cups-filters/cups-filters-9999.ebuild b/net-print/cups-filters/cups-filters-9999.ebuild
index 36d27dbf553b..b60a155e41fa 100644
--- a/net-print/cups-filters/cups-filters-9999.ebuild
+++ b/net-print/cups-filters/cups-filters-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -6,10 +6,10 @@ EAPI=6
GENTOO_DEPEND_ON_PERL=no
-inherit eutils perl-module autotools systemd
+inherit eutils perl-module systemd
if [[ "${PV}" == "9999" ]] ; then
- inherit bzr
+ inherit bzr autotools
EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
else
SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
@@ -20,10 +20,9 @@ HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/pdf_as_standard_print_jo
LICENSE="MIT GPL-2"
SLOT="0"
-IUSE="dbus +foomatic jpeg ldap perl png +postscript static-libs tiff zeroconf"
+IUSE="dbus +foomatic jpeg ldap pdf perl png +postscript static-libs tiff zeroconf"
RDEPEND="
- app-text/mupdf
postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
>=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils,xpdf-headers(+)]
>=app-text/qpdf-3.0.2:=
@@ -39,6 +38,7 @@ RDEPEND="
foomatic? ( !net-print/foomatic-filters )
jpeg? ( virtual/jpeg:0 )
ldap? ( net-nds/openldap )
+ pdf? ( app-text/mupdf )
perl? ( dev-lang/perl:= )
png? ( media-libs/libpng:0= )
tiff? ( media-libs/tiff:0 )
@@ -50,7 +50,7 @@ DEPEND="${RDEPEND}
src_prepare() {
default
- eautoreconf
+ [[ "${PV}" == "9999" ]] && eautoreconf
}
src_configure() {
@@ -63,6 +63,7 @@ src_configure() {
$(use_enable static-libs static) \
$(use_enable foomatic) \
$(use_enable ldap) \
+ $(use_enable pdf mutool) \
$(use_enable postscript ghostscript) \
$(use_enable postscript ijs) \
--with-fontdir="fonts/conf.avail" \
@@ -90,6 +91,11 @@ src_compile() {
src_install() {
default
+ if use foomatic; then
+ # workaround: some printer drivers still require this, bug 501466
+ dosym /usr/bin/foomatic-rip /usr/libexec/cups/filter/foomatic-rip
+ fi
+
if use perl; then
pushd "${S}/scripting/perl" > /dev/null
perl-module_src_install
@@ -105,7 +111,7 @@ src_install() {
prune_libtool_files --all
- cp "${FILESDIR}"/cups-browsed.init.d "${T}"/cups-browsed || die
+ cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die
if ! use zeroconf ; then
sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die