summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Neumärker <xdch47@posteo.de>2019-08-15 17:18:47 +0200
committerDaniel Pielmeier <billie@gentoo.org>2019-08-15 18:03:14 +0200
commit543eb1bab06212a69a74408d13ef38bd72c6f477 (patch)
treeb7c0db290ba4171b6c0b210bed510809908481a9 /net-print/hplip-plugin/hplip-plugin-3.19.6.ebuild
parentx11-themes/fvwm_sounds: Version the distfile (diff)
downloadgentoo-543eb1bab06212a69a74408d13ef38bd72c6f477.tar.gz
gentoo-543eb1bab06212a69a74408d13ef38bd72c6f477.tar.bz2
gentoo-543eb1bab06212a69a74408d13ef38bd72c6f477.zip
net-print/hplip-plugin: bump to 3.19.6
Closes: https://bugs.gentoo.org/684428 Thanks @stefson Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Felix Neumärker <xdch47@posteo.de> Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'net-print/hplip-plugin/hplip-plugin-3.19.6.ebuild')
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.19.6.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/hplip-plugin-3.19.6.ebuild b/net-print/hplip-plugin/hplip-plugin-3.19.6.ebuild
new file mode 100644
index 000000000000..042e62f4b98f
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.19.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/libusb:0
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PRESTRIPPED="
+ /usr/share/hplip/fax/plugins/fax_marvell.so
+ /usr/share/hplip/prnt/plugins/hbpl1.so
+ /usr/share/hplip/prnt/plugins/lj.so
+ /usr/share/hplip/scan/plugins/bb_escl.so
+ /usr/share/hplip/scan/plugins/bb_marvell.so
+ /usr/share/hplip/scan/plugins/bb_soapht.so
+ /usr/share/hplip/scan/plugins/bb_soap.so
+"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_install() {
+ local hplip_arch
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}