summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-06-27 21:24:16 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-06-27 21:24:16 +0200
commitd64acf53dbaea549f68daa42913b71babe95af2a (patch)
treef9783e85832f85787abb0b191d9566db48118ee5 /net-print/hplip-plugin
parentnet-analyzer/authforce: remove old (EAPI4) (diff)
downloadgentoo-d64acf53dbaea549f68daa42913b71babe95af2a.tar.gz
gentoo-d64acf53dbaea549f68daa42913b71babe95af2a.tar.bz2
gentoo-d64acf53dbaea549f68daa42913b71babe95af2a.zip
net-print/hplip-plugin: Version bump to 3.19.5
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'net-print/hplip-plugin')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.19.5.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index a24edd928188..3301f0eee444 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,3 +1,4 @@
DIST hplip-3.18.12-plugin.run 10486821 BLAKE2B e48940b1b5fe94dc216383b63bee7807bce9ad265b7c454c201c0ed22ec1964e6c5adf653c3c230789c042cffaaf50bd604bae6f66f407a85f98248934307158 SHA512 82b90aa8245f787e088a1bebfa7892a7f2b97fd04b3702c46eed27306640e562aeec63b4b5b45c24943abe4672f2627d1821bdcdf58a5c1ac4e1d06c7270535f
DIST hplip-3.18.6-plugin.run 2065663 BLAKE2B 501a37dd504250225ddad9712259e0e1b564aa034e433f24d277c5609fa95580417da1a0ae040a4624ff48806a3b34ec56ff31aed843e9f0f0b68b304d2ebd9e SHA512 7b5eb2f43dd014df25ccd9e72dd7efc069db47921f2de650b2ff993dbee60056063edeee6593be7d35019212daf623fff9696b13508a808db92128f5c81bde76
DIST hplip-3.19.3-plugin.run 11516959 BLAKE2B 858b5973b6bdceddfed25227ffd0e4f7871f1fe01bd080c88a0f28a72e6c7cf8d0aa35c7c55139a5844f80d2dfa3f9862f61cf9564df8dcd65370ee85882c729 SHA512 c0305926bc610f665cef0c114b64db7861da9a6159dff46a3b600ae440f8b225c7b6f774a6549808aa5f11df78970a799bce763922b52aaf0473210e198d382d
+DIST hplip-3.19.5-plugin.run 11516444 BLAKE2B c43aaa4dd3c4a8acf91b2746733e5237ef0ff39c3e6180530e0fcd34d5319e603c23806a3b010d70399772abc5564095fe2696c823d80eedf892b87acd170d23 SHA512 8c933f175bf0b91a8f30d6b362f8a487a964dd3304c859d78c9505357088047fdcacb99230f8696071269d5950f681adc0e4051617f1051be254fd6bed704cb9
diff --git a/net-print/hplip-plugin/hplip-plugin-3.19.5.ebuild b/net-print/hplip-plugin/hplip-plugin-3.19.5.ebuild
new file mode 100644
index 000000000000..7714ffa082db
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.19.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit udev unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+#SRC_URI="http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-${PV}-plugin.run"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PRESTRIPPED="
+ /usr/share/hplip/fax/plugins/fax_marvell.so
+ /usr/share/hplip/prnt/plugins/hbpl1.so
+ /usr/share/hplip/prnt/plugins/lj.so
+ /usr/share/hplip/scan/plugins/bb_escl.so
+ /usr/share/hplip/scan/plugins/bb_marvell.so
+ /usr/share/hplip/scan/plugins/bb_soapht.so
+ /usr/share/hplip/scan/plugins/bb_soap.so
+"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_makeself "hplip-${PV}-plugin.run"
+}
+
+src_install() {
+ local hplip_arch=$(use amd64 && echo 'x86_64' || echo 'x86_32')
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ mkdir -p "${ED}/var/lib/hp/"
+ cat >> "${ED}/var/lib/hp/hplip.state" <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}