summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-print/pykota/pykota-1.26.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-print/pykota/pykota-1.26.ebuild')
-rw-r--r--net-print/pykota/pykota-1.26.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/net-print/pykota/pykota-1.26.ebuild b/net-print/pykota/pykota-1.26.ebuild
new file mode 100644
index 000000000000..1739a9cd936f
--- /dev/null
+++ b/net-print/pykota/pykota-1.26.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH='sqlite?'
+
+inherit distutils
+
+DESCRIPTION="Flexible print quota and accounting package for use with CUPS and lpd"
+HOMEPAGE="http://www.pykota.com"
+SRC_URI="http://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap mysql postgres snmp sqlite xml"
+
+DEPEND="dev-lang/python
+ dev-python/egenix-mx-base
+ net-print/pkpgcounter
+ dev-python/chardet
+ dev-python/pkipplib
+ ldap? ( dev-python/python-ldap )
+ mysql? ( dev-python/mysql-python )
+ postgres? ( dev-db/postgresql[server] dev-python/pygresql )
+ snmp? ( net-analyzer/net-snmp =dev-python/pysnmp-3.4* )
+ xml? ( dev-python/jaxml )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}"
+
+DOCS="README TODO SECURITY CREDITS FAQ"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ distutils_src_prepare
+
+ sed -i -e 's:from pysqlite2 import dbapi2:import sqlite3:' \
+ pykota/storages/sqlitestorage.py || die
+}
+
+src_install() {
+ dodir /etc/${PN} || die
+ distutils_src_install
+
+ # cups backend ----------------------------------------------
+
+ dodir $(cups-config --serverbin)/backend || die
+ dosym /usr/share/pykota/cupspykota $(cups-config --serverbin)/backend/cupspykota || die
+
+ # extra docs: inits -----------------------------------------
+
+ init_dir="/usr/share/doc/${PF}/initscripts"
+ insinto "${init_dir}"
+ doins -r initscripts/* || die
+
+ # Fixes permissions for bug 155865
+ chmod 700 "${D}"/usr/share/pykota/cupspykota
+
+ for doc in ${DOCS}; do
+ rm "${D}"/usr/share/doc/${PN}/${doc} || die
+ done
+ rm "${D}"/usr/share/doc/${PN}/{LICENSE,COPYING} || die
+ mv "${D}"/usr/share/doc/${PN}/* "${D}"/usr/share/doc/${PF}/ || die
+ rmdir "${D}"/usr/share/doc/${PN} || die
+}