summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2018-08-17 21:45:18 +0200
committerDaniel Pielmeier <billie@gentoo.org>2018-08-17 21:45:18 +0200
commit0deeb73ca3141d757ea551eaae95a9b5bafcc20e (patch)
treeeb1aa159144924db618b1ed1f32e8d10df123702 /net-print
parentapp-admin/conky: Fix bug #663886. (diff)
downloadgentoo-0deeb73ca3141d757ea551eaae95a9b5bafcc20e.tar.gz
gentoo-0deeb73ca3141d757ea551eaae95a9b5bafcc20e.tar.bz2
gentoo-0deeb73ca3141d757ea551eaae95a9b5bafcc20e.zip
net-print/hplip: Version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip/Manifest1
-rw-r--r--net-print/hplip/hplip-3.18.7.ebuild268
2 files changed, 269 insertions, 0 deletions
diff --git a/net-print/hplip/Manifest b/net-print/hplip/Manifest
index 5e30d32c0079..ed4755c58ec1 100644
--- a/net-print/hplip/Manifest
+++ b/net-print/hplip/Manifest
@@ -2,3 +2,4 @@ DIST hplip-3.17.10.tar.gz 23878364 BLAKE2B 0165bcb00159572a16277624db0de4b2ca842
DIST hplip-3.17.9-patches-1.tar.xz 8484 BLAKE2B 3a1f25d0554af5597266eb5ed3ff9f594560671784a89ade6246e9287661bf17fa16c555391c3f685e59aec8c548560911065a9c4188906c2f00c755f503fe49 SHA512 125f9cfd1c3cad662ce33954b8ab9ab1898368b449c4ad78dfe99f29de8025183773272b9865cd22b976a30c502e38254ce0ac59d685299dff7f9314927d546a
DIST hplip-3.18.3-patches-2.tar.xz 8936 BLAKE2B 58c17f3b6332de1edd88a3b458f1e9f856bc917842f62eee0808469ec14ff5793cd33c7a2ba30593eba624e58c12a6d426fa43a7d375d6ac50b985b895a85b4c SHA512 cbafcd9616f9c86318007b703325d3429ed0698c3fc9d3eddd422e4cd7a16c77320ac168bfa01b5874213e1740cfaae1867d31c3cf96cd57573ad33651a674ed
DIST hplip-3.18.6.tar.gz 22590564 BLAKE2B edbc80120bb332de9848e528095839b8f3496404ae83482a17bb8bd196c30dd8d3fca4d3dbb60c048bfbeeddd4384b4d7844798dad993eaf52d5418a9391b4ad SHA512 deb4e6e1c7e9ea7452967f7d7d7fd93e92eb59406b4978bb9b874db93bc5022b25aab012a7420ac3e991259032bc7cb749cd924c93a164544e29a4152962184f
+DIST hplip-3.18.7.tar.gz 24302243 BLAKE2B 41db647a5766c0f25f197811c497f6f7b4779a3ffbd06b0bfe8ab0874780bfaf48255d31bbf192c167aed32b32304ce0f84a7beec640fcff1b39eeb13e32ae7a SHA512 bd835824fba0905a828880a088c81cd8e4fdd5e1d26c714678ada87d7c5a80e52ca7f9df2380d74f66177abe8fa20959b0da015e02a4da579169d2d248ff960f
diff --git a/net-print/hplip/hplip-3.18.7.ebuild b/net-print/hplip/hplip-3.18.7.ebuild
new file mode 100644
index 000000000000..00309e5ab471
--- /dev/null
+++ b/net-print/hplip/hplip-3.18.7.ebuild
@@ -0,0 +1,268 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="threads,xml"
+
+# 14 and 15 spit out a lot of warnings about subdirs
+WANT_AUTOMAKE="1.13"
+
+inherit autotools linux-info python-single-r1 readme.gentoo-r1 udev
+
+DESCRIPTION="HP Linux Imaging and Printing - Print, scan, fax drivers and service tools"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing"
+SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz
+ https://dev.gentoo.org/~billie/distfiles/${PN}-3.18.3-patches-2.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+IUSE="doc fax +hpcups hpijs kde libressl -libusb0 minimal parport policykit qt5 scanner +snmp static-ppds X"
+
+# dependency on dev-python/notify-python dropped due to python 3 incompatibility
+# possible replacement notify2 (https://pypi.org/project/notify2/0.3) not in tree
+
+COMMON_DEPEND="
+ net-print/cups
+ virtual/jpeg:0
+ hpijs? ( net-print/cups-filters[foomatic] )
+ !minimal? (
+ ${PYTHON_DEPS}
+ sys-apps/dbus
+ !libusb0? ( virtual/libusb:1 )
+ libusb0? ( virtual/libusb:0 )
+ scanner? ( media-gfx/sane-backends )
+ snmp? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ net-analyzer/net-snmp
+ )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ app-text/ghostscript-gpl
+ !minimal? (
+ >=dev-python/dbus-python-1.2.0-r1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pygobject:2[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]' 'python3*')
+ fax? ( dev-python/reportlab[${PYTHON_USEDEP}] )
+ kernel_linux? ( virtual/udev )
+ qt5? ( >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_USEDEP}] )
+ scanner? (
+ >=dev-python/reportlab-3.2[${PYTHON_USEDEP}]
+ >=dev-python/pillow-3.1.1[${PYTHON_USEDEP}]
+ X? ( || (
+ kde? ( kde-misc/skanlite )
+ media-gfx/xsane
+ media-gfx/sane-frontends
+ ) )
+ )
+ )
+ policykit? ( sys-auth/polkit )
+"
+
+REQUIRED_USE="!minimal? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${WORKDIR}/patches"
+)
+
+CONFIG_CHECK="~PARPORT ~PPDEV"
+ERROR_PARPORT="Please make sure kernel parallel port support is enabled (PARPORT and PPDEV)."
+
+#DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+For more information on setting up your printer please take
+a look at the hplip section of the gentoo printing guide:
+https://wiki.gentoo.org/wiki/Printing
+
+Any user who wants to print must be in the lp group.
+"
+
+pkg_setup() {
+ use !minimal && python-single-r1_pkg_setup
+
+ use scanner && ! use X && ewarn "You need USE=X for the scanner GUI."
+
+ if ! use hpcups && ! use hpijs ; then
+ ewarn "Installing neither hpcups (USE=-hpcups) nor hpijs (USE=-hpijs) driver,"
+ ewarn "which is probably not what you want."
+ ewarn "You will almost certainly not be able to print."
+ fi
+
+ if use minimal ; then
+ ewarn "Installing driver portions only, make sure you know what you are doing."
+ ewarn "Depending on the USE flags set for hpcups or hpijs the appropiate driver"
+ ewarn "is installed. If both USE flags are set hpijs overrides hpcups."
+ else
+ use parport && linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+
+ if use !minimal ; then
+ python_export EPYTHON PYTHON
+ python_fix_shebang .
+ fi
+
+ # Make desktop files follow the specification
+ # Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=443680
+ # Upstream bug: https://bugs.launchpad.net/hplip/+bug/1080324
+ sed -i -e '/^Categories=/s/Application;//' \
+ -e '/^Encoding=.*/d' hplip.desktop.in || die
+ sed -i -e '/^Categories=/s/Application;//' \
+ -e '/^Version=.*/d' \
+ -e '/^Comment=.*/d' hplip-systray.desktop.in || die
+
+ # Fix for Gentoo bug https://bugs.gentoo.org/show_bug.cgi?id=345725
+ # Upstream bug: https://bugs.launchpad.net/hplip/+bug/880847,
+ # https://bugs.launchpad.net/hplip/+bug/500086
+ local udevdir=$(get_udevdir)
+ sed -i -e "s|/etc/udev|${udevdir}|g" \
+ $(find . -type f -exec grep -l /etc/udev {} +) || die
+
+ # Force recognition of Gentoo distro by hp-check
+ sed -i \
+ -e "s:file('/etc/issue', 'r').read():'Gentoo':" \
+ installer/core_install.py || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf drv_build minimal_build
+
+ if use libusb0 ; then
+ myconf="${myconf} --enable-libusb01_build"
+ else
+ myconf="${myconf} --disable-libusb01_build"
+ fi
+
+ if use hpcups ; then
+ drv_build="$(use_enable hpcups hpcups-install)"
+ if use static-ppds ; then
+ drv_build="${drv_build} --enable-cups-ppd-install"
+ drv_build="${drv_build} --disable-cups-drv-install"
+ else
+ drv_build="${drv_build} --enable-cups-drv-install"
+ drv_build="${drv_build} --disable-cups-ppd-install"
+ fi
+ else
+ drv_build="--disable-hpcups-install"
+ drv_build="${drv_build} --disable-cups-drv-install"
+ drv_build="${drv_build} --disable-cups-ppd-install"
+ fi
+
+ if use hpijs ; then
+ drv_build="${drv_build} $(use_enable hpijs hpijs-install)"
+ if use static-ppds ; then
+ drv_build="${drv_build} --enable-foomatic-ppd-install"
+ drv_build="${drv_build} --disable-foomatic-drv-install"
+ else
+ drv_build="${drv_build} --enable-foomatic-drv-install"
+ drv_build="${drv_build} --disable-foomatic-ppd-install"
+ fi
+ else
+ drv_build="${drv_build} --disable-hpijs-install"
+ drv_build="${drv_build} --disable-foomatic-drv-install"
+ drv_build="${drv_build} --disable-foomatic-ppd-install"
+ fi
+
+ if use minimal ; then
+ if use hpijs ; then
+ minimal_build="--enable-hpijs-only-build"
+ else
+ minimal_build="--disable-hpijs-only-build"
+ fi
+ if use hpcups ; then
+ minimal_build="${minimal_build} --enable-hpcups-only-build"
+ else
+ minimal_build="${minimal_build} --disable-hpcups-only-build"
+ fi
+ fi
+
+ # disable class driver for now
+ econf \
+ --disable-cups11-build \
+ --disable-lite-build \
+ --disable-foomatic-rip-hplip-install \
+ --disable-shadow-build \
+ --disable-qt3 \
+ --disable-qt4 \
+ --disable-udev_sysfs_rules \
+ --with-cupsbackenddir=$(cups-config --serverbin)/backend \
+ --with-cupsfilterdir=$(cups-config --serverbin)/filter \
+ --with-docdir=/usr/share/doc/${PF} \
+ --with-htmldir=/usr/share/doc/${PF}/html \
+ ${myconf} \
+ ${drv_build} \
+ ${minimal_build} \
+ --enable-hpps-install \
+ --disable-class-driver \
+ $(use_enable doc doc-build) \
+ $(use_enable fax fax-build) \
+ $(use_enable !minimal gui-build) \
+ $(use_enable !minimal dbus-build) \
+ $(use_enable parport pp-build) \
+ $(use_enable policykit) \
+ $(use_enable qt5) \
+ $(use_enable scanner scan-build) \
+ $(use_enable snmp network-build)
+
+ # hpijs ppds are created at configure time but are not installed (3.17.11)
+
+ # Use system foomatic-rip for hpijs driver instead of foomatic-rip-hplip
+ # The hpcups driver does not use foomatic-rip
+ #local i
+ #for i in ppd/hpijs/*.ppd.gz ; do
+ # rm -f ${i}.temp || die
+ # gunzip -c ${i} | sed 's/foomatic-rip-hplip/foomatic-rip/g' | \
+ # gzip > ${i}.temp || die
+ # mv ${i}.temp ${i} || die
+ #done
+}
+
+src_install() {
+ # Disable parallel install
+ # Gentoo Bug: https://bugs.gentoo.org/show_bug.cgi?id=578018
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+ # default
+
+ # Installed by sane-backends
+ # Gentoo Bug: https://bugs.gentoo.org/show_bug.cgi?id=201023
+ rm -f "${ED%/}"/etc/sane.d/dll.conf || die
+
+ # Remove desktop and autostart files
+ # Gentoo Bug: https://bugs.gentoo.org/show_bug.cgi?id=638770
+ use qt5 || {
+ rm -Rf "${ED}"/usr/share/applications "${ED}"/etc/xdg
+ }
+
+ rm -f "${ED%/}"/usr/share/doc/${PF}/{copyright,README_LIBJPG,COPYING} || die
+ rmdir --ignore-fail-on-non-empty "${ED%/}"/usr/share/doc/${PF}/ || die
+
+ # Remove hal fdi files
+ rm -rf "${ED%/}"/usr/share/hal || die
+
+ find "${D}" -name '*.la' -delete || die
+
+ if use !minimal ; then
+ python_export EPYTHON PYTHON
+ python_optimize "${ED%/}"/usr/share/hplip
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}