summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-09-24 20:35:34 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-09-24 20:37:19 +0200
commit2e385ecc6f0b1fdfb1e1d34a4d227b91b2188750 (patch)
tree621aab2af7b6886454bfc9d01ebea1dbb0ec70ae /net-print
parentnet-print/hplip: Version bump to 3.17.9 (diff)
downloadgentoo-2e385ecc6f0b1fdfb1e1d34a4d227b91b2188750.tar.gz
gentoo-2e385ecc6f0b1fdfb1e1d34a4d227b91b2188750.tar.bz2
gentoo-2e385ecc6f0b1fdfb1e1d34a4d227b91b2188750.zip
net-print/hplip-plugin: Version bump to 3.17.7
Package-Manager: Portage-2.3.10, Repoman-2.3.2
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.17.7.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 80da89bf8217..a5c6e5cd438d 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,2 +1,3 @@
DIST hplip-3.16.3-plugin.run 2084271 SHA256 b7edef2a1c5c0a5e001deb4a18c0ef7202e653596e97144b8908ae093818070f SHA512 2ae8aeb40c2604a2c6b9725700f9addf7a82e819d603631158a5d5feac931248e53e7533178100df1fc12b0dc2340cb3ae0d85f145cd023a311f77bbe67e7c7f WHIRLPOOL 928117f862030eca9c3e5813eb8c4db66570923695b0c7af17df1992f339d2478f42af67ca0e0eb8cfa1d7425b522082fde3b8c829c3f5167e1ec503c95a986b
DIST hplip-3.17.6-plugin.run 2059641 SHA256 7ba9377c6ea4ed2a498963dc53a400e3015374bd376dddb5e3248aeabb3aee28 SHA512 a04145a5512ceecc0d35b06846050507afb0905f865878f166f646de7f75368ea9392cc7daea9a0fbec236f6ea65192915f4be0196b005ce7a28b2807185191e WHIRLPOOL f0a02f1254e849c9b2df58ddcbbc1d91c4e496d41fae909245eb60ed3e2f1ac737b89bb4b7d5dbf75cd465d55d1a1ec2fcb0d3df1597addba9ffabaedc39801d
+DIST hplip-3.17.7-plugin.run 2059561 SHA256 3c7acfb8e349332c555c958181c86322a86c33848a11b481040a754d6b5c9db1 SHA512 605cae8ea4433943377e3865b6d0c84bcc0be6f4aa78ab0dbcf2543438fceede8bc0cd2c1a242822b97e173390851e210b0e0c8492d129ea5e7fbcb9c8c505ff WHIRLPOOL 7efc7602bee97f31627152acfa9731d2ebff705d8841f2d6472dc90bd6cd18080f629c46d46564659b0566a6bffeae86452353e2a4fa3b8599b5bb3f8ed09ea9
diff --git a/net-print/hplip-plugin/hplip-plugin-3.17.7.ebuild b/net-print/hplip-plugin/hplip-plugin-3.17.7.ebuild
new file mode 100644
index 000000000000..8617df53c8dc
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.17.7.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit udev unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
+#SRC_URI="http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-${PV}-plugin.run"
+SRC_URI="http://hplipopensource.com/hplip-web/plugin/hplip-${PV}-plugin.run"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PRESTRIPPED="
+ /usr/share/hplip/fax/plugins/fax_marvell.so
+ /usr/share/hplip/prnt/plugins/hbpl1.so
+ /usr/share/hplip/prnt/plugins/lj.so
+ /usr/share/hplip/scan/plugins/bb_escl.so
+ /usr/share/hplip/scan/plugins/bb_marvell.so
+ /usr/share/hplip/scan/plugins/bb_soapht.so
+ /usr/share/hplip/scan/plugins/bb_soap.so
+"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_makeself "hplip-${PV}-plugin.run"
+}
+
+src_install() {
+ local hplip_arch=$(use amd64 && echo 'x86_64' || echo 'x86_32')
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ mkdir -p "${ED}/var/lib/hp/"
+ cat >> "${ED}/var/lib/hp/hplip.state" <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}