summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2020-10-18 17:52:59 +0200
committerDaniel Pielmeier <billie@gentoo.org>2020-10-18 17:54:13 +0200
commit2eb24007fce9fd2ca72e316d4343780723bb150b (patch)
tree85c571c6c505ac184dce7a4f6263ec6ad2f27dbe /net-print
parentsys-auth/sssd: Drop old (diff)
downloadgentoo-2eb24007fce9fd2ca72e316d4343780723bb150b.tar.gz
gentoo-2eb24007fce9fd2ca72e316d4343780723bb150b.tar.bz2
gentoo-2eb24007fce9fd2ca72e316d4343780723bb150b.zip
net-print/hplip: Version bump to hplip-3.20.9.
Closes: https://bugs.gentoo.org/746332 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip/Manifest2
-rw-r--r--net-print/hplip/hplip-3.20.9.ebuild280
2 files changed, 282 insertions, 0 deletions
diff --git a/net-print/hplip/Manifest b/net-print/hplip/Manifest
index 160daf5e3c98..6aa93ada4b62 100644
--- a/net-print/hplip/Manifest
+++ b/net-print/hplip/Manifest
@@ -3,3 +3,5 @@ DIST hplip-3.19.12.tar.gz 25676247 BLAKE2B 1373aa70a2307071c28a22b0ae85e242c3e6b
DIST hplip-3.20.5-patches-1.tar.xz 12716 BLAKE2B 982480185b2decb9f4e857336b474dab585d64aa44a9f0da70ba568e20488f451507aae3bd1427aef4274d36db93dd9bcb1d906f7b393939dfc43c81a1f9a9db SHA512 ae46a6f490253a1112838b08d56199c6257d33911569619483d925798b54a8bc9fe57afd1e86dedb9482d89d42f44bec81db215f37cbcd8fb5982596c80c1117
DIST hplip-3.20.6-patches-2.tar.xz 14308 BLAKE2B b9982387364344e90d87769f4f5da2eae06ca9a21685d8d17aa8a0ac446285f806f8fdbc9c0aa3a7fdf6a2daee6440955974c2c34053d3e160931e327a2681da SHA512 e611be1eba5bc0d9c53b0563b5c42e2a06e73031431a40db9c360dc28106736eafa645be7fca86bbcfddf54efe6885369548cea508d51d03125f1807c18a62e3
DIST hplip-3.20.6.tar.gz 25908476 BLAKE2B cd70d00081ff41d36b566d6f6f546b2cddabb46427afafcd2d04ea7769ce5114feff74612e58ffa83dde4e817ffa2804dbf41411187d9cd15ed7b888b87658ad SHA512 ccd82112afb5ee73f5d027819ab89ba8f52ec36a4b061d314565f95d288be24e045050c3368332eeae50c0fb170f8cb015fdd8dde4b32a08e3758f0f0f4e8e96
+DIST hplip-3.20.9-patches-1.tar.xz 17804 BLAKE2B 912f3e0ad8f3081255df3dbe7e4e2e64099890a0af56ff338f45a00dd1f26f26ee9417adff037895764ce12787d5923351c9df4c7642d1ed1f89d3fc9b66a271 SHA512 74986e7952bc1a990c49ec7e551f03f07fbbf518778d9dafa815b613c9b984f94bc0d390d90e91c37c28f3a6c3d78ec6c176759326fb0a0bc86afe4a098fdc45
+DIST hplip-3.20.9.tar.gz 26141198 BLAKE2B 3aa353343ee79ae04dbe94cb9e135469586a50c2052a21ffcff6907be40522a1605f1174b0b8891dea25abb83a3b836350e1e6c9d12ab2798aa826f1d3ce4069 SHA512 d2981cf51f6d893a576c51808710ac9815aa6ac5fdc617d95cc372518731a48b0aca09af721c1792e1531df6cf8fc0ebf5ebd7e9c96950602a830ceed3d441ae
diff --git a/net-print/hplip/hplip-3.20.9.ebuild b/net-print/hplip/hplip-3.20.9.ebuild
new file mode 100644
index 000000000000..395120a2cffc
--- /dev/null
+++ b/net-print/hplip/hplip-3.20.9.ebuild
@@ -0,0 +1,280 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+),xml"
+
+# 14 and 15 spit out a lot of warnings about subdirs
+WANT_AUTOMAKE="1.13"
+
+inherit autotools linux-info python-single-r1 readme.gentoo-r1 udev
+
+DESCRIPTION="HP Linux Imaging and Printing - Print, scan, fax drivers and service tools"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing"
+SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz
+ https://dev.gentoo.org/~billie/distfiles/${PN}-3.20.9-patches-1.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+IUSE="doc fax +hpcups hpijs kde libnotify libressl -libusb0 minimal parport policykit qt5 scanner +snmp static-ppds X"
+
+COMMON_DEPEND="
+ net-print/cups
+ virtual/jpeg:0
+ hpijs? ( net-print/cups-filters[foomatic] )
+ !minimal? (
+ ${PYTHON_DEPS}
+ sys-apps/dbus
+ !libusb0? ( virtual/libusb:1 )
+ libusb0? ( virtual/libusb:0 )
+ scanner? ( media-gfx/sane-backends )
+ snmp? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ net-analyzer/net-snmp:=
+ $(python_gen_cond_dep 'net-dns/avahi[${PYTHON_MULTI_USEDEP}]')
+ )
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ ${COMMON_DEPEND}
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ app-text/ghostscript-gpl
+ !minimal? (
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]' 'python3*')
+ kernel_linux? ( virtual/udev )
+ $(python_gen_cond_dep '
+ >=dev-python/dbus-python-1.2.0-r1[${PYTHON_MULTI_USEDEP}]
+ dev-python/distro[${PYTHON_MULTI_USEDEP}]
+ fax? ( dev-python/reportlab[${PYTHON_MULTI_USEDEP}] )
+ qt5? (
+ >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_MULTI_USEDEP}]
+ libnotify? ( dev-python/notify2[${PYTHON_MULTI_USEDEP}] )
+ )
+ scanner? (
+ >=dev-python/reportlab-3.2[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pillow-3.1.1[${PYTHON_MULTI_USEDEP}]
+ net-dns/avahi[${PYTHON_MULTI_USEDEP}]
+ X? (
+ || (
+ kde? ( kde-misc/skanlite )
+ media-gfx/xsane
+ media-gfx/sane-frontends
+ )
+ )
+ )
+ ')
+ )
+ policykit? ( sys-auth/polkit )
+"
+
+REQUIRED_USE="!minimal? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${WORKDIR}/patches"
+)
+
+CONFIG_CHECK="~PARPORT ~PPDEV"
+ERROR_PARPORT="Please make sure kernel parallel port support is enabled (PARPORT and PPDEV)."
+
+#DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+For more information on setting up your printer please take
+a look at the hplip section of the gentoo printing guide:
+https://wiki.gentoo.org/wiki/Printing
+"
+
+pkg_setup() {
+ use !minimal && python-single-r1_pkg_setup
+
+ use scanner && ! use X && ewarn "You need USE=X for the scanner GUI."
+
+ if ! use hpcups && ! use hpijs ; then
+ ewarn "Installing neither hpcups (USE=-hpcups) nor hpijs (USE=-hpijs) driver,"
+ ewarn "which is probably not what you want."
+ ewarn "You will almost certainly not be able to print."
+ fi
+
+ if use minimal ; then
+ ewarn "Installing driver portions only, make sure you know what you are doing."
+ ewarn "Depending on the USE flags set for hpcups or hpijs the appropiate driver"
+ ewarn "is installed. If both USE flags are set hpijs overrides hpcups."
+ else
+ use parport && linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+
+ if use !minimal ; then
+ python_fix_shebang .
+ fi
+
+ # Make desktop files follow the specification
+ # Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=443680
+ # Upstream bug: https://bugs.launchpad.net/hplip/+bug/1080324
+ sed -i -e '/^Categories=/s/Application;//' \
+ -e '/^Encoding=.*/d' hplip.desktop.in || die
+ sed -i -e '/^Categories=/s/Application;//' \
+ -e '/^Version=.*/d' \
+ -e '/^Comment=.*/d' hplip-systray.desktop.in || die
+
+ # Fix for Gentoo bug https://bugs.gentoo.org/show_bug.cgi?id=345725
+ # Upstream bug: https://bugs.launchpad.net/hplip/+bug/880847,
+ # https://bugs.launchpad.net/hplip/+bug/500086
+ local udevdir=$(get_udevdir)
+ sed -i -e "s|/etc/udev|${udevdir}|g" \
+ $(find . -type f -exec grep -l /etc/udev {} +) || die
+
+ # Force recognition of Gentoo distro by hp-check
+ sed -i \
+ -e "s:file('/etc/issue', 'r').read():'Gentoo':" \
+ installer/core_install.py || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf drv_build minimal_build
+
+ if use libusb0 ; then
+ myconf="${myconf} --enable-libusb01_build"
+ else
+ myconf="${myconf} --disable-libusb01_build"
+ fi
+
+ if use hpcups ; then
+ drv_build="$(use_enable hpcups hpcups-install)"
+ if use static-ppds ; then
+ drv_build="${drv_build} --enable-cups-ppd-install"
+ drv_build="${drv_build} --disable-cups-drv-install"
+ else
+ drv_build="${drv_build} --enable-cups-drv-install"
+ drv_build="${drv_build} --disable-cups-ppd-install"
+ fi
+ else
+ drv_build="--disable-hpcups-install"
+ drv_build="${drv_build} --disable-cups-drv-install"
+ drv_build="${drv_build} --disable-cups-ppd-install"
+ fi
+
+ if use hpijs ; then
+ drv_build="${drv_build} $(use_enable hpijs hpijs-install)"
+ if use static-ppds ; then
+ drv_build="${drv_build} --enable-foomatic-ppd-install"
+ drv_build="${drv_build} --disable-foomatic-drv-install"
+ else
+ drv_build="${drv_build} --enable-foomatic-drv-install"
+ drv_build="${drv_build} --disable-foomatic-ppd-install"
+ fi
+ else
+ drv_build="${drv_build} --disable-hpijs-install"
+ drv_build="${drv_build} --disable-foomatic-drv-install"
+ drv_build="${drv_build} --disable-foomatic-ppd-install"
+ fi
+
+ if use minimal ; then
+ if use hpijs ; then
+ minimal_build="--enable-hpijs-only-build"
+ else
+ minimal_build="--disable-hpijs-only-build"
+ fi
+ if use hpcups ; then
+ minimal_build="${minimal_build} --enable-hpcups-only-build"
+ else
+ minimal_build="${minimal_build} --disable-hpcups-only-build"
+ fi
+ minimal_build="${minimal_build} --disable-fax-build"
+ else
+ if use fax ; then
+ minimal_build="${minimal_build} --enable-fax-build"
+ else
+ minimal_build="${minimal_build} --disable-fax-build"
+ fi
+ fi
+
+ # disable class driver for now
+ econf \
+ --disable-cups11-build \
+ --disable-lite-build \
+ --disable-foomatic-rip-hplip-install \
+ --disable-shadow-build \
+ --disable-qt3 \
+ --disable-qt4 \
+ --disable-udev_sysfs_rules \
+ --with-cupsbackenddir=$(cups-config --serverbin)/backend \
+ --with-cupsfilterdir=$(cups-config --serverbin)/filter \
+ --with-docdir=/usr/share/doc/${PF} \
+ --with-htmldir=/usr/share/doc/${PF}/html \
+ ${myconf} \
+ ${drv_build} \
+ ${minimal_build} \
+ --enable-hpps-install \
+ --disable-class-driver \
+ $(use_enable doc doc-build) \
+ $(use_enable !minimal gui-build) \
+ $(use_enable !minimal dbus-build) \
+ $(use_enable parport pp-build) \
+ $(use_enable policykit) \
+ $(use_enable qt5) \
+ $(use_enable scanner scan-build) \
+ $(use_enable snmp network-build)
+
+ # hpijs ppds are created at configure time but are not installed (3.17.11)
+
+ # Use system foomatic-rip for hpijs driver instead of foomatic-rip-hplip
+ # The hpcups driver does not use foomatic-rip
+ #local i
+ #for i in ppd/hpijs/*.ppd.gz ; do
+ # rm -f ${i}.temp || die
+ # gunzip -c ${i} | sed 's/foomatic-rip-hplip/foomatic-rip/g' | \
+ # gzip > ${i}.temp || die
+ # mv ${i}.temp ${i} || die
+ #done
+}
+
+src_install() {
+ # Disable parallel install
+ # Gentoo Bug: https://bugs.gentoo.org/show_bug.cgi?id=578018
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+ # default
+
+ # Installed by sane-backends
+ # Gentoo Bug: https://bugs.gentoo.org/show_bug.cgi?id=201023
+ rm -f "${ED}"/etc/sane.d/dll.conf || die
+
+ # Remove desktop and autostart files
+ # Gentoo Bug: https://bugs.gentoo.org/show_bug.cgi?id=638770
+ use qt5 || {
+ rm -Rf "${ED}"/usr/share/applications "${ED}"/etc/xdg
+ }
+
+ rm -f "${ED}"/usr/share/doc/${PF}/{copyright,README_LIBJPG,COPYING} || die
+ rmdir --ignore-fail-on-non-empty "${ED}"/usr/share/doc/${PF}/ || die
+
+ # Remove hal fdi files
+ rm -rf "${ED}"/usr/share/hal || die
+
+ find "${D}" -name '*.la' -delete || die
+
+ if use !minimal ; then
+ python_optimize "${ED}"/usr/share/hplip
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}