summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-04-09 16:18:29 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-04-09 16:18:29 +0100
commit52c6387234ecf60c8605cf23093e82d8f384249c (patch)
tree727b776a7d64622ca4d73c2fba8b941a6e25ffaa /net-print
parentsec-policy/: Stabilize SELinux policies 2.20221101-r4 (diff)
downloadgentoo-52c6387234ecf60c8605cf23093e82d8f384249c.tar.gz
gentoo-52c6387234ecf60c8605cf23093e82d8f384249c.tar.bz2
gentoo-52c6387234ecf60c8605cf23093e82d8f384249c.zip
net-print/hplip-plugin: Version bump to 3.23.3
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.23.3.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 9124632219d8..7ea4562d2d41 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1 +1,2 @@
DIST hplip-3.22.10-plugin.run 11494258 BLAKE2B c9cca80349af4f04f1b1d055083fea451d079a08179fe29fb8ca056c76a36847a58cdc526080d16620a7ab7b8650ccc46f15b3a63447964a6f6006e54b316905 SHA512 dfedc343898fb7b9e951de9a09578627b208f7d0652666eb05d5926ad3ec220bd049d6bee1fb211c72f2e484925e48a665c3133aeeca9d19032fd95e0c3711fa
+DIST hplip-3.23.3-plugin.run 11491593 BLAKE2B 94ba1cf92661f738f19d0c1c42b513569dad7815aeb9dad2d791f68f8ee893ca380fab2c7ff2b1fb9527851d288ec2993875952d889dac0e963b6f19c201d484 SHA512 048c545869f9679daa581b63236d57fbc362c39a4f3f6c6afe66552ac1b2def1563ec5b19d3feda44dbd564e2b0f2794833b24752a6139dc77d848146e283074
diff --git a/net-print/hplip-plugin/hplip-plugin-3.23.3.ebuild b/net-print/hplip-plugin/hplip-plugin-3.23.3.ebuild
new file mode 100644
index 000000000000..4bf67bc6bda1
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.23.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+S="${WORKDIR}"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="orblite"
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+ orblite? (
+ media-gfx/sane-backends
+ >=sys-libs/glibc-2.26
+ virtual/libusb:0
+ )
+"
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PREBUILT="${HPLIP_HOME}/*.so"
+
+src_install() {
+ local hplip_arch plugin
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ arm64) hplip_arch="arm64" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ bb_orblite-*)
+ use orblite || continue
+ plugin_type=scan ;;
+ bb_*)
+ plugin_type=scan ;;
+ fax_*)
+ plugin_type=fax ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}