summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-05-07 10:56:02 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-10 13:53:52 +0300
commit61cd037fd7588b7418579bb3810beb267aeb64f4 (patch)
tree514f6fbac6ba34dbe6ac7e467f3e705aeba1eba2 /net-print
parentdev-python/setuptools: Reenable tests (diff)
downloadgentoo-61cd037fd7588b7418579bb3810beb267aeb64f4.tar.gz
gentoo-61cd037fd7588b7418579bb3810beb267aeb64f4.tar.bz2
gentoo-61cd037fd7588b7418579bb3810beb267aeb64f4.zip
net-print/gutenprint: bump to 5.3.4
This release drops 2 patches, these named files/5.3.3-* Closes: https://bugs.gentoo.org/674078 Closes: https://bugs.gentoo.org/788880 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Closes: https://github.com/gentoo/gentoo/pull/20715 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/gutenprint/Manifest1
-rw-r--r--net-print/gutenprint/gutenprint-5.3.4.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/net-print/gutenprint/Manifest b/net-print/gutenprint/Manifest
index 88c4bc616699..f709b3a038b0 100644
--- a/net-print/gutenprint/Manifest
+++ b/net-print/gutenprint/Manifest
@@ -1 +1,2 @@
DIST gutenprint-5.3.3.tar.xz 5050624 BLAKE2B dbcf74169d0756d991bbdad7338a6e6f995f8eeedc2610677b327abee6aecc787d1cc35949f73c1d93ad274de7d467542b72a5fe0abf58fbc4ec6f21667cbad7 SHA512 d2c47eb4ccc3c46ccb2f1042682edf7443f5c57439ead72f49ecd10537cf967251bacf7ca7da29fb8dceecc7eebd55ed021f2594ff9fb6509bab543fab1dc8d6
+DIST gutenprint-5.3.4.tar.xz 5341824 BLAKE2B 134e59c7dbf9c0ba95b91c717f1e6841f35520b55105feb1ba40b82785c825b8e2a2429990e78186a1455e5c6de9880f911438d514c53c56d05575dd4e2d68a4 SHA512 63de0b62edbe255a7efaaeab1dcd22577b7b46d7e0e48441b79977f19e76bf3862e4e8e18c55dd1f2e7392d555f9e8ee875ea53b90c689852d2343491a8fbcc8
diff --git a/net-print/gutenprint/gutenprint-5.3.4.ebuild b/net-print/gutenprint/gutenprint-5.3.4.ebuild
new file mode 100644
index 000000000000..261ffa287c9c
--- /dev/null
+++ b/net-print/gutenprint/gutenprint-5.3.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Ghostscript and cups printer drivers"
+HOMEPAGE="http://gutenprint.sourceforge.net"
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+SRC_URI="mirror://sourceforge/gimp-print/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="cups gimp gtk nls readline ppds static-libs"
+RESTRICT="test"
+REQUIRED_USE="gimp? ( gtk )"
+
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+# gimp restriction: https://sourceforge.net/p/gimp-print/bugs/725/
+RDEPEND="
+ dev-lang/perl
+ cups? ( >=net-print/cups-1.1.14 )
+ gimp? (
+ media-gfx/gimp:0/2
+ x11-libs/gtk+:2
+ )
+ gtk? ( x11-libs/gtk+:2 )
+ readline? ( sys-libs/readline:0= )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README doc/gutenprint-users-manual.{pdf,odt} )
+PATCHES=( "${FILESDIR}"/${PN}-5.3.1-cflags.patch )
+
+src_configure() {
+ local myeconfargs=(
+ --enable-test
+ --disable-translated-cups-ppds
+ $(use_enable gtk libgutenprintui2)
+ $(use_with gimp gimp2)
+ $(use_with gimp gimp2-as-gutenprint)
+ $(use_with cups)
+ $(use_enable nls)
+ $(use_with readline)
+ $(use_enable static-libs static)
+ )
+
+ if use cups && use ppds; then
+ myeconfargs+=( --enable-cups-ppds --enable-cups-level3-ppds )
+ else
+ myeconfargs+=( --disable-cups-ppds )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ dodoc doc/FAQ.html
+ dodoc -r doc/gutenprintui2/html
+ rm -r "${ED}"/usr/share/gutenprint/doc || die
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if [[ -x /usr/sbin/cups-genppdupdate ]]; then
+ elog "Updating installed printer ppd files"
+ elog $(/usr/sbin/cups-genppdupdate)
+ else
+ elog "You need to update installed ppds manually using cups-genppdupdate"
+ fi
+}