summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-09-15 12:52:59 +0200
committerManuel Rüger <mrueg@gentoo.org>2015-09-15 12:53:17 +0200
commit65a83c822d917102e9a7fa26edb74d7565027c71 (patch)
tree1efa63626dd4b829906e1439f41c682c6f7d3641 /net-print
parentdev-libs/libev: add alpha keyword (diff)
downloadgentoo-65a83c822d917102e9a7fa26edb74d7565027c71.tar.gz
gentoo-65a83c822d917102e9a7fa26edb74d7565027c71.tar.bz2
gentoo-65a83c822d917102e9a7fa26edb74d7565027c71.zip
net-print/cups-filters: Version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups-filters/Manifest1
-rw-r--r--net-print/cups-filters/cups-filters-1.0.76.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/net-print/cups-filters/Manifest b/net-print/cups-filters/Manifest
index 90278a4efc62..35c3c93d6465 100644
--- a/net-print/cups-filters/Manifest
+++ b/net-print/cups-filters/Manifest
@@ -2,3 +2,4 @@ DIST cups-filters-1.0.71.tar.xz 1339116 SHA256 3180aa209c383402822e568ccef8e1ca4
DIST cups-filters-1.0.73.tar.xz 1351652 SHA256 84521dc5079e683144e95e22ffcdbc3d51c44f9d4079c5bcc7f7ff421e94ec75 SHA512 ae380403569640fab21c9a0914b894628bcc57b709d68c05b620ec425734436281fe752d99b83c114927110489e523ffdb676b723109094dc7ef6d53bc9e8f41 WHIRLPOOL 3c447ed182a73cab84349101f5846c0cf9784de0b50960bc689de3f4086becf392229d378cc5fa70857adc66191f67e564ed5b6f2c081a7184e62b788d1f80f9
DIST cups-filters-1.0.74.tar.xz 1352328 SHA256 55e86080c3778d247d88bf6232947cb7c2057a6bce501c6e707800846f71119b SHA512 b7eac4915ee95524af37342bd3dcb4a430052f32360654df5c2cab9373c1c1993d51f5066b44936f5a0ed43b4f34ff22db54f65de1eff4361469577621496954 WHIRLPOOL 07da3a30af49b6ae73d308260b73ef4a67989fab9a2546bd40c75a921c51e058b2e7cab418d8e8e51def1dc414ba6d9c7924cddd1652b59fb160d07806b0454d
DIST cups-filters-1.0.75.tar.xz 1352492 SHA256 7c69ecea306e33d940b698ef34230c126a1016a5a02c8b18faa466d1aa4c3073 SHA512 a385f4c3aeca8c9a8c9b577b4f90e3e4ceb4488795dd5215b36a6d34832b0719d08d4bd8f653bda6182e5433ee046bae00dd1ab46aa932e66480e3657225c15f WHIRLPOOL 4fcd637c445a7f9b18a8b29185e36169be766f743ff14f1601909110fdb40a4e42c6e58253d63162b263d2efd15f98de0e3731ad1afcb6c909a497c798a3b6d3
+DIST cups-filters-1.0.76.tar.xz 1353016 SHA256 b3a190b11a102af6994e41d2cfa47e5caf999c7d046f3c0b940f6b38729f5b32 SHA512 1c438ffc10551b79468f7f850e8f036defaa9c2e1114153107ff909904f25786c36635ea29cb8b07a2d6df37ab2e68bd91731d783e279f1a36decba9204baf7d WHIRLPOOL c9f0e0347f434aab1bc041c56704343fea1c656a355d69d274f3ab5883471815962ae23e9d96533b945e119dff4d3d8204a31b35a179e59b435d067fdc8e2a07
diff --git a/net-print/cups-filters/cups-filters-1.0.76.ebuild b/net-print/cups-filters/cups-filters-1.0.76.ebuild
new file mode 100644
index 000000000000..84982d880863
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-1.0.76.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit base eutils perl-module autotools systemd
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit bzr
+ EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
+ KEYWORDS=""
+else
+ SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
+fi
+DESCRIPTION="Cups PDF filters"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdfasstandardprintjobformat"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic jpeg perl png static-libs tiff zeroconf"
+
+RDEPEND="
+ >=app-text/ghostscript-gpl-9.09
+ app-text/poppler:=[cxx,jpeg?,lcms,tiff?,xpdf-headers(+)]
+ >=app-text/qpdf-3.0.2:=
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/lcms:2
+ >=net-print/cups-1.7.3
+ !<=net-print/cups-1.5.9999
+ sys-devel/bc
+ sys-libs/zlib
+ dbus? ( sys-apps/dbus )
+ foomatic? ( !net-print/foomatic-filters )
+ jpeg? ( virtual/jpeg:0 )
+ perl? ( dev-lang/perl:= )
+ png? ( media-libs/libpng:0= )
+ tiff? ( media-libs/tiff:0 )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ base_src_prepare
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable dbus) \
+ $(use_enable zeroconf avahi) \
+ $(use_enable static-libs static) \
+ --with-fontdir="fonts/conf.avail" \
+ --with-pdftops=pdftops \
+ --enable-imagefilters \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with tiff) \
+ --with-rcdir=no \
+ --with-browseremoteprotocols=DNSSD,CUPS \
+ --without-php
+}
+
+src_compile() {
+ MAKEOPTS=-j1 default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_configure
+ perl-module_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_install
+ perl_delete_localpod
+ popd > /dev/null
+ fi
+
+ # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+ dosym /usr/libexec/cups/filter/gstoraster /usr/libexec/cups/filter/pstoraster
+ dosym /usr/libexec/cups/filter/gstopxl /usr/libexec/cups/filter/pstopxl
+
+ prune_libtool_files --all
+
+ cp "${FILESDIR}"/cups-browsed.init.d "${T}"/cups-browsed || die
+
+ if ! use zeroconf ; then
+ sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+ sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+ fi
+
+ if ! use foomatic ; then
+ # this needs an upstream solution / configure switch
+ rm -v "${ED}/usr/bin/foomatic-rip" || die
+ rm -v "${ED}/usr/libexec/cups/filter/foomatic-rip" || die
+ rm -v "${ED}/usr/share/man/man1/foomatic-rip.1" || die
+ fi
+
+ doinitd "${T}"/cups-browsed
+ systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+pkg_postinst() {
+ if ! use foomatic ; then
+ ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+ ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+ fi
+}