summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-06-18 00:12:32 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-06-18 00:12:32 +0100
commit6c28873d81cc0683830afeda44851ece2efc15b9 (patch)
tree07a11a11766579d0eb53843a3b58a6c9635e5b27 /net-print
parentwww-misc/buku: add 4.6 (diff)
downloadgentoo-6c28873d81cc0683830afeda44851ece2efc15b9.tar.gz
gentoo-6c28873d81cc0683830afeda44851ece2efc15b9.tar.bz2
gentoo-6c28873d81cc0683830afeda44851ece2efc15b9.zip
net-print/hplip-plugin: Version bump to 3.21.4
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.21.4.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 2d43c2579ecb..53c5ac1fc398 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,2 +1,3 @@
DIST hplip-3.20.11-plugin.run 11514293 BLAKE2B b3b7698a45e5e68a25ec1216e736484d26546b657f4a519a153acf0280847667e7ca81afc988f722668746281857d51d9e1703857514ffe5b57dea85f2bae4d3 SHA512 9075c1ac8e8f6e12d33b81b633025259f54352ea00271eec07ee898fd9a164445519608fc9ea61a7157845a4a03f87c28f486c7994f0d7db81d11d3fe51f1876
DIST hplip-3.21.2-plugin.run 11514233 BLAKE2B 262f23c34632f7ba4a9c6e1c4533d0fd44b025e476c0f28f0fc68bc401430c503233583ae381d6c74a89a996b750603910000c6fdc6b0b606e32d56c82ed07f4 SHA512 62f3b6e369bdd1b2145f814901314c78ae5d7426734c92b0511f8ea4a925e24880875a1cfd1623ef800dcfdf3cf5b1c5d83032a19ca200547a4555b0d944f8e6
+DIST hplip-3.21.4-plugin.run 11514018 BLAKE2B a12881a1e4795fb1f5294a8b164f72aa38fd2365fe07853d0a16c688b38835f852e6317992541920fdc299ee84a7b725e70788e5759acbffb173d2604328468a SHA512 0a01dcbafe641688fd21e4f1a1a4520eadd5a1312a913c6870054bbf5b43d22310dea3a21a8e37e645f5637d808ebaeeaa4d64346e73b97c6dc1cba25733a8de
diff --git a/net-print/hplip-plugin/hplip-plugin-3.21.4.ebuild b/net-print/hplip-plugin/hplip-plugin-3.21.4.ebuild
new file mode 100644
index 000000000000..cca0faecc4c1
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.21.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="orblite"
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+ orblite? (
+ media-gfx/sane-backends
+ >=sys-libs/glibc-2.26
+ virtual/libusb:0
+ )
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PREBUILT="${HPLIP_HOME}/*.so"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_install() {
+ local hplip_arch
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ bb_orblite-*)
+ use orblite || continue
+ plugin_type=scan ;;
+ bb_*)
+ plugin_type=scan ;;
+ fax_*)
+ plugin_type=fax ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}