summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2020-09-26 12:34:50 +0200
committerDaniel Pielmeier <billie@gentoo.org>2020-09-26 12:35:53 +0200
commit9d0b50677352d435832143ba3f4bc797974e9837 (patch)
treeda763ac5e11eb0d71baba317ee9f89db79ccfd09 /net-print
parentmedia-sound/kid3: 3.8.4 version bump (diff)
downloadgentoo-9d0b50677352d435832143ba3f4bc797974e9837.tar.gz
gentoo-9d0b50677352d435832143ba3f4bc797974e9837.tar.bz2
gentoo-9d0b50677352d435832143ba3f4bc797974e9837.zip
net-print/hplip-plugin: Partial revert of commit '0fe5854ccdd'.
Restore hplip-plugin-3.19.12 to keep a working version for users affected by bug #727688. Bug: https://bugs.gentoo.org/727688 Package-Manager: Portage-3.0.4, Repoman-3.0.1 RepoMan-Options: --force Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.19.12.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 4764154b0845..f22bf52107cc 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1 +1,2 @@
+DIST hplip-3.19.12-plugin.run 11512079 BLAKE2B 534cbba51b2254f8227611b8f0449e100361fb445400f664e43e30412be8eb554bb35c2fe260d45cd5ad742b083af6d551532a9d14585029b0ff93675fab578a SHA512 ac2022d555f5084d5bf1e4519ddbb29828e9ca385aa6dff818ae9e79b60b4b2745e31ad4146cb01bca3747fae0d61b96e4a823b81179d2e2c55a643831165e4b
DIST hplip-3.20.6-plugin.run 11514108 BLAKE2B 83e2d26fb397c5c5df1fc4371bfc2798cea049965499b6f1ad5daa05b44b74f51ba9deb933b564dfa47a8d0ef79d4921c3a96b9531730317742e1c5651d7b012 SHA512 6f9e5c92e302f4068abbe9134cf7f8081fcbe98568c9b75d6a668843b76c83afd0f4fbb3d90d3ac775c719ab8e2dca5beedd887ef6d072bd8ee0eb48d42521ed
diff --git a/net-print/hplip-plugin/hplip-plugin-3.19.12.ebuild b/net-print/hplip-plugin/hplip-plugin-3.19.12.ebuild
new file mode 100644
index 000000000000..94c7a5c55145
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.19.12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/libusb:0
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PREBUILT="${HPLIP_HOME}/*.so"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_install() {
+ local hplip_arch
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}