summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2015-09-23 21:41:22 +0200
committerDaniel Pielmeier <billie@gentoo.org>2015-09-23 21:41:22 +0200
commitb3a95a2e12d2235f1605fc820f021c5a3e63312a (patch)
tree8d49b7aed39c55f49f6020eb0cf838fa48662148 /net-print
parentapp-admin/puppet: bup (diff)
downloadgentoo-b3a95a2e12d2235f1605fc820f021c5a3e63312a.tar.gz
gentoo-b3a95a2e12d2235f1605fc820f021c5a3e63312a.tar.bz2
gentoo-b3a95a2e12d2235f1605fc820f021c5a3e63312a.zip
Version bump.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip/Manifest1
-rw-r--r--net-print/hplip/hplip-3.15.9.ebuild260
2 files changed, 261 insertions, 0 deletions
diff --git a/net-print/hplip/Manifest b/net-print/hplip/Manifest
index 76c6981f18e6..50c26d9d0ce0 100644
--- a/net-print/hplip/Manifest
+++ b/net-print/hplip/Manifest
@@ -3,3 +3,4 @@ DIST hplip-3.14.10.tar.gz 21773429 SHA256 11b3cd8311dea6b22a4c80be1e5d021e84d15a
DIST hplip-3.15.6-patches-1.tar.xz 8176 SHA256 3f42f72590966f49788ae620948dd3fe206c914d2d4a8d21aaaa86ef5f8b4645 SHA512 d9a35c594f087508a58d07b7c9f47e7bfb280ad66533481b069065cfbdc1927d56d50ab8b50d256bba1bd369fecc6c647bdae7a56a7f0e9edd74da8377dd22f4 WHIRLPOOL f3e0eb720ba14d596f68f106b71c7bd225dfe753cdd56857aa8d2600a72517384ad1a0cbfec7b3ac60922d682bd77a7f3ea2b44db6cdebacee820ebcfbcfc232
DIST hplip-3.15.6.tar.gz 21956752 SHA256 30c513ee65aa5b342d8074ff89439c0827c35191683727335738d8bc0f9776c9 SHA512 97abde02c588563b77bd1eca73e1864eb6bda218fe9e7b77396ecc461ea884d94b5757c01486c81177c354e1aeec73eae0620d3a06d7b42d0ad2f62cb91334d3 WHIRLPOOL 12c72f36d0abbe73a0b4c489d783a9e11bbf33bfe15575a40db37a598edf34f9f8ccc4b5dc1aadbf7f308311decf19ca92af6192094c6d8e0c40c1a9d1b6c464
DIST hplip-3.15.7.tar.gz 21979938 SHA256 d310903048f3600f93422e5a8c39ddd682511e0849cd9abc5e943f9a10bdd49d SHA512 45458b74ec496816292c40a9c1d5aed4a288f84be62e79378e701fff5fb1cb55cc77e8415884b824602ec6af8d1155b7dc288ef7382a2e4d96b337520d541a1c WHIRLPOOL 9cf840f79a63877e8fb36ddd51681e1473450c81bd46263272037682519e3ddfdfffc79ac86a60212d46ae61778fac118a9e5576bbf02892c46eba645b960f00
+DIST hplip-3.15.9.tar.gz 22027325 SHA256 a1f58fe8707373c193728a7fd826523e99c30e3ca7f660faa75531acdff89d6d SHA512 4a33adff226cbcd0c36963a33117eef6877dbfead9514d6095a4f5a1eca3e46e81ee162279b7808c3e1fb24e92dab8edaf945eea351d9b85c8f891b7379d13fc WHIRLPOOL 8e2012d5543b0d11389bfd6c629671bec85282223ef4d1f921972af1071d770c825997fc0938cb47299f797d1f5f58dc270bc9220693e48be7abf6c15591cefb
diff --git a/net-print/hplip/hplip-3.15.9.ebuild b/net-print/hplip/hplip-3.15.9.ebuild
new file mode 100644
index 000000000000..a32038422202
--- /dev/null
+++ b/net-print/hplip/hplip-3.15.9.ebuild
@@ -0,0 +1,260 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads,xml"
+
+inherit eutils fdo-mime linux-info python-single-r1 udev autotools toolchain-funcs
+
+DESCRIPTION="HP Linux Imaging and Printing. Includes printer, scanner, fax drivers and service tools"
+HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
+SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz
+ https://dev.gentoo.org/~billie/distfiles/${PN}-3.15.6-patches-1.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+IUSE="doc fax +hpcups hpijs kde libnotify -libusb0 minimal parport policykit qt4 scanner snmp static-ppds X"
+
+COMMON_DEPEND="
+ virtual/jpeg:0
+ hpijs? (
+ || ( >=net-print/cups-filters-1.0.43-r1[foomatic] >=net-print/foomatic-filters-3.0.20080507[cups] )
+ )
+ !minimal? (
+ ${PYTHON_DEPS}
+ >=net-print/cups-1.4.0
+ !libusb0? ( virtual/libusb:1 )
+ libusb0? ( virtual/libusb:0 )
+ scanner? ( >=media-gfx/sane-backends-1.0.19-r1 )
+ fax? ( >=sys-apps/dbus-1.6.8-r1 )
+ snmp? (
+ net-analyzer/net-snmp
+ dev-libs/openssl:0
+ )
+ )"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+RDEPEND="${COMMON_DEPEND}
+ >=app-text/ghostscript-gpl-8.71-r3
+ policykit? (
+ sys-auth/polkit
+ )
+ !minimal? (
+ >=dev-python/dbus-python-1.1.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.28.6-r53:2[${PYTHON_USEDEP}]
+ kernel_linux? ( virtual/udev )
+ scanner? (
+ >=dev-python/reportlab-2.6[${PYTHON_USEDEP}]
+ >=virtual/python-imaging-1[${PYTHON_USEDEP}]
+ X? ( || (
+ kde? ( kde-misc/skanlite )
+ media-gfx/xsane
+ media-gfx/sane-frontends
+ ) )
+ )
+ fax? (
+ >=dev-python/reportlab-2.6[${PYTHON_USEDEP}]
+ )
+ qt4? (
+ >=dev-python/PyQt4-4.9.6-r2[dbus,X,${PYTHON_USEDEP}]
+ libnotify? (
+ >=dev-python/notify-python-0.1.1-r3[${PYTHON_USEDEP}]
+ )
+ )
+ )"
+
+REQUIRED_USE="!minimal? ( ${PYTHON_REQUIRED_USE} )"
+
+CONFIG_CHECK="~PARPORT ~PPDEV"
+ERROR_PARPORT="Please make sure kernel parallel port support is enabled (PARPORT and PPDEV)."
+
+pkg_setup() {
+ use !minimal && python-single-r1_pkg_setup
+
+ ! use qt4 && ewarn "You need USE=qt4 for the hplip GUI."
+
+ use scanner && ! use X && ewarn "You need USE=X for the scanner GUI."
+
+ if ! use hpcups && ! use hpijs ; then
+ ewarn "Installing neither hpcups (USE=-hpcups) nor hpijs (USE=-hpijs) driver,"
+ ewarn "which is probably not what you want."
+ ewarn "You will almost certainly not be able to print."
+ fi
+
+ if use minimal ; then
+ ewarn "Installing driver portions only, make sure you know what you are doing."
+ ewarn "Depending on the USE flags set for hpcups or hpijs the appropiate driver"
+ ewarn "is installed. If both USE flags are set hpijs overrides hpcups."
+ else
+ use parport && linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ if use !minimal ; then
+ python_export EPYTHON PYTHON
+ python_fix_shebang .
+ fi
+
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch "${WORKDIR}"
+
+ # Make desktop files follow the specification
+ # Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=443680
+ # Upstream bug: https://bugs.launchpad.net/hplip/+bug/1080324
+ sed -i -e '/^Categories=/s/Application;//' \
+ -e '/^Encoding=.*/d' hplip.desktop.in || die
+ sed -i -e '/^Categories=/s/Application;//' \
+ -e '/^Version=.*/d' \
+ -e '/^Comment=.*/d' hplip-systray.desktop.in || die
+
+ # Fix for Gentoo bug https://bugs.gentoo.org/show_bug.cgi?id=345725
+ # Upstream bug: https://bugs.launchpad.net/hplip/+bug/880847,
+ # https://bugs.launchpad.net/hplip/+bug/500086
+ local udevdir=$(get_udevdir)
+ sed -i -e "s|/etc/udev|${udevdir}|g" \
+ $(find . -type f -exec grep -l /etc/udev {} +) || die
+
+ # Force recognition of Gentoo distro by hp-check
+ sed -i \
+ -e "s:file('/etc/issue', 'r').read():'Gentoo':" \
+ installer/core_install.py || die
+
+ # Use system foomatic-rip for hpijs driver instead of foomatic-rip-hplip
+ # The hpcups driver does not use foomatic-rip
+ local i
+ for i in ppd/hpijs/*.ppd.gz ; do
+ rm -f ${i}.temp || die
+ gunzip -c ${i} | sed 's/foomatic-rip-hplip/foomatic-rip/g' | \
+ gzip > ${i}.temp || die
+ mv ${i}.temp ${i} || die
+ done
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf drv_build minimal_build
+
+ if use fax || use qt4 ; then
+ myconf="${myconf} --enable-dbus-build"
+ else
+ myconf="${myconf} --disable-dbus-build"
+ fi
+
+ if use libusb0 ; then
+ myconf="${myconf} --enable-libusb01_build"
+ else
+ myconf="${myconf} --disable-libusb01_build"
+ fi
+
+ if use hpcups ; then
+ drv_build="$(use_enable hpcups hpcups-install)"
+ if use static-ppds ; then
+ drv_build="${drv_build} --enable-cups-ppd-install"
+ drv_build="${drv_build} --disable-cups-drv-install"
+ else
+ drv_build="${drv_build} --enable-cups-drv-install"
+ drv_build="${drv_build} --disable-cups-ppd-install"
+ fi
+ else
+ drv_build="--disable-hpcups-install"
+ drv_build="${drv_build} --disable-cups-drv-install"
+ drv_build="${drv_build} --disable-cups-ppd-install"
+ fi
+
+ if use hpijs ; then
+ drv_build="${drv_build} $(use_enable hpijs hpijs-install)"
+ if use static-ppds ; then
+ drv_build="${drv_build} --enable-foomatic-ppd-install"
+ drv_build="${drv_build} --disable-foomatic-drv-install"
+ else
+ drv_build="${drv_build} --enable-foomatic-drv-install"
+ drv_build="${drv_build} --disable-foomatic-ppd-install"
+ fi
+ else
+ drv_build="${drv_build} --disable-hpijs-install"
+ drv_build="${drv_build} --disable-foomatic-drv-install"
+ drv_build="${drv_build} --disable-foomatic-ppd-install"
+ fi
+
+ if use minimal ; then
+ if use hpijs ; then
+ minimal_build="--enable-hpijs-only-build"
+ else
+ minimal_build="--disable-hpijs-only-build"
+ fi
+ if use hpcups ; then
+ minimal_build="${minimal_build} --enable-hpcups-only-build"
+ else
+ minimal_build="${minimal_build} --disable-hpcups-only-build"
+ fi
+ fi
+
+ econf \
+ --disable-cups11-build \
+ --disable-lite-build \
+ --disable-foomatic-rip-hplip-install \
+ --disable-shadow-build \
+ --disable-qt3 \
+ --disable-udev_sysfs_rules \
+ --with-cupsbackenddir=$(cups-config --serverbin)/backend \
+ --with-cupsfilterdir=$(cups-config --serverbin)/filter \
+ --with-docdir=/usr/share/doc/${PF} \
+ --with-htmldir=/usr/share/doc/${PF}/html \
+ ${myconf} \
+ ${drv_build} \
+ ${minimal_build} \
+ $(use_enable doc doc-build) \
+ $(use_enable fax fax-build) \
+ $(use_enable parport pp-build) \
+ $(use_enable scanner scan-build) \
+ $(use_enable snmp network-build) \
+ $(use_enable qt4 gui-build) \
+ $(use_enable qt4) \
+ $(use_enable policykit)
+}
+
+src_install() {
+ default
+
+ # Installed by sane-backends
+ # Gentoo Bug: https://bugs.gentoo.org/show_bug.cgi?id=201023
+ rm -f "${D}"/etc/sane.d/dll.conf || die
+
+ rm -f "${D}"/usr/share/doc/${PF}/{copyright,README_LIBJPG,COPYING} || die
+ rmdir --ignore-fail-on-non-empty "${D}"/usr/share/doc/${PF}/ || die
+
+ # Remove hal fdi files
+ rm -rf "${D}"/usr/share/hal || die
+
+ prune_libtool_files --all
+
+ if use !minimal ; then
+ python_export EPYTHON PYTHON
+ python_optimize "${D}"/usr/share/hplip
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "For more information on setting up your printer please take"
+ elog "a look at the hplip section of the gentoo printing guide:"
+ elog "https://wiki.gentoo.org/wiki/Printing"
+ elog
+ elog "Any user who wants to print must be in the lp group."
+ elog
+ elog "Please note: Printers requiring a binary plugin are currently"
+ elog "not supported. All bugs regarding the plugin are most likely"
+ elog "closed. A bug about including the plugin package to gentoo is"
+ elog "available here: https://bugs.gentoo.org/352439"
+ fi
+}