summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-09-01 02:02:56 -0400
committerTim Harder <radhermit@gentoo.org>2016-09-01 02:07:29 -0400
commite779b82ca1b5984980561c3e17af70201ae7a71d (patch)
treef1605e452870a66e34fe62d02d4efa5d6190880b /net-print
parentdev-ruby/hamster: add missing dependency, fixes bug 592602 (diff)
downloadgentoo-e779b82ca1b5984980561c3e17af70201ae7a71d.tar.gz
gentoo-e779b82ca1b5984980561c3e17af70201ae7a71d.tar.bz2
gentoo-e779b82ca1b5984980561c3e17af70201ae7a71d.zip
net-print/gutenprint: version bump to 5.2.11
Diffstat (limited to 'net-print')
-rw-r--r--net-print/gutenprint/Manifest1
-rw-r--r--net-print/gutenprint/files/gutenprint-switch-from-ijs-config-to-pkg-config.patch60
-rw-r--r--net-print/gutenprint/gutenprint-5.2.11.ebuild97
3 files changed, 158 insertions, 0 deletions
diff --git a/net-print/gutenprint/Manifest b/net-print/gutenprint/Manifest
index 46db193b40c3..a38c2d37e626 100644
--- a/net-print/gutenprint/Manifest
+++ b/net-print/gutenprint/Manifest
@@ -1,2 +1,3 @@
DIST gutenprint-5.2.10.tar.bz2 6241585 SHA256 431f352b412dfb9809d126a85a37a1fcd1c1826275ace8cdcd4fd9a6ee360e59 SHA512 bb71fd5c127748730dde01471b09907d500b72c35401abaf92c631d04156bacafd4b1a9baef61f48db6c4a622fd612a1e2834ed30207b5b178767ea9d9d5e1ac WHIRLPOOL 4d809f99df3515fc878d3be5df4f48b66fc764eea1f62db15e75d6ca7326c24c6c228bd975575c20f3e7bc8398c1e492e1025784e64a4534f82ad89c7ba92990
+DIST gutenprint-5.2.11.tar.bz2 6570118 SHA256 c1a34cd2e02527de4d2a9bf6c14732cb9aa11b333f771eb6043fdc974de24df9 SHA512 f4010e489dd6763b19113abf1d55e84cea8d36b920d03dbe204dba30ab0d3fb3e3391e739cd1a56e2f63581c8ce4a856a7f747deb6e7b18d7e1f7a3d87901c60 WHIRLPOOL 0c6a0495d59ef720da74b610f6c26515ea5d0748e78f1b8eb4bb12277dca874b428ef17f9cf668f0449362900580ecefe35c2d1ebf6f6025519c886fc8a83b9e
DIST gutenprint-5.2.9.tar.bz2 5720450 SHA256 4b27e4f06f32d30271df89ecb6089bb11bcf2caec5f60b0909e083095354bca0 SHA512 082990e09c49247baab9575b34882026770923915eb1c4ff6f75475cd341691263c7567a430542ead868e80ee6ea82e00ad12c89be0611913f934d66a10a9549 WHIRLPOOL d466288983c4a194c76f505a5adc16af00a651c07a584ff860919b1cf0e2ca870091eac76c6b7d466d9508f3e77a4c6095efe593c0350feeb41dd761adb6e92a
diff --git a/net-print/gutenprint/files/gutenprint-switch-from-ijs-config-to-pkg-config.patch b/net-print/gutenprint/files/gutenprint-switch-from-ijs-config-to-pkg-config.patch
new file mode 100644
index 000000000000..99ef9b74c6e2
--- /dev/null
+++ b/net-print/gutenprint/files/gutenprint-switch-from-ijs-config-to-pkg-config.patch
@@ -0,0 +1,60 @@
+From 233a909a77dd4c18d359bf32cd8ef99ed1b7b459 Mon Sep 17 00:00:00 2001
+From: speachy <>
+Date: Fri, 29 Jan 2016 12:41:21 +0000
+Subject: [PATCH] Apply patch from Brian Norris to switch from 'ijs-config' to
+ 'pkg-config' for IJS support, as the former does not work for
+ cross-compilation.
+
+---
+ configure.ac | 10 ++++------
+ src/ghost/ijsgutenprint.c | 4 ++--
+ 2 files changed, 6 insertions(+), 8 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 800794b..fac8361 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -371,9 +371,9 @@ if test "$BUILD_FOOMATIC_3" = "yes" ; then
+ BUILD_FOOMATIC=yes
+ fi
+
+-AC_PATH_PROG(IJS_CONFIG, ijs-config)
++PKG_CHECK_MODULES(IJS, ijs, [HAVE_IJS=yes], [HAVE_IJS=no])
+
+-if test -z "${IJS_CONFIG}" ; then
++if test "x${HAVE_IJS}" = "xno" ; then
+ BUILD_GHOSTSCRIPT="no"
+ else
+ BUILD_GHOSTSCRIPT="yes"
+@@ -620,11 +620,9 @@ fi
+
+ dnl ijs checks
+ if test x${BUILD_GHOSTSCRIPT} = xyes ; then
+- if test -z "$IJS_CONFIG" ; then
+- AC_MSG_ERROR(Cannot find ijs-config; please ensure Ghostscript 6.53 or above is installed);
++ if test -z "$HAVE_IJS" ; then
++ AC_MSG_ERROR(Cannot find ijs; please ensure Ghostscript 6.53 or above is installed);
+ fi
+- IJS_CFLAGS=`$IJS_CONFIG --cflags`
+- IJS_LIBS=`$IJS_CONFIG --libs`
+ fi
+
+ GUTENPRINT_RELEASE_VERSION=${GUTENPRINT_MAJOR_VERSION}.${GUTENPRINT_MINOR_VERSION}
+diff --git a/src/ghost/ijsgutenprint.c b/src/ghost/ijsgutenprint.c
+index a3621a2..69aadf1 100644
+--- a/src/ghost/ijsgutenprint.c
++++ b/src/ghost/ijsgutenprint.c
+@@ -35,8 +35,8 @@
+ #include <string.h>
+ #include <unistd.h>
+ #include <locale.h>
+-#include <ijs.h>
+-#include <ijs_server.h>
++#include <ijs/ijs.h>
++#include <ijs/ijs_server.h>
+ #include <errno.h>
+ #include <gutenprint/gutenprint-intl-internal.h>
+
+--
+2.7.3
+
diff --git a/net-print/gutenprint/gutenprint-5.2.11.ebuild b/net-print/gutenprint/gutenprint-5.2.11.ebuild
new file mode 100644
index 000000000000..bd53819aea48
--- /dev/null
+++ b/net-print/gutenprint/gutenprint-5.2.11.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Ghostscript and cups printer drivers"
+HOMEPAGE="http://gutenprint.sourceforge.net"
+SRC_URI="mirror://sourceforge/gimp-print/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cups foomaticdb gimp gtk nls readline ppds static-libs"
+REQUIRED_USE="gimp? ( gtk )"
+
+RDEPEND="app-text/ghostscript-gpl
+ dev-lang/perl
+ readline? ( sys-libs/readline:0= )
+ cups? ( >=net-print/cups-1.1.14 )
+ foomaticdb? ( net-print/foomatic-db-engine )
+ gimp? ( >=media-gfx/gimp-2.2 x11-libs/gtk+:2 )
+ gtk? ( x11-libs/gtk+:2 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+RESTRICT="test"
+
+DOCS=( AUTHORS ChangeLog NEWS README doc/gutenprint-users-manual.{pdf,odt} )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.2.4-CFLAGS.patch
+ "${FILESDIR}"/${PN}-5.2.10-genppd.patch # bug 382927
+ "${FILESDIR}"/${PN}-switch-from-ijs-config-to-pkg-config.patch # bug 587916
+)
+
+src_prepare() {
+ default
+
+ sed -i "s:m4local:m4extra:" Makefile.am || die
+
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" \
+ -e "s/AM_PROG_CC_STDC/AC_PROG_CC/" \
+ -i configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-test
+ --with-ghostscript
+ --disable-translated-cups-ppds
+ $(use_enable gtk libgutenprintui2)
+ $(use_with gimp gimp2)
+ $(use_with gimp gimp2-as-gutenprint)
+ $(use_with cups)
+ $(use_enable nls)
+ $(use_with readline)
+ $(use_enable static-libs static)
+ )
+
+ if use cups && use ppds; then
+ myeconfargs+=( --enable-cups-ppds --enable-cups-level3-ppds )
+ else
+ myeconfargs+=( --disable-cups-ppds )
+ fi
+
+ use foomaticdb \
+ && myeconfargs+=( --with-foomatic3 ) \
+ || myeconfargs+=( --without-foomatic )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ dodoc doc/FAQ.html
+ dodoc -r doc/gutenprintui2/html
+ rm -r "${ED}"/usr/share/gutenprint/doc || die
+
+ find "${ED}" -name '*.la' -exec rm -f '{}' + || die
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == / ]] && [[ -x /usr/sbin/cups-genppdupdate ]]; then
+ elog "Updating installed printer ppd files"
+ elog $(/usr/sbin/cups-genppdupdate)
+ else
+ elog "You need to update installed ppds manually using cups-genppdupdate"
+ fi
+}