summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Efros <powerman@powerman.name>2016-03-23 07:13:56 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-03-23 18:21:19 +0000
commit3e29597479c9438e9dac17ea101487c60c7debef (patch)
tree6b45d73ebe6913b8afb636df96ef636d13ab2d5b /net-proxy/3proxy/3proxy-0.7.1.4.ebuild
parentnet-proxy/3proxy: Version bump to 0.7.1.2 (diff)
downloadgentoo-3e29597479c9438e9dac17ea101487c60c7debef.tar.gz
gentoo-3e29597479c9438e9dac17ea101487c60c7debef.tar.bz2
gentoo-3e29597479c9438e9dac17ea101487c60c7debef.zip
net-proxy/3proxy: Version bump to 0.7.1.4
Closes: https://github.com/gentoo/gentoo/pull/1118
Diffstat (limited to 'net-proxy/3proxy/3proxy-0.7.1.4.ebuild')
-rw-r--r--net-proxy/3proxy/3proxy-0.7.1.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-proxy/3proxy/3proxy-0.7.1.4.ebuild b/net-proxy/3proxy/3proxy-0.7.1.4.ebuild
new file mode 100644
index 000000000000..556ce0adf098
--- /dev/null
+++ b/net-proxy/3proxy/3proxy-0.7.1.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A really tiny cross-platform proxy servers set"
+HOMEPAGE="http://www.3proxy.ru/"
+SRC_URI="http://3proxy.ru/${PV}/${P}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.7.1.2-gentoo.patch
+ cp Makefile.Linux Makefile || die
+ default
+}
+
+src_install() {
+ local x
+
+ cd src || die
+ dobin 3proxy
+ for x in proxy socks ftppr pop3p tcppm udppm mycrypt dighosts countersutil ; do
+ newbin ${x} ${PN}-${x}
+ [[ -f ${S}/man/${x}.8 ]] && newman "${S}"/man/${x}.8 ${PN}-${x}.8
+ done
+ cd ..
+
+ doman "${S}"/man/3proxy*.[38]
+
+ cd "${S}"
+ dodoc Readme
+ dohtml -r doc/html/*
+ docinto cfg
+ dodoc cfg/*.{txt,sample}
+ docinto cfg/sql
+ dodoc cfg/sql/*.{cfg,sql}
+}