summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-proxy/adzapper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-proxy/adzapper')
-rw-r--r--net-proxy/adzapper/Manifest1
-rw-r--r--net-proxy/adzapper/adzapper-20110915-r2.ebuild57
-rw-r--r--net-proxy/adzapper/files/20110915-flush.patch107
-rw-r--r--net-proxy/adzapper/metadata.xml6
4 files changed, 171 insertions, 0 deletions
diff --git a/net-proxy/adzapper/Manifest b/net-proxy/adzapper/Manifest
new file mode 100644
index 000000000000..d6d2587d5450
--- /dev/null
+++ b/net-proxy/adzapper/Manifest
@@ -0,0 +1 @@
+DIST adzap-20110915.tar.gz 128132 SHA256 30a66419b4e77631d303ca5ba76ad3a64fabbed1cdab01bee02f0d790431ce7a SHA512 8b3566fc708b3db3b8eaa0306f90c75a82ac001cfdc3bc925fc649481420532ddc017f1b5139fce36733d3a38b2a7a31b39872b522ba4f49c098177496d64416 WHIRLPOOL 02d4360bec08fffcf3e0719d0fdd76c6cd02c52094193ed31e5d98c25a34da2e732fd87c7c0811beaad25979074b831210454370cabbdbdb7c5868fb41966d9e
diff --git a/net-proxy/adzapper/adzapper-20110915-r2.ebuild b/net-proxy/adzapper/adzapper-20110915-r2.ebuild
new file mode 100644
index 000000000000..483969430800
--- /dev/null
+++ b/net-proxy/adzapper/adzapper-20110915-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${P/zapper/zap}
+
+inherit eutils
+
+DESCRIPTION="Redirector for squid that intercepts advertising, page counters and some web bugs"
+HOMEPAGE="http://adzapper.sourceforge.net/"
+SRC_URI="http://adzapper.sourceforge.net/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc sparc x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl"
+
+S="${WORKDIR}"/${P/per/}
+
+src_prepare() {
+ epatch "${FILESDIR}"/20110915-flush.patch
+ # update the zapper path in various scripts
+ local SCRPATH="/etc/adzapper/squid_redirect"
+ sed -i \
+ -e "s|^zapper=.*|zapper=${SCRPATH}|" \
+ -e "s|^ZAPPER=.*|ZAPPER=\"${SCRPATH}\"|" \
+ -e "s|^pidfile=.*|pidfile=/var/run/squid.pid|" \
+ -e "s|^PIDFILE=.*|PIDFILE=\"/var/run/squid.pid\"|" \
+ -e "s|^RESTARTCMD=.*|RESTARTCMD=\"/etc/init.d/squid restart\"|" \
+ scripts/wrapzap scripts/update-zapper* \
+ || die "sed updating failed."
+}
+
+src_install() {
+ exeinto /etc/adzapper
+ doexe \
+ scripts/wrapzap \
+ scripts/zapchain \
+ adblock-plus/adblockplus2adzapper.py
+ newexe scripts/squid_redirect-nodata squid_redirect
+
+ insinto /etc/adzapper
+ doins scripts/update-zapper*
+
+ insinto /var/www/localhost/htdocs/zap
+ doins zaps/*
+}
+
+pkg_postinst() {
+ einfo "To enable adzapper, add the following lines to /etc/squid/squid.conf:"
+ einfo " url_rewrite_program /etc/adzapper/wrapzap"
+ einfo " url_rewrite_children 10"
+}
diff --git a/net-proxy/adzapper/files/20110915-flush.patch b/net-proxy/adzapper/files/20110915-flush.patch
new file mode 100644
index 000000000000..3fb4ce913db0
--- /dev/null
+++ b/net-proxy/adzapper/files/20110915-flush.patch
@@ -0,0 +1,107 @@
+--- a/scripts/squid_redirect-nodata
++++ b/scripts/squid_redirect-nodata
+@@ -31,7 +31,7 @@
+
+ use POSIX ":sys_wait_h";
+ use Socket;
+-require 'flush.pl';
++use IO::Handle;
+
+ $::IOSIZE=1024;
+
+@@ -232,7 +232,7 @@
+ {
+ if (defined $::LogFile)
+ { print LOGFILE $_;
+- flush(LOGFILE);
++ LOGFILE->flush();;
+ }
+ chomp;
+
+@@ -259,7 +259,7 @@
+ }
+ }
+
+- flush(STDOUT);
++ STDOUT->flush();
+ }
+
+ exit 0;
+@@ -789,14 +789,16 @@
+ }
+
+ # dispatch request and headers
+- printflush(GCHILD_WRITE,"$method $uri $v1 $v2\n")
++ print GCHILD_WRITE "$method $uri $v1 $v2\n"
+ || die "tell grandchild the request: $!";
++ GCHILD_WRITE->flush();
+
+ print PROXY "$method $uri HTTP/$v1.$v2\r\n";
+ for my $H (@hdrs)
+ { print PROXY $H->[0], ":", $H->[1], "\r\n";
+ }
+- printflush(PROXY,"\r\n");
++ print PROXY "\r\n";
++ PROXY->flush();
+ ##warn "[$$]: sent rq to proxy\n";
+
+ proxy_copybody(CONN,PROXY,$method,$persist,\@hdrs)
+@@ -965,8 +967,9 @@
+ }
+
+ warn "[$child:$$]: pass response to parent\n";
+- printflush(TOCHILD,($persist ? PERSIST : CLOSE)." $code $info")
++ print TOCHILD ($persist ? PERSIST : CLOSE)." $code $info"
+ || die "[$child:$$]: print(TOCHILD) fails: $!";
++ TOCHILD->flush();
+ warn "[$child:$$]: told parent, passing response to client\n";
+
+ # copy to child
+@@ -974,7 +977,8 @@
+ for my $H (@hdrs)
+ { print CONN $H->[0], ":", $H->[1], "\r\n";
+ }
+- printflush(CONN,"\r\n");
++ print CONN "\r\n";
++ CONN->flush();
+
+ # see RFC2616 section 10
+ if (
+@@ -1050,11 +1054,13 @@
+ )
+ {
+ ##warn "[$$]: read ".length($_)." bytes of request body\n";
+- if (! printflush($to,$_))
+- { warn "$::cmd: [$$]: printflush($to,..): $!";
++ $to->autoflush(1);
++ if (! print $to $_)
++ { warn "$::cmd: [$$]: print $to ..): $!";
+ $ok=0;
+ last COPY;
+ }
++ $to->autoflush(0);
+ $cl-=length if defined $cl;
+ }
+ warn "[$$]: finished unchunked body, ok=$ok";
+@@ -1083,10 +1089,10 @@
+ { print $to $_;
+ $chunksize-=length;
+ }
+- flush($to);
++ $to->flush();
+ }
+
+- flush($to);
++ $to->flush();
+
+ # pass trailer headers
+ while (defined($_=<$from>) && !/^\r?\n/)
+@@ -1096,7 +1102,7 @@
+ { ##warn "[$$]: final trailer: $_";
+ print $to $_;
+ }
+- flush($to);
++ $to->flush();
+
+ return (1,"");
+ }
diff --git a/net-proxy/adzapper/metadata.xml b/net-proxy/adzapper/metadata.xml
new file mode 100644
index 000000000000..b0b62517f3e0
--- /dev/null
+++ b/net-proxy/adzapper/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+<longdescription>Redirector for squid that intercepts advertising, page counters and some web bugs</longdescription>
+</pkgmetadata>