summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2020-09-04 13:03:50 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-10-09 10:25:14 +0300
commit8b91c42f9c41aa14d2510d548f8e1d28f66cd3b4 (patch)
tree197eb8ba3e13618d169cb9f123acfcb3abbd13df /net-proxy/mitmproxy
parentsys-kernel/pf-sources: bump to 5.8-pf7 (diff)
downloadgentoo-8b91c42f9c41aa14d2510d548f8e1d28f66cd3b4.tar.gz
gentoo-8b91c42f9c41aa14d2510d548f8e1d28f66cd3b4.tar.bz2
gentoo-8b91c42f9c41aa14d2510d548f8e1d28f66cd3b4.zip
net-proxy/mitmproxy: Disable flaky tests
Issue: https://github.com/mitmproxy/mitmproxy/issues/4136 Closes: https://bugs.gentoo.org/740336 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Matt Smith <matt@offtopica.uk> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-proxy/mitmproxy')
-rw-r--r--net-proxy/mitmproxy/mitmproxy-5.2.ebuild16
1 files changed, 16 insertions, 0 deletions
diff --git a/net-proxy/mitmproxy/mitmproxy-5.2.ebuild b/net-proxy/mitmproxy/mitmproxy-5.2.ebuild
index d5ba12b4c7c2..3a6b3954f6d4 100644
--- a/net-proxy/mitmproxy/mitmproxy-5.2.ebuild
+++ b/net-proxy/mitmproxy/mitmproxy-5.2.ebuild
@@ -68,8 +68,24 @@ python_prepare_all() {
# remove failing test
sed -i 's/test_get_version/_&/g' test/mitmproxy/test_version.py || die
+ # https://github.com/mitmproxy/mitmproxy/issues/4136
+ # https://bugs.gentoo.org/740336
+ rm test/mitmproxy/addons/test_termlog.py || die
+
# requires asynctest
rm test/mitmproxy/addons/test_readfile.py || die
+ # Passes with OpenSSL 1.1.1g, fails with OpenSSL 1.1.1h
+ # https://github.com/gentoo/gentoo/pull/17411#discussion_r497270699
+ sed \
+ -e 's/test_mode_none_should_pass_without_sni/_&/g' \
+ -e 's/test_mode_strict_w_pemfile_should_pass/_&/g' \
+ -e 's/test_mode_strict_w_confdir_should_pass/_&/g' \
+ -i test/mitmproxy/net/test_tcp.py || die
+ sed \
+ -e 's/test_verification_w_confdir/_&/g' \
+ -e 's/test_verification_w_pemfile/_&/g' \
+ -i test/mitmproxy/proxy/test_server.py || die
+
distutils-r1_python_prepare_all
}