summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2017-06-06 22:50:42 +0800
committerYixun Lan <dlan@gentoo.org>2017-06-06 22:53:23 +0800
commit03b80f298609e2db3f5a32ef0c391ab4378b4567 (patch)
tree2c3153d1935744da2755b30570e27c1589291340 /net-proxy/shadowsocks-libev/shadowsocks-libev-3.0.6.ebuild
parentmedia-libs/opencv: disable pch for gcc-6.0 bug #617654 (diff)
downloadgentoo-03b80f298609e2db3f5a32ef0c391ab4378b4567.tar.gz
gentoo-03b80f298609e2db3f5a32ef0c391ab4378b4567.tar.bz2
gentoo-03b80f298609e2db3f5a32ef0c391ab4378b4567.zip
net-proxy/shadowsocks-libev: version bump, 3.0.6
1) drop USE=system-libs, use bundled libbloom, libcork, libipset 2) drop crypto (openssl, polarssl), fallback mbedtls Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-proxy/shadowsocks-libev/shadowsocks-libev-3.0.6.ebuild')
-rw-r--r--net-proxy/shadowsocks-libev/shadowsocks-libev-3.0.6.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/net-proxy/shadowsocks-libev/shadowsocks-libev-3.0.6.ebuild b/net-proxy/shadowsocks-libev/shadowsocks-libev-3.0.6.ebuild
new file mode 100644
index 000000000000..136bc28dcc32
--- /dev/null
+++ b/net-proxy/shadowsocks-libev/shadowsocks-libev-3.0.6.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils systemd
+
+DESCRIPTION="A lightweight secured SOCKS5 proxy for embedded devices and low end boxes"
+HOMEPAGE="https://github.com/shadowsocks/shadowsocks-libev"
+
+#repack with git submodule populated: libbloom, libcork, libipset
+SRC_URI="https://dev.gentoo.org/~dlan/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="net-libs/mbedtls
+ >=dev-libs/libsodium-1.0.8
+ dev-libs/libev
+ net-libs/udns
+ dev-libs/libpcre
+ "
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )
+ "
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=" \
+ $(use_enable debug assert) \
+ "
+ use doc || myconf+="--disable-documentation"
+ econf ${myconf}
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+
+ dodir "/etc/${PN}"
+ insinto "/etc/${PN}"
+ newins "${FILESDIR}/shadowsocks.json" shadowsocks.json
+
+ newinitd "${FILESDIR}/shadowsocks.initd" shadowsocks
+ dosym /etc/init.d/shadowsocks /etc/init.d/shadowsocks.server
+ dosym /etc/init.d/shadowsocks /etc/init.d/shadowsocks.client
+ dosym /etc/init.d/shadowsocks /etc/init.d/shadowsocks.redir
+ dosym /etc/init.d/shadowsocks /etc/init.d/shadowsocks.tunnel
+
+ dodoc -r acl
+
+ systemd_newunit "${FILESDIR}/${PN}-local_at.service" "${PN}-local@.service"
+ systemd_newunit "${FILESDIR}/${PN}-server_at.service" "${PN}-server@.service"
+ systemd_newunit "${FILESDIR}/${PN}-redir_at.service" "${PN}-redir@.service"
+ systemd_newunit "${FILESDIR}/${PN}-tunnel_at.service" "${PN}-tunnel@.service"
+}
+
+pkg_setup() {
+ elog "You need to choose the mode"
+ elog " server: rc-update add shadowsocks.server default"
+ elog " client: rc-update add shadowsocks.client default"
+ elog " redir: rc-update add shadowsocks.redir default"
+ elog " tunnel: rc-update add shadowsocks.tunnel default"
+}