summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-27 04:47:39 +0000
committerSam James <sam@gentoo.org>2020-12-27 04:47:40 +0000
commit3ae48278c2359865ae50c5c16af770d907a105b9 (patch)
treee4c150592330bf0b36c13afc129f8eacd88c82f5 /net-proxy/sshuttle
parentmedia-libs/bcg729: Stabilize 1.1.1 arm64, #761703 (diff)
downloadgentoo-3ae48278c2359865ae50c5c16af770d907a105b9.tar.gz
gentoo-3ae48278c2359865ae50c5c16af770d907a105b9.tar.bz2
gentoo-3ae48278c2359865ae50c5c16af770d907a105b9.zip
net-proxy/sshuttle: bump to 1.0.4
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-proxy/sshuttle')
-rw-r--r--net-proxy/sshuttle/Manifest1
-rw-r--r--net-proxy/sshuttle/sshuttle-1.0.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-proxy/sshuttle/Manifest b/net-proxy/sshuttle/Manifest
index 0f7ae1c7a3f4..be0ffbe3b4d2 100644
--- a/net-proxy/sshuttle/Manifest
+++ b/net-proxy/sshuttle/Manifest
@@ -1 +1,2 @@
DIST sshuttle-1.0.3.tar.gz 79216 BLAKE2B fefc93654c4991bad54de6b156916ee656f7d460d609c5333b15c601e9b2b0169c1670e911988dfa8290a5bc1885d94f9ec9656066d2b13da0b4d53d9739297a SHA512 22132dba0e6b7dd835f0af1368a5e8c3a95db66e11ffec9ec3cae72cc7ed4eec13580eeceb08071bee12cae8169852772578f8e29a69583cb79c71d350f474bb
+DIST sshuttle-1.0.4.tar.gz 82241 BLAKE2B 7c8ff612b3762e26d2f29667fe4399ce2f6d51b7adff17af861644464121276480401d3a0127f8c14ab1f200829a8ed40c471620674122318b9204d573cb7fd6 SHA512 f612f193b1ad2f94c0fc5fa3642adcce7bcf62da093152987efd947e4b353694b0571fd3a221d44fe2e7b215782169cf728f3f398ec3e4d1ad25f5149e5a4d2c
diff --git a/net-proxy/sshuttle/sshuttle-1.0.4.ebuild b/net-proxy/sshuttle/sshuttle-1.0.4.ebuild
new file mode 100644
index 000000000000..6f5b0c2088bc
--- /dev/null
+++ b/net-proxy/sshuttle/sshuttle-1.0.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 linux-info
+
+DESCRIPTION="Transparent proxy server that works as a poor man's VPN using ssh"
+HOMEPAGE="https://github.com/sshuttle/sshuttle https://pypi.org/project/sshuttle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/sphinx
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="|| ( net-firewall/iptables net-firewall/nftables )"
+
+CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~IP_NF_MATCH_TTL ~NF_NAT"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't run tests via setup.py pytest
+ sed -i "/setup_requires=/s/'pytest-runner'//" setup.py || die
+
+ # don't require pytest-cov when running tests
+ sed -i "s/^addopts =/#\0/" setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ emake -j1 -C docs html man
+}
+
+python_install_all() {
+ HTML_DOCS=( docs/_build/html/. )
+ doman docs/_build/man/*
+ distutils-r1_python_install_all
+}