summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-01-22 10:33:50 +0000
committerSam James <sam@gentoo.org>2021-01-24 00:34:08 +0000
commit1cd3b14db3b89fcc4a9f586bc9af9f89e2fec3a0 (patch)
treebbe7ea8badbc98b2c1934130fde8f3358739c126 /net-proxy
parentmedia-libs/opencore-amr: Drop 0.1.5 (r0), autotools-multilib-- (diff)
downloadgentoo-1cd3b14db3b89fcc4a9f586bc9af9f89e2fec3a0.tar.gz
gentoo-1cd3b14db3b89fcc4a9f586bc9af9f89e2fec3a0.tar.bz2
gentoo-1cd3b14db3b89fcc4a9f586bc9af9f89e2fec3a0.zip
net-proxy/mitmproxy: Bump to 6.0.2
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Matt Smith <matt@offtopica.uk> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/mitmproxy/Manifest1
-rw-r--r--net-proxy/mitmproxy/mitmproxy-6.0.2.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/net-proxy/mitmproxy/Manifest b/net-proxy/mitmproxy/Manifest
index 19f7154e1ffe..1f7d185f3789 100644
--- a/net-proxy/mitmproxy/Manifest
+++ b/net-proxy/mitmproxy/Manifest
@@ -2,3 +2,4 @@ DIST mitmproxy-5.1.1.tar.gz 27223155 BLAKE2B 38369eb07c41bde9f8e8c246ab5cc4fc6ed
DIST mitmproxy-5.2.tar.gz 27251381 BLAKE2B d6bc5de8a3840a880664f52e011736cb640d324c6aa3846d4f2b3c2fc0d49467ab8ad3e8268a591cbe19d9f6dda5acc37fa2de705b4de1c1920b5003e10ea457 SHA512 6073c73b24618d6f64c4e99f199ebb6bc4157a3f83bfa7aff10a113f8dde823715e95bdf4202a1526dc0856d120858d32842b814327c3b98452b629fccb1790d
DIST mitmproxy-5.3.0.tar.gz 27272534 BLAKE2B 2a35824616ca0a63a9e432a110adf14423df229568636456aa9d3959fc306b9ba30d8069c78cbc7c5950ef3e44526882b028c6ed05af417ef667b07215c258c6 SHA512 3f52f5285869de49c7c04ef9b6c0f3ef66689eb45fb6f9e971111049bf1aa0777e3e84b51f7031c1bdf105ce3f17fa4b03036d72617985b92996c6eea7566c38
DIST mitmproxy-6.0.1.tar.gz 27272092 BLAKE2B ecc01d0d498eb802baabe8e361c04c0826a7c31f4d5369ee34e655ee7741beb89098a03bbd5d840f21b400a7f9679c9fabb0cbee62a02a5d52949ed196d07bd9 SHA512 848ced92f16863da1c41cbb33fe9fec76b837336e2f252860de80039463b1b7527caa7928124885105c25b922a1cd26c4414f75dd4f1ae950624271d7df47023
+DIST mitmproxy-6.0.2.tar.gz 27274682 BLAKE2B 146fc4cd376e4ff02d13bf168b26868c5a33b47b30e678fb6d97df36c4b8ec9e8b9ca6e864e56c3943b231a2f2745c1abd7c58814ddf712113c2a20704a6964f SHA512 27eb5e9736891148b5ebec963a2d18de6a69b44428538d2ed1cf9a1dcdd7cbcdeeed662edb2d25521098374e2f9a29b5bb8fba8da4f77ac0d32bf7881ac70d61
diff --git a/net-proxy/mitmproxy/mitmproxy-6.0.2.ebuild b/net-proxy/mitmproxy/mitmproxy-6.0.2.ebuild
new file mode 100644
index 000000000000..ec54ddf561d8
--- /dev/null
+++ b/net-proxy/mitmproxy/mitmproxy-6.0.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1
+
+DESCRIPTION="An interactive, SSL-capable, man-in-the-middle HTTP proxy"
+HOMEPAGE="https://mitmproxy.org/"
+SRC_URI="https://github.com/mitmproxy/mitmproxy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="libressl test"
+
+RDEPEND="
+ >=app-arch/brotli-1.0.0[python,${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.2.10[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
+ >=dev-python/certifi-2015.11.20.1[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/hyper-h2-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hyperframe-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/kaitaistruct-0.7[${PYTHON_USEDEP}]
+ >=dev-python/ldap3-2.8[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.14.0[${PYTHON_USEDEP}]
+ >=dev-python/publicsuffix-2.20190205[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-20.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.16[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.3.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
+ >=dev-python/urwid-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/wsproto-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/zstandard-0.11.0[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( >=dev-libs/libressl-3.2.0:0 )
+"
+
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/hypothesis-4.50.8[${PYTHON_USEDEP}]
+ >=dev-python/parver-0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/zstandard-0.8.1[${PYTHON_USEDEP}]
+ )"
+
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # loosen dependencies
+ sed -i \
+ -e '/>/s/>.*/",/g' \
+ -e '/python_requires/d' \
+ setup.py || die
+
+ # remove failing test
+ sed -i 's/test_get_version/_&/g' test/mitmproxy/test_version.py || die
+
+ # https://github.com/mitmproxy/mitmproxy/issues/4136
+ # https://bugs.gentoo.org/740336
+ rm test/mitmproxy/addons/test_termlog.py || die
+
+ # requires asynctest
+ rm test/mitmproxy/addons/test_readfile.py || die
+
+ # Passes with OpenSSL 1.1.1g, fails with OpenSSL 1.1.1h
+ # https://github.com/gentoo/gentoo/pull/17411#discussion_r497270699
+ sed \
+ -e 's/test_mode_none_should_pass_without_sni/_&/g' \
+ -e 's/test_mode_strict_w_pemfile_should_pass/_&/g' \
+ -e 's/test_mode_strict_w_confdir_should_pass/_&/g' \
+ -i test/mitmproxy/net/test_tcp.py || die
+ sed \
+ -e 's/test_verification_w_confdir/_&/g' \
+ -e 's/test_verification_w_pemfile/_&/g' \
+ -i test/mitmproxy/proxy/test_server.py || die
+
+ distutils-r1_python_prepare_all
+}