summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-07-30 12:55:22 +0000
committerThomas Deutschmann <whissi@gentoo.org>2020-07-30 20:16:51 +0200
commit2ec3a523cbcd8d8a41cd963a4da72d68fb10c1d3 (patch)
tree5f90229b6688b97b4d5e3bbf26a39154a0b06cc4 /net-proxy
parentapp-admin/graylog: bump to 3.3.2 (diff)
downloadgentoo-2ec3a523cbcd8d8a41cd963a4da72d68fb10c1d3.tar.gz
gentoo-2ec3a523cbcd8d8a41cd963a4da72d68fb10c1d3.tar.bz2
gentoo-2ec3a523cbcd8d8a41cd963a4da72d68fb10c1d3.zip
net-proxy/hatop: bump to 0.8.0 with py3 support
Closes: https://bugs.gentoo.org/645986 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16901 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/hatop/Manifest1
-rw-r--r--net-proxy/hatop/hatop-0.8.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/net-proxy/hatop/Manifest b/net-proxy/hatop/Manifest
index 3e1a8c7e048c..e61d05cd4f68 100644
--- a/net-proxy/hatop/Manifest
+++ b/net-proxy/hatop/Manifest
@@ -1 +1,2 @@
DIST hatop-0.7.7.tar.gz 134143 BLAKE2B 549290a67463a7c6ef58e1e0a45666dded7973e679183dee0be7aaa97491c5d0e36da98e2fc62e4097fa4811ad1e620078f32019abfd83472139c43b2805be47 SHA512 879de0e13af1d1c4e86be034066fb4bbc5c1700a30abebbfb1e1d524fb50cec0fa90fe160a7b7d00bf6aedd49ab7bb8fa1447f751fae95200e850ff506feb074
+DIST hatop-0.8.0.tar.gz 134737 BLAKE2B bc5b1f878dc3ff388c788b6f4a07d9a3076ca3c2c11de15ec6d1ad17d5b2295162568791e4dc9e3edf091a08c80662ceb4d5a6d276e69dd3c96132cb78d007ee SHA512 1776da58a12835434d7b8f59582bad44fb3bf9479f05fedb45f84bc73792b331dda63f989c8b202436801a30600283ec782380e16aa75abf7643ffa5da029718
diff --git a/net-proxy/hatop/hatop-0.8.0.ebuild b/net-proxy/hatop/hatop-0.8.0.ebuild
new file mode 100644
index 000000000000..2c3f9331958c
--- /dev/null
+++ b/net-proxy/hatop/hatop-0.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="ncurses"
+
+inherit python-r1
+
+DESCRIPTION="Ncurses client and real-time monitoring and displaying of HAProxy status"
+HOMEPAGE="https://github.com/jhunt/hatop"
+SRC_URI="https://github.com/jhunt/hatop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ net-proxy/haproxy"
+
+src_install() {
+ python_foreach_impl python_doscript bin/hatop
+
+ doman man/hatop.1
+
+ dodoc CHANGES.rst KEYBINDS README.rst
+}