summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-05-09 05:57:23 -0500
committerBen Kohler <bkohler@gentoo.org>2024-05-09 06:29:43 -0500
commit39bd59e9508d0c9d0b4b5f09588afc45df6b0b3e (patch)
tree670b5514807e0aedc6d173a87b22e9d6692c7df8 /net-proxy
parentdev-java/guice: adjust ${CDEPEND} -> ${CP_DEPEND} (diff)
downloadgentoo-39bd59e9508d0c9d0b4b5f09588afc45df6b0b3e.tar.gz
gentoo-39bd59e9508d0c9d0b4b5f09588afc45df6b0b3e.tar.bz2
gentoo-39bd59e9508d0c9d0b4b5f09588afc45df6b0b3e.zip
net-proxy/tinyproxy: add 1.11.2
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/tinyproxy/Manifest1
-rw-r--r--net-proxy/tinyproxy/tinyproxy-1.11.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-proxy/tinyproxy/Manifest b/net-proxy/tinyproxy/Manifest
index 6466b36bb81d..0cb36d4f8329 100644
--- a/net-proxy/tinyproxy/Manifest
+++ b/net-proxy/tinyproxy/Manifest
@@ -1 +1,2 @@
+DIST tinyproxy-1.11.2.tar.xz 185864 BLAKE2B ae8f1cc0fcfa3f2a6b239ad1f0f34bf21843cbf85613643b221359904e672d5c28c69bcb6b61f0244c5a3e6fd901b0c24488c3b80a0aa1f95b87ff90b175dc62 SHA512 008e43b770f946965d5a3fbad1881859e30b66a3a4a97cf9982e63d81139da7a8f23937601b72f32276166cd170008cafec9231b616fc840f05cae3c1329be35
DIST tinyproxy-31339cb1615765f2fbb4ec7779400535bad6da46.tar.gz 112886 BLAKE2B 82af9f671b31c9be46624400d726e428837763ab763942c335df1aa63499e33c17384b55ea2f68790cd3b8b1e4eff3b61b40f25e1d55506ce0f0694c7cddaddb SHA512 638ae0731aa2d9f498643aa883871f7b3978c68ee5098fcbeb234234e5432d1a833c33fb0cc1944504369bdf975baa0bd6166664c340825b9b55664d8afdf94c
diff --git a/net-proxy/tinyproxy/tinyproxy-1.11.2.ebuild b/net-proxy/tinyproxy/tinyproxy-1.11.2.ebuild
new file mode 100644
index 000000000000..4cbde7982d63
--- /dev/null
+++ b/net-proxy/tinyproxy/tinyproxy-1.11.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd tmpfiles
+
+DESCRIPTION="A lightweight HTTP/SSL proxy"
+HOMEPAGE="https://github.com/tinyproxy/tinyproxy/"
+SRC_URI="https://github.com/tinyproxy/tinyproxy/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="test debug +filter-proxy reverse-proxy transparent-proxy
++upstream-proxy +xtinyproxy-header"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( xtinyproxy-header )"
+
+DEPEND="
+ acct-group/tinyproxy
+ acct-user/tinyproxy
+"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s|nobody|${PN}|g" \
+ etc/${PN}.conf.in || die "sed failed"
+
+ sed -i -e "s# -Wp,-D_FORTIFY_SOURCE=2##" configure.ac || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable filter-proxy filter) \
+ $(use_enable reverse-proxy reverse) \
+ $(use_enable transparent-proxy transparent) \
+ $(use_enable upstream-proxy upstream) \
+ $(use_enable xtinyproxy-header xtinyproxy) \
+ --localstatedir=/var
+}
+
+src_test() {
+ # The make check target does not run the test suite
+ emake test
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS README.md
+
+ diropts -m0775 -o ${PN} -g ${PN}
+ keepdir /var/log/${PN}
+
+ newinitd "${FILESDIR}"/${PN}-1.10.0.initd tinyproxy
+ systemd_newunit "${FILESDIR}"/${PN}-1.10.0.service tinyproxy.service
+ dotmpfiles "${FILESDIR}"/${PN}.tmpfiles.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.tmpfiles.conf
+
+ elog "For filtering domains and URLs, enable filter option in the configuration"
+ elog "file and add them to the filter file (one domain or URL per line)."
+}