summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2019-11-27 10:27:57 +0100
committerChristian Ruppert <idl0r@gentoo.org>2019-11-27 10:51:37 +0100
commitfd380f32c4a4c524306c7724a4e105f182439d09 (patch)
tree7f119d724efddee1e08865f3f6e88e2f6e08d170 /net-proxy
parentnet-proxy/haproxy: Cleanup old versions (diff)
downloadgentoo-fd380f32c4a4c524306c7724a4e105f182439d09.tar.gz
gentoo-fd380f32c4a4c524306c7724a4e105f182439d09.tar.bz2
gentoo-fd380f32c4a4c524306c7724a4e105f182439d09.zip
net-proxy/haproxy: Update haproxy-2.0.9999.ebuild
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Christian Ruppert <idl0r@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/haproxy/haproxy-2.0.9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-proxy/haproxy/haproxy-2.0.9999.ebuild b/net-proxy/haproxy/haproxy-2.0.9999.ebuild
index c920acfec53a..06e10c936692 100644
--- a/net-proxy/haproxy/haproxy-2.0.9999.ebuild
+++ b/net-proxy/haproxy/haproxy-2.0.9999.ebuild
@@ -20,8 +20,8 @@ fi
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-IUSE="+crypt doc examples libressl slz +net_ns +pcre pcre-jit pcre2 pcre2-jit ssl
-systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
+IUSE="+crypt doc examples libressl slz +net_ns +pcre pcre-jit pcre2 pcre2-jit prometheus-exporter
+ssl systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
pcre2-jit? ( pcre2 )
pcre? ( !pcre2 )
@@ -98,8 +98,12 @@ src_compile() {
# For now, until the strict-aliasing breakage will be fixed
append-cflags -fno-strict-aliasing
+ if use prometheus-exporter; then
+ EXTRA_OBJS="contrib/prometheus-exporter/service-prometheus.o"
+ fi
+
# HAProxy really needs some of those "SPEC_CFLAGS", like -fno-strict-aliasing
- emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args[@]}
+ emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) EXTRA_OBJS="${EXTRA_OBJS}" ${args[@]}
emake -C contrib/systemd SBINDIR=/usr/sbin
if use tools ; then