summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2020-12-29 15:50:49 +0200
committerSam James <sam@gentoo.org>2021-01-04 16:32:48 +0000
commit29491675582613ff3ffb5d0021ff1db0c147f49f (patch)
tree410ba6a55ee4d0a2ca3953eaaa65a3f5deb5cbc0 /net-voip
parentnet-libs/pjproject: drop old versions. (diff)
downloadgentoo-29491675582613ff3ffb5d0021ff1db0c147f49f.tar.gz
gentoo-29491675582613ff3ffb5d0021ff1db0c147f49f.tar.bz2
gentoo-29491675582613ff3ffb5d0021ff1db0c147f49f.zip
net-voip/yate: version bump to 6.2.0
Includes fixups for USE=mysql. DISCLAIMER: I have no interest in yate itself. However, change is requird for ILBC cleanup. Given the state of the open bugs, I'd actually recommend last-riting yate and yatebts. Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://bugs.gentoo.org/666012 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/yate/Manifest1
-rw-r--r--net-voip/yate/files/yate-6.2.0-my_bool.patch21
-rw-r--r--net-voip/yate/yate-6.2.0.ebuild93
3 files changed, 115 insertions, 0 deletions
diff --git a/net-voip/yate/Manifest b/net-voip/yate/Manifest
index e727a56602c6..e1c8dbcbeea0 100644
--- a/net-voip/yate/Manifest
+++ b/net-voip/yate/Manifest
@@ -1,2 +1,3 @@
DIST yate-6.0.0-1.tar.gz 6039879 BLAKE2B d6d6398f7a91543c44435ab3cd73eaa1cca59c098c8b3ddbe66f5b058c45ab6cfc74533cc184235a44b499046331fa467961fc6fcd291418b24918d88f1037b9 SHA512 3a56bf5cd20c8452063f968de5d7993a926463b736686cd3df7a152d57be07fabeef9cebc91018ff0ad5b726157a9a9a0240969a752e7844f6431618b4eec53a
DIST yate-6.1.0-1.tar.gz 6074737 BLAKE2B a59445b546730c1e9756e634c663f3ecc6875056ade1272afe9fc2a79c591515c7472b892a593df5c3001be6c822093fef0a16822b7537e477d064c06d849e03 SHA512 e23c9d45b98222cc4499833ef242e011b6d8c32213e9716958349bcbe74b1c168351b04ad9633073127d9463cda83c3236bd5640c0987cc14fd8f02349b4b293
+DIST yate-6.2.0-1.tar.gz 6114538 BLAKE2B cc96c894192d99bebd6bfe4dc6fb137298e880f03d2ad0482f98bcac20e35b17d94e7dcf159fdc28c7ce68d8a7e8856ba7648d3fe8ef7815c0bd3690764506e2 SHA512 e84446ec5df58408b8b0065a59f21a5dd619560844ebdffbee3a7c927f45a18c5dd78858a48b8641177e29b2370d3b0f9e490db5417b4dd3c395fd7e02bd1eb0
diff --git a/net-voip/yate/files/yate-6.2.0-my_bool.patch b/net-voip/yate/files/yate-6.2.0-my_bool.patch
new file mode 100644
index 000000000000..a2ddb857f397
--- /dev/null
+++ b/net-voip/yate/files/yate-6.2.0-my_bool.patch
@@ -0,0 +1,21 @@
+--- yate.o/modules/server/mysqldb.cpp 2020-03-03 18:03:34.000000000 +0200
++++ yate/modules/server/mysqldb.cpp 2020-12-29 15:38:56.717897678 +0200
+@@ -22,6 +22,7 @@
+ #include <yatephone.h>
+
+ #include <stdio.h>
++#include <stdbool.h>
+ #include <mysql.h>
+
+ #ifndef CLIENT_MULTI_STATEMENTS
+@@ -508,8 +509,8 @@
+
+ #ifdef MYSQL_OPT_RECONNECT
+ // this option must be set after connect - bug in mysql client library
+- my_bool reconn = 1;
+- mysql_options(mySqlConn->m_conn,MYSQL_OPT_RECONNECT,(const char*)&reconn);
++ bool reconn = 1;
++ mysql_options(mySqlConn->m_conn,MYSQL_OPT_RECONNECT,&reconn);
+ #endif
+
+ #ifdef HAVE_MYSQL_SET_CHARSET
diff --git a/net-voip/yate/yate-6.2.0.ebuild b/net-voip/yate/yate-6.2.0.ebuild
new file mode 100644
index 000000000000..6b2c3af25127
--- /dev/null
+++ b/net-voip/yate/yate-6.2.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="The Yate AV Suite"
+HOMEPAGE="http://yate.null.ro/"
+
+if [[ ${PV} == 9999 ]] ; then
+ ESVN_REPO_URI="http://voip.null.ro/svn/yate/trunk"
+ inherit subversion
+ KEYWORDS=""
+else
+ SRC_URI="http://voip.null.ro/tarballs/${PN}6/${P}-1.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S="${WORKDIR}/${PN}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="doc cpu_flags_x86_sse2 sctp dahdi zaptel wpcard tdmcard wanpipe +ilbc +ilbc-webrtc +isac-float isac-fixed postgres mysql +gsm +speex spandsp +ssl +zlib amrnb"
+
+RDEPEND="
+ postgres? ( dev-db/postgresql:* )
+ mysql? ( dev-db/mysql-connector-c:= )
+ gsm? ( media-sound/gsm )
+ speex? ( media-libs/speex )
+ ssl? ( dev-libs/openssl:0 )
+ zlib? ( sys-libs/zlib )
+ ilbc? ( media-libs/libilbc )
+ spandsp? ( >=media-libs/spandsp-0.0.3 )
+ dahdi? ( net-misc/dahdi )
+"
+DEPEND="doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+ ${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-6.0.0-dont-mess-with-cflags.patch"
+ "${FILESDIR}/${PN}-6.2.0-my_bool.patch"
+)
+
+src_prepare() {
+ default_src_prepare
+ eautoreconf
+ ./yate-config.sh || die
+}
+
+#fdsize, inline, rtti: keep default values
+#internalregex: use system
+#coredumper: not in the tree, bug 118716
+#wanpipe, wphwec: not in the tree, bug 188939
+#amrnb: not in tree!
+#zaptel: ??
+src_configure() {
+ econf \
+ --with-archlib=$(get_libdir) \
+ --without-libqt4 \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable sctp) \
+ $(use_enable dahdi) \
+ $(use_enable zaptel) \
+ $(use_enable wpcard) \
+ $(use_enable tdmcard) \
+ $(use_enable wanpipe) \
+ $(use_enable ilbc) \
+ $(use_enable ilbc-webrtc) \
+ $(use_enable isac-float) \
+ $(use_enable isac-fixed) \
+ $(use_with postgres libpq) \
+ $(use_with mysql) \
+ $(use_with gsm libgsm) \
+ $(use_with speex libspeex) \
+ $(use_with amrnb) \
+ $(use_with spandsp) \
+ $(use_with ssl openssl)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ if use doc; then
+ emake DESTDIR="${ED}" install
+ else
+ emake DESTDIR="${ED}" install-noapi
+ fi
+ newinitd "${FILESDIR}"/yate.initd yate
+ newconfd "${FILESDIR}"/yate.confd yate
+}