summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-04 17:13:26 +0000
committerSam James <sam@gentoo.org>2021-01-04 17:14:15 +0000
commitb9fc633956cc2edb26e8b726da14bb80abf9d6f7 (patch)
treefdd0f7a22e161673d33077bd1d1f50ef7d824c55 /net-voip
parentnet-proxy/sqtop: mark myself as proxy (diff)
downloadgentoo-b9fc633956cc2edb26e8b726da14bb80abf9d6f7.tar.gz
gentoo-b9fc633956cc2edb26e8b726da14bb80abf9d6f7.tar.bz2
gentoo-b9fc633956cc2edb26e8b726da14bb80abf9d6f7.zip
net-voip/sipvicious: moved from dev-python/sipvicious
It's written in Python but it's not a library. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/sipvicious/Manifest1
-rw-r--r--net-voip/sipvicious/metadata.xml13
-rw-r--r--net-voip/sipvicious/sipvicious-0.3.0.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/net-voip/sipvicious/Manifest b/net-voip/sipvicious/Manifest
new file mode 100644
index 000000000000..31115c2a9f19
--- /dev/null
+++ b/net-voip/sipvicious/Manifest
@@ -0,0 +1 @@
+DIST sipvicious-0.3.0.tar.gz 43097 BLAKE2B 5ddcdf775db0ade6e61e77009c7991d8523db02dbdd6e8588c23f5cd6f4d2868dd1d78e7f17322cde67414b4eb2b8c89f2d4ee0079487e5f5f7ee75f4759adf5 SHA512 35aa3ea7d3cfd6f84716cd95a263357881196eaa180375d1f0a392a1478292ba9a8bf6cd53888448523f7faa447c82cc43fb1ef6c105a0e93e6c7854a51da172
diff --git a/net-voip/sipvicious/metadata.xml b/net-voip/sipvicious/metadata.xml
new file mode 100644
index 000000000000..d5f9bc4288a3
--- /dev/null
+++ b/net-voip/sipvicious/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jaco@uls.co.za</email>
+ <name>Jaco Kroon</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ <description>Proxy</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-voip/sipvicious/sipvicious-0.3.0.ebuild b/net-voip/sipvicious/sipvicious-0.3.0.ebuild
new file mode 100644
index 000000000000..cd684b870f12
--- /dev/null
+++ b/net-voip/sipvicious/sipvicious-0.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="SIPVicious is a SIP security package"
+HOMEPAGE="https://github.com/EnableSecurity/sipvicious/wiki"
+SRC_URI="https://github.com/EnableSecurity/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ ')"