summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-06-19 18:01:22 +0200
committerJohannes Huber <johu@gentoo.org>2018-06-19 18:02:15 +0200
commite1f0e87b5ec78ff62351b20943baba74cc6fe808 (patch)
tree6a5645628835aed5577eb9c442e26bcbe5d2938c /net-vpn/openfortivpn/openfortivpn-1.7.1.ebuild
parentnet-mail/mailutils: remove old (diff)
downloadgentoo-e1f0e87b5ec78ff62351b20943baba74cc6fe808.tar.gz
gentoo-e1f0e87b5ec78ff62351b20943baba74cc6fe808.tar.bz2
gentoo-e1f0e87b5ec78ff62351b20943baba74cc6fe808.zip
net-vpn/openfortivpn: Version bump 1.7.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-vpn/openfortivpn/openfortivpn-1.7.1.ebuild')
-rw-r--r--net-vpn/openfortivpn/openfortivpn-1.7.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-vpn/openfortivpn/openfortivpn-1.7.1.ebuild b/net-vpn/openfortivpn/openfortivpn-1.7.1.ebuild
new file mode 100644
index 000000000000..bfc317510e66
--- /dev/null
+++ b/net-vpn/openfortivpn/openfortivpn-1.7.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools linux-info
+
+DESCRIPTION="A Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl"
+
+DEPEND="
+ net-dialup/ppp
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}