summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 04:07:34 +0100
committerSam James <sam@gentoo.org>2021-07-31 23:13:37 +0100
commitd3f64760c2dbf2283babe27722192dbca8612c89 (patch)
treeecfea655349a46631f35d77d53b4b02181232c8c /net-vpn/openvpn
parentnet-vpn/libreswan: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-d3f64760c2dbf2283babe27722192dbca8612c89.tar.gz
gentoo-d3f64760c2dbf2283babe27722192dbca8612c89.tar.bz2
gentoo-d3f64760c2dbf2283babe27722192dbca8612c89.zip
net-vpn/openvpn: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Revbump because the new tmpfiles inherit adds a new dependency (virtual/tmpfiles). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn/openvpn')
-rw-r--r--net-vpn/openvpn/openvpn-2.5.2-r2.ebuild (renamed from net-vpn/openvpn/openvpn-2.5.2-r1.ebuild)4
-rw-r--r--net-vpn/openvpn/openvpn-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/net-vpn/openvpn/openvpn-2.5.2-r1.ebuild b/net-vpn/openvpn/openvpn-2.5.2-r2.ebuild
index b446547b08c2..e09e6ac634dc 100644
--- a/net-vpn/openvpn/openvpn-2.5.2-r1.ebuild
+++ b/net-vpn/openvpn/openvpn-2.5.2-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools flag-o-matic systemd linux-info
+inherit autotools flag-o-matic systemd linux-info tmpfiles
DESCRIPTION="Robust and highly flexible tunneling application compatible with many OSes"
HOMEPAGE="https://openvpn.net/"
@@ -140,6 +140,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process openvpn.conf
+
if use x64-macos; then
elog "You might want to install tuntaposx for TAP interface support:"
elog "http://tuntaposx.sourceforge.net"
diff --git a/net-vpn/openvpn/openvpn-9999.ebuild b/net-vpn/openvpn/openvpn-9999.ebuild
index ac64c3e3d3c7..d5d643edb2fb 100644
--- a/net-vpn/openvpn/openvpn-9999.ebuild
+++ b/net-vpn/openvpn/openvpn-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools flag-o-matic systemd linux-info
+inherit autotools flag-o-matic systemd linux-info tmpfiles
DESCRIPTION="Robust and highly flexible tunneling application compatible with many OSes"
HOMEPAGE="https://openvpn.net/"
@@ -139,6 +139,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process openvpn.conf
+
if use x64-macos ; then
elog "You might want to install tuntaposx for TAP interface support:"
elog "http://tuntaposx.sourceforge.net"