summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorILMostro <ilmostro7@gmail.com>2021-01-21 09:45:06 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-01-21 10:07:56 +0200
commitfa4b18775b90deb7b3a5f70e0752637eb2d7c605 (patch)
treed023cc8da510da142f80c853acedd41d03d2eb66 /net-vpn/protonvpn-cli/protonvpn-cli-2.2.4.ebuild
parentmedia-sound/qsynth: fixed path to the patch in live (diff)
downloadgentoo-fa4b18775b90deb7b3a5f70e0752637eb2d7c605.tar.gz
gentoo-fa4b18775b90deb7b3a5f70e0752637eb2d7c605.tar.bz2
gentoo-fa4b18775b90deb7b3a5f70e0752637eb2d7c605.zip
net-vpn/protonvpn-cli: 2.2.4 vbump
Signed-off-by: Amel Hodzic <ilmostro7@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18148 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-vpn/protonvpn-cli/protonvpn-cli-2.2.4.ebuild')
-rw-r--r--net-vpn/protonvpn-cli/protonvpn-cli-2.2.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-vpn/protonvpn-cli/protonvpn-cli-2.2.4.ebuild b/net-vpn/protonvpn-cli/protonvpn-cli-2.2.4.ebuild
new file mode 100644
index 000000000000..75c1d0f3cec3
--- /dev/null
+++ b/net-vpn/protonvpn-cli/protonvpn-cli-2.2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A VPN command-line tool from protonvpn - python rewrite"
+HOMEPAGE="https://protonvpn.com https://github.com/ProtonVPN/protonvpn-cli-ng"
+SRC_URI="https://github.com/ProtonVPN/linux-cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pythondialog:0[${PYTHON_USEDEP}]
+ net-vpn/openvpn"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/linux-cli-${PV}"
+
+DOCS=( CHANGELOG.md README.md USAGE.md )