summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-08-27 10:33:47 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-08-27 10:33:47 -0400
commit57a36e030ff7e0e37a1dcb7dfaa6ffaecda6e19a (patch)
tree0d03c1c556e389205e107ffea016c4b18dfeff6d /net-vpn/tinc/tinc-1.0.36.ebuild
parentnet-misc/remmina: bump to 1.3.6 (diff)
downloadgentoo-57a36e030ff7e0e37a1dcb7dfaa6ffaecda6e19a.tar.gz
gentoo-57a36e030ff7e0e37a1dcb7dfaa6ffaecda6e19a.tar.bz2
gentoo-57a36e030ff7e0e37a1dcb7dfaa6ffaecda6e19a.zip
net-vpn/tinc: version bump to 1.0.36
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-vpn/tinc/tinc-1.0.36.ebuild')
-rw-r--r--net-vpn/tinc/tinc-1.0.36.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-vpn/tinc/tinc-1.0.36.ebuild b/net-vpn/tinc/tinc-1.0.36.ebuild
new file mode 100644
index 000000000000..d239ba672fd9
--- /dev/null
+++ b/net-vpn/tinc/tinc-1.0.36.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+
+SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="libressl +lzo uml vde +zlib"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ lzo? ( dev-libs/lzo:2 )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ vde? ( net-misc/vde )"
+
+src_configure() {
+ econf \
+ --enable-jumbograms \
+ --disable-tunemu \
+ $(use_enable lzo) \
+ $(use_enable uml) \
+ $(use_enable vde) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodir /etc/tinc
+ dodoc AUTHORS NEWS README THANKS
+ doconfd "${FILESDIR}"/tinc.networks
+ newconfd "${FILESDIR}"/tincd.conf tincd
+ newinitd "${FILESDIR}"/tincd-r1 tincd
+ systemd_newunit "${FILESDIR}"/tincd_at.service "tincd@.service"
+}