summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2021-02-04 11:13:50 -0500
committerAnthony G. Basile <blueness@gentoo.org>2021-02-04 11:14:06 -0500
commit465c225b9183bfb2ce77d059a3b588d8cd5656a3 (patch)
treef77e8e85ac5b22b5cd105beafc703eec617c4ae1 /net-vpn/tor
parentsys-fs/udisks: Removed old (diff)
downloadgentoo-465c225b9183bfb2ce77d059a3b588d8cd5656a3.tar.gz
gentoo-465c225b9183bfb2ce77d059a3b588d8cd5656a3.tar.bz2
gentoo-465c225b9183bfb2ce77d059a3b588d8cd5656a3.zip
net-vpn/tor: version bump to 0.4.4.7
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-vpn/tor')
-rw-r--r--net-vpn/tor/Manifest1
-rw-r--r--net-vpn/tor/tor-0.4.4.7.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/net-vpn/tor/Manifest b/net-vpn/tor/Manifest
index 5ceed4bed88a..45db12c03e99 100644
--- a/net-vpn/tor/Manifest
+++ b/net-vpn/tor/Manifest
@@ -1,2 +1,3 @@
DIST tor-0.4.4.6.tar.gz 7806477 BLAKE2B 8eb5f22825193a61be42105ad32bd82e662c1859971fb2248fe05da2f80d1a3a9cbc96ee4f47f4127da56c328f5c60a6f57d5641cfa90b79becc8bf622f56f3f SHA512 84f981bed6d8c89d3de437e35dd2ad2ca3ee5efd7ce6b78e3e00bf40f644f495b960a7a741be5dd7ba096d73d5f941974722a44e9d3ef4fbcd02b20274d565fb
+DIST tor-0.4.4.7.tar.gz 7812645 BLAKE2B 8e35c56c0dc94c01de556ae3a02e2d465776dbe9cb2db35d4513dbe83b5e3b0b3641570ddeee1f43aedc34edba245591d4457debc13fa43111780cd4cff739f2 SHA512 356e9569eb79d81bccba1360d10af7d78f3824d5a4827fc95272a952fc8e5bebdfa9ec99fa82992c025625d6da963c15803acbabd66cd59c587c1e042af16acc
DIST tor-0.4.5.5-rc.tar.gz 7918239 BLAKE2B 8db4d4edbfa8a3298bd5269dfa6c38797cb217a6e5e1bffbee7a007847f8ea0c2fa87dc9343597af500fb9a51dacc7685d66a309b7bdffaabcdf271018b3bc84 SHA512 e7ca955387a7e985488d9af8a51703251af990e7fe790377caa8e349b48ccc6286e73fdb2f042d74323af2f9a82ecf3766adf3c2dd499bfc46d7ad7f578815a8
diff --git a/net-vpn/tor/tor-0.4.4.7.ebuild b/net-vpn/tor/tor-0.4.4.7.ebuild
new file mode 100644
index 000000000000..3ef4e3e4dd5e
--- /dev/null
+++ b/net-vpn/tor/tor-0.4.4.7.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic readme.gentoo-r1 systemd
+
+MY_PV="$(ver_rs 4 -)"
+MY_PF="${PN}-${MY_PV}"
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+SRC_URI="https://www.torproject.org/dist/${MY_PF}.tar.gz
+ https://archive.torproject.org/tor-package-archive/${MY_PF}.tar.gz"
+S="${WORKDIR}/${MY_PF}"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~ppc-macos"
+IUSE="caps doc libressl lzma +man scrypt seccomp selinux +server systemd tor-hardening test zstd"
+
+DEPEND="
+ dev-libs/libevent:=[ssl]
+ sys-libs/zlib
+ caps? ( sys-libs/libcap )
+ man? ( app-text/asciidoc )
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
+ lzma? ( app-arch/xz-utils )
+ scrypt? ( app-crypt/libscrypt )
+ seccomp? ( >=sys-libs/libseccomp-2.4.1 )
+ systemd? ( sys-apps/systemd )
+ zstd? ( app-arch/zstd )"
+RDEPEND="
+ acct-user/tor
+ acct-group/tor
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-tor )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.7.4-torrc.sample.patch
+ "${FILESDIR}"/${PN}-0.3.3.2-alpha-tor.service.in.patch
+)
+
+DOCS=()
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ use doc && DOCS+=( README ChangeLog ReleaseNotes doc/HACKING )
+ export ac_cv_lib_cap_cap_init=$(usex caps)
+ econf \
+ --localstatedir="${EPREFIX}/var" \
+ --disable-all-bugs-are-fatal \
+ --enable-system-torrc \
+ --disable-android \
+ --disable-html-manual \
+ --disable-libfuzzer \
+ --enable-missing-doc-warnings \
+ --disable-module-dirauth \
+ --enable-pic \
+ --disable-rust \
+ --disable-restart-debugging \
+ --disable-zstd-advanced-apis \
+ $(use_enable man asciidoc) \
+ $(use_enable man manpage) \
+ $(use_enable lzma) \
+ $(use_enable scrypt libscrypt) \
+ $(use_enable seccomp) \
+ $(use_enable server module-relay) \
+ $(use_enable systemd) \
+ $(use_enable tor-hardening gcc-hardening) \
+ $(use_enable tor-hardening linker-hardening) \
+ $(use_enable test unittests) \
+ $(use_enable test coverage) \
+ $(use_enable zstd)
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+
+ newconfd "${FILESDIR}"/tor.confd tor
+ newinitd "${FILESDIR}"/tor.initd-r9 tor
+ systemd_dounit contrib/dist/tor.service
+
+ keepdir /var/lib/tor
+
+ fperms 750 /var/lib/tor
+ fowners tor:tor /var/lib/tor
+
+ insinto /etc/tor/
+ newins "${FILESDIR}"/torrc-r2 torrc
+}