summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-04-18 15:07:29 +0200
committerDavid Seifert <soap@gentoo.org>2020-04-18 15:07:29 +0200
commit3d52f0aede746ac5da9e5808b0733a20b50f32cd (patch)
tree4963d05df9797bedec880a7fba94e01c1f62b076 /net-vpn/vpnc
parentsys-fs/xfsprogs: Build fails with -O3. Replaced with -O2 (diff)
downloadgentoo-3d52f0aede746ac5da9e5808b0733a20b50f32cd.tar.gz
gentoo-3d52f0aede746ac5da9e5808b0733a20b50f32cd.tar.bz2
gentoo-3d52f0aede746ac5da9e5808b0733a20b50f32cd.zip
net-vpn/vpnc: Revbump to use fork
* We're using streambinder's fork at https://github.com/streambinder/vpnc which is just a collection of patches to vpnc. Closes: https://bugs.gentoo.org/689802 Closes: https://bugs.gentoo.org/715314 Closes: https://bugs.gentoo.org/716556 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-vpn/vpnc')
-rw-r--r--net-vpn/vpnc/Manifest1
-rw-r--r--net-vpn/vpnc/files/vpnc-0.5.3_p550-r1-var-run-fhs-3.0.patch33
-rw-r--r--net-vpn/vpnc/vpnc-0.5.3_p550-r1.ebuild68
3 files changed, 102 insertions, 0 deletions
diff --git a/net-vpn/vpnc/Manifest b/net-vpn/vpnc/Manifest
index f63a67a64dd8..8104364d86c4 100644
--- a/net-vpn/vpnc/Manifest
+++ b/net-vpn/vpnc/Manifest
@@ -1 +1,2 @@
+DIST vpnc-0.5.3_p550-r1.tar.gz 133339 BLAKE2B d4f09a62edbe3b4014c4903d908eecf27ee09705017f715aadc869592fb80d7f4482f08e4681dd9e9c22ae16ae185404e09572800de8cb76419c20f5bf8e17d1 SHA512 3adaf4c73c14c328ca9702c1e3d3c333b0a589f99b52990febf7b22ac87f666f1fc0a1d62e9831ec645567ca01425ea476a7bb62fee214012c97651e0e99b732
DIST vpnc-0.5.3_p550.tar.xz 101860 BLAKE2B 9800ab0704108cd70450dcfe314eba7c09ca1bb329fa6b9f2946dbb6ee6407e5f6bc3d17d8be782e9103d94a12895777125acdad070f39ea1b96a946ba7d2302 SHA512 95150c743c61a962c36591bb874c77f2c28f341c0a1290dba4e878a460d22d762dd88f7cfc0aa9d17ace71a8b826d9fd13554c23b5123dee6009e9fffcd2de55
diff --git a/net-vpn/vpnc/files/vpnc-0.5.3_p550-r1-var-run-fhs-3.0.patch b/net-vpn/vpnc/files/vpnc-0.5.3_p550-r1-var-run-fhs-3.0.patch
new file mode 100644
index 000000000000..e574b51fba63
--- /dev/null
+++ b/net-vpn/vpnc/files/vpnc-0.5.3_p550-r1-var-run-fhs-3.0.patch
@@ -0,0 +1,33 @@
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -158,7 +158,7 @@
+ * treat passcode as password
+ * filter "metric10 64" and the like from ip route get output
+ * updated to libgcrypt-1.1.90
+- * create /var/run/vpnc/ as necessary
++ * create /run/vpnc/ as necessary
+
+ * vpnc-0.2-rm+zomb-pre6.tar.gz Sun Nov 2 02:15:56 CET 2003
+
+--- a/src/config.c
++++ b/src/config.c
+@@ -390,7 +390,7 @@
+
+ static const char *config_def_pid_file(void)
+ {
+- return "/var/run/vpnc.pid";
++ return "/run/vpnc.pid";
+ }
+
+ static const char *config_def_vendor(void)
+--- a/TODO
++++ b/TODO
+@@ -115,7 +115,7 @@
+ * DONE post link to http://www.liebchen-online.de/vpn-zaurus.html
+ * DONE passcode == password
+ * DONE support for new libgcrypt versions
+-* DONE make /var/run/vpnc as needed
++* DONE make /run/vpnc as needed
+ * DONE ignore "metric10 xx"
+ * DONE ignore attr 32136! (Cisco extension: XAUTH Vendor)
+ * DONE FreeBSD supported
diff --git a/net-vpn/vpnc/vpnc-0.5.3_p550-r1.ebuild b/net-vpn/vpnc/vpnc-0.5.3_p550-r1.ebuild
new file mode 100644
index 000000000000..4276d407ffab
--- /dev/null
+++ b/net-vpn/vpnc/vpnc-0.5.3_p550-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd toolchain-funcs vcs-snapshot
+
+DESCRIPTION="Free client for Cisco VPN routing software"
+HOMEPAGE="https://www.unix-ag.uni-kl.de/~massar/vpnc/"
+SRC_URI="https://github.com/streambinder/vpnc/archive/fa0689c.tar.gz -> ${PF}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="resolvconf +gnutls selinux"
+RESTRICT="!gnutls? ( bindist )"
+
+DEPEND="
+ dev-lang/perl
+ dev-libs/libgcrypt:0=
+ >=sys-apps/iproute2-2.6.19.20061214[-minimal]
+ gnutls? ( net-libs/gnutls:0= )
+ !gnutls? ( dev-libs/openssl:0= )"
+RDEPEND="${DEPEND}
+ resolvconf? ( virtual/resolvconf )
+ selinux? ( sec-policy/selinux-vpn )
+"
+
+CONFIG_CHECK="~TUN"
+
+S="${WORKDIR}/${PF}"
+PATCHES=( "${FILESDIR}"/${PF}-var-run-fhs-3.0.patch )
+
+src_configure() {
+ tc-export CC
+ export OPENSSL_GPL_VIOLATION=$(usex !gnutls)
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${ED}" install
+ dodoc README.md TODO VERSION
+
+ keepdir /etc/vpnc/scripts.d
+ newinitd "${FILESDIR}"/vpnc-3.init vpnc
+ newconfd "${FILESDIR}"/vpnc.confd vpnc
+ sed -e "s:/usr/local:${EPREFIX}/usr:" -i "${ED}"/etc/vpnc/vpnc-script || die
+
+ systemd_dotmpfilesd "${FILESDIR}"/vpnc-tmpfiles.conf
+ systemd_newunit "${FILESDIR}"/vpnc.service vpnc@.service
+
+ # COPYING file resides here, should not be installed
+ rm -r "${ED}"/usr/share/doc/vpnc/ || die
+}
+
+pkg_postinst() {
+ elog "You can generate a configuration file from the original Cisco profiles of your"
+ elog "connection by using /usr/bin/pcf2vpnc to convert the .pcf file"
+ elog "A guide is available at https://wiki.gentoo.org/wiki/Vpnc"
+
+ if use gnutls; then
+ elog "Will build with GnuTLS (default) instead of OpenSSL so you may even redistribute binaries."
+ elog "See the Makefile itself and https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440318"
+ else
+ ewarn "Building SSL support with OpenSSL instead of GnuTLS. This means that"
+ ewarn "you are not allowed to re-distibute the binaries due to conflicts between BSD license and GPL,"
+ ewarn "see the vpnc Makefile and https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440318"
+ fi
+}