summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2020-07-31 14:11:32 +0200
committerJason A. Donenfeld <zx2c4@gentoo.org>2020-07-31 14:12:07 +0200
commitb6941460e30a5ae2ee1f4665f0874e33df1e3e0a (patch)
tree87b5670ec60e00afd6e49f05f2d95e6e471ffb65 /net-vpn
parentnet-vpn/wireguard-modules: set maximum kernel bounds (diff)
downloadgentoo-b6941460e30a5ae2ee1f4665f0874e33df1e3e0a.tar.gz
gentoo-b6941460e30a5ae2ee1f4665f0874e33df1e3e0a.tar.bz2
gentoo-b6941460e30a5ae2ee1f4665f0874e33df1e3e0a.zip
net-vpn/wireguard-modules: remove 9999 ebuild
This is less important than it used to be. Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/wireguard-modules/wireguard-modules-9999.ebuild100
1 files changed, 0 insertions, 100 deletions
diff --git a/net-vpn/wireguard-modules/wireguard-modules-9999.ebuild b/net-vpn/wireguard-modules/wireguard-modules-9999.ebuild
deleted file mode 100644
index 198636c9d9a4..000000000000
--- a/net-vpn/wireguard-modules/wireguard-modules-9999.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MODULES_OPTIONAL_USE="module"
-inherit linux-mod bash-completion-r1
-
-DESCRIPTION="Simple yet fast and modern VPN that utilizes state-of-the-art cryptography."
-HOMEPAGE="https://www.wireguard.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.zx2c4.com/wireguard-linux-compat"
- KEYWORDS=""
-else
- SRC_URI="https://git.zx2c4.com/wireguard-linux-compat/snapshot/wireguard-linux-compat-${PV}.tar.xz"
- S="${WORKDIR}/wireguard-linux-compat-${PV}"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="debug +module module-src"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-MODULE_NAMES="wireguard(kernel/drivers/net:src)"
-BUILD_TARGETS="module"
-CONFIG_CHECK="NET INET NET_UDP_TUNNEL CRYPTO_ALGAPI"
-
-pkg_setup() {
- if use module; then
- linux-mod_pkg_setup
- if [[ -f $KERNEL_DIR/include/uapi/linux/wireguard.h ]]; then
- eerror
- eerror "WireGuard has been merged upstream into this kernel. Therefore,"
- eerror "you no longer need this compatibility ebuild. Instead, simply"
- eerror "enable CONFIG_WIREGUARD=y in your kernel configuration."
- eerror
- die "Use CONFIG_WIREGUARD=y for this kernel, and do not use this package."
- elif kernel_is -lt 3 10 0 || kernel_is -ge 5 6 0; then
- die "This version of ${PN} requires Linux >= 3.10 and < 5.6."
- fi
- fi
-}
-
-src_compile() {
- BUILD_PARAMS="KERNELDIR=${KV_OUT_DIR}"
- use debug && BUILD_PARAMS="CONFIG_WIREGUARD_DEBUG=y ${BUILD_PARAMS}"
- use module && linux-mod_src_compile
-}
-
-src_install() {
- use module && linux-mod_src_install
- use module-src && emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" -C src dkms-install
-}
-
-pkg_postinst() {
- if use module-src && ! use module; then
- einfo
- einfo "You have enabled the module-src USE flag without the module USE"
- einfo "flag. This means that sources are installed to"
- einfo "${ROOT}/usr/src/wireguard instead of having the"
- einfo "kernel module compiled. You will need to compile the module"
- einfo "yourself. Most likely, you don't want this USE flag, and should"
- einfo "rather use USE=module"
- einfo
- fi
-
- if use module; then
- linux-mod_pkg_postinst
- local old new
- if [[ $(uname -r) != "${KV_FULL}" ]]; then
- ewarn
- ewarn "You have just built WireGuard for kernel ${KV_FULL}, yet the currently running"
- ewarn "kernel is $(uname -r). If you intend to use this WireGuard module on the currently"
- ewarn "running machine, you will first need to reboot it into the kernel ${KV_FULL}, for"
- ewarn "which this module was built."
- ewarn
- elif [[ -f /sys/module/wireguard/version ]] && \
- old="$(< /sys/module/wireguard/version)" && \
- new="$(modinfo -F version "${ROOT}/lib/modules/${KV_FULL}/net/wireguard.ko" 2>/dev/null)" && \
- [[ $old != "$new" ]]; then
- ewarn
- ewarn "You appear to have just upgraded WireGuard from version v$old to v$new."
- ewarn "However, the old version is still running on your system. In order to use the"
- ewarn "new version, you will need to remove the old module and load the new one. As"
- ewarn "root, you can accomplish this with the following commands:"
- ewarn
- ewarn " # rmmod wireguard"
- ewarn " # modprobe wireguard"
- ewarn
- ewarn "Do note that doing this will remove current WireGuard interfaces, so you may want"
- ewarn "to gracefully remove them yourself prior."
- ewarn
- fi
- fi
-}