summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-14 10:56:06 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-14 14:45:07 +0100
commit7fdc37240878ce14c497140ce4bf1126c5760bc1 (patch)
treecf749923693371d279bb7f8b2f553a9fa41cdf76 /net-wireless/gnome-bluetooth
parentgnome-extra/gnome-tweak-tool: Drop old (diff)
downloadgentoo-7fdc37240878ce14c497140ce4bf1126c5760bc1.tar.gz
gentoo-7fdc37240878ce14c497140ce4bf1126c5760bc1.tar.bz2
gentoo-7fdc37240878ce14c497140ce4bf1126c5760bc1.zip
net-wireless/gnome-bluetooth: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'net-wireless/gnome-bluetooth')
-rw-r--r--net-wireless/gnome-bluetooth/Manifest1
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-3.18.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/Manifest b/net-wireless/gnome-bluetooth/Manifest
index 5e81e3de0231..4693a741e7bd 100644
--- a/net-wireless/gnome-bluetooth/Manifest
+++ b/net-wireless/gnome-bluetooth/Manifest
@@ -1,3 +1,4 @@
DIST gnome-bluetooth-3.14.0.tar.xz 1350300 SHA256 e2ef5e0036748eeb4756e8cb57e9909f10b771d290086dd1f377451d3fe18b09 SHA512 5df9367bf7ac08a896d2a34b855c06c0f9f2b8485f1f549659ee42b9ccea5db0983eef271b4611cfc234f590e4cca7485f353342efbe1e28e7068d4d6c2a0beb WHIRLPOOL 920ff7993a3f74bc5da0343097c7a8e1354ab95feda97cff1c8a87f991a6cae6259593a39f072199ae1ef320739b7dd074c5078e6fa66cbf23ed5874c22748ca
DIST gnome-bluetooth-3.14.1.tar.xz 1355116 SHA256 3d2f6161c43d4c53af37979d6d7ff8714211676bffa80e211f168819e64bb4c9 SHA512 64ccc7fe32b9dce2513caca4e785133376d8ab776cdfe4d6a8146897b4a526cd4426f81d55fddec8971614b4b0a15523ebde9cde0f628aed10c807b2c1d9ad48 WHIRLPOOL 5bfbd131ca17f05a071dfccf627d488fb61e0375a172a627d96152e5bc82294d03a5e1b5cb04ca44921e440d774fd43219843ed1f6153d8a53deac567b8d08b0
DIST gnome-bluetooth-3.16.1.tar.xz 1357388 SHA256 3feb202d6780a53bc4a570eab5b0179f9351b32c1d3f28151ac2d222453ae08b SHA512 811db04e1ab91585031e86cb55ee7764b0f0dfd88682afaee2e67f99af12619c540a48a3879afd8fb66e39cb35917f637b637e4b6f3ab8b8e908351426b77576 WHIRLPOOL 3019d80e64d5009f06480a65f19bf1b46daaeda4071345e0fea7da666d28301c51d6daf4a671c9582fbf64ff8e5b923444054e68c5a85d0a0e97351ed0bff648
+DIST gnome-bluetooth-3.18.1.tar.xz 793232 SHA256 c51d5b896d32845a2b5bb6ccd48926c88c8e9ef0915c32d3c56cb7e7974d4a49 SHA512 ed6c5b7e826275c894370084c5c2afa8c76751885caf0b0cad822e892249c44dd223ba377b6fc08a8f120d30377c80641fb31c69b8ec0ddd780e88aa1cadb224 WHIRLPOOL 22ab42417d3dd056d2ac7dab3774860fd11299beaf3f66d777121fd918d023e349b878b3df4d9a97c87da276a83b4f24307c1a4059cc34ffe30aed9452db55ce
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.18.1.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.18.1.ebuild
new file mode 100644
index 000000000000..0037c1e84bb3
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.18.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit eutils gnome2 udev user
+
+DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeBluetooth"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="2/13" # subslot = libgnome-bluetooth soname version
+IUSE="+introspection"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.38:2
+ media-libs/libcanberra[gtk3]
+ >=x11-libs/gtk+-3.12:3[introspection?]
+ x11-libs/libnotify
+ virtual/udev
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=net-wireless/bluez-5
+ x11-themes/gnome-icon-theme-symbolic
+"
+DEPEND="${COMMON_DEPEND}
+ !net-wireless/bluez-gnome
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40.0
+ dev-util/itstool
+ virtual/libudev
+ virtual/pkgconfig
+ x11-proto/xproto
+"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+pkg_setup() {
+ enewgroup plugdev
+}
+
+src_prepare() {
+ # Regenerate gdbus-codegen files to allow using any glib version; bug #436236
+ # https://bugzilla.gnome.org/show_bug.cgi?id=758096
+ rm -v lib/bluetooth-client-glue.{c,h} || die
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --enable-documentation \
+ --disable-desktop-update \
+ --disable-icon-update \
+ --disable-static
+}
+
+src_install() {
+ gnome2_src_install
+ udev_dorules "${FILESDIR}"/61-${PN}.rules
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! has_version sys-auth/consolekit[acl] && ! has_version sys-apps/systemd[acl] ; then
+ elog "Don't forget to add yourself to the plugdev group "
+ elog "if you want to be able to control bluetooth transmitter."
+ fi
+}