summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-01-04 22:00:57 -0500
committerZero_Chaos <zerochaos@gentoo.org>2016-01-04 22:01:31 -0500
commit514aa621dc3be1b9a2be67e7bf18cb923b45f13d (patch)
treeedf9a75e7ccfe13bb449fcdeba4a491f5a12eb3d /net-wireless/gnuradio/gnuradio-9999.ebuild
parentnet-analyzer/dhcpdump: adding arm (diff)
downloadgentoo-514aa621dc3be1b9a2be67e7bf18cb923b45f13d.tar.gz
gentoo-514aa621dc3be1b9a2be67e7bf18cb923b45f13d.tar.bz2
gentoo-514aa621dc3be1b9a2be67e7bf18cb923b45f13d.zip
net-wireless/gnuradio: bump to 3.7.9, hopefully fix bug #430348 correctly
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-wireless/gnuradio/gnuradio-9999.ebuild')
-rw-r--r--net-wireless/gnuradio/gnuradio-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-wireless/gnuradio/gnuradio-9999.ebuild b/net-wireless/gnuradio/gnuradio-9999.ebuild
index 2933b8eb1087..82c7a54366ce 100644
--- a/net-wireless/gnuradio/gnuradio-9999.ebuild
+++ b/net-wireless/gnuradio/gnuradio-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -154,7 +154,7 @@ src_configure() {
-DENABLE_GR_CORE=ON \
-DSYSCONFDIR="${EPREFIX}"/etc \
-DPYTHON_EXECUTABLE="${PYTHON}"
- -DGR_PKG_DOC_DIR='${GR_DOC_DIR}/${CMAKE_PROJECT_NAME}'-"${PVF}"
+ -DGR_PKG_DOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
)
use vocoder && mycmakeargs+=( -DGR_USE_SYSTEM_LIBGSM=TRUE )
cmake-utils_src_configure
@@ -166,11 +166,17 @@ src_install() {
if use examples ; then
dodir /usr/share/doc/${PF}/
mv "${ED}"/usr/share/${PN}/examples "${ED}"/usr/share/doc/${PF}/ || die
+ docompress -x /usr/share/doc/${PF}/examples
else
# It seems that the examples are always installed
rm -rf "${ED}"/usr/share/${PN}/examples || die
fi
+ if use doc || use examples; then
+ #this doesn't appear useful
+ rm -rf "${ED}"/usr/share/doc/${PF}/xml || die
+ fi
+
# We install the mimetypes to the correct locations from the ebuild
rm -rf "${ED}"/usr/share/${PN}/grc/freedesktop || die
rm -f "${ED}"/usr/libexec/${PN}/grc_setup_freedesktop || die