summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2015-08-25 00:37:07 -0400
committerZero_Chaos <zerochaos@gentoo.org>2015-08-25 00:38:00 -0400
commit8cca39d19cdaff5716220d0ed737d9826389fa42 (patch)
treee701ab1703ea4956e9f35e155028524b18da1e8f /net-wireless/gr-paint/gr-paint-9999.ebuild
parentmedia-video/mplayer: Stable for HPPA (bug #551972). (diff)
downloadgentoo-8cca39d19cdaff5716220d0ed737d9826389fa42.tar.gz
gentoo-8cca39d19cdaff5716220d0ed737d9826389fa42.tar.bz2
gentoo-8cca39d19cdaff5716220d0ed737d9826389fa42.zip
net-wireless/gr-paint: new
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-wireless/gr-paint/gr-paint-9999.ebuild')
-rw-r--r--net-wireless/gr-paint/gr-paint-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-wireless/gr-paint/gr-paint-9999.ebuild b/net-wireless/gr-paint/gr-paint-9999.ebuild
new file mode 100644
index 000000000000..11808a8133f1
--- /dev/null
+++ b/net-wireless/gr-paint/gr-paint-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit git-r3
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="paints monochrome images into the waterfall of a receiver"
+HOMEPAGE="https://github.com/drmpeg/gr-paint"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/drmpeg/gr-paint.git"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ net-wireless/gnuradio:=[${PYTHON_USEDEP}]
+ dev-libs/boost:=[${PYTHON_USEDEP}]"
+RDEPEND="${COMMON_DEPEND}
+ media-gfx/imagemagick"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ dev-util/cppunit
+ dev-lang/swig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable doc DOXYGEN)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ cmake-utils_src_configure
+}