summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-07-05 17:34:22 +0200
committerMichael Weber <xmw@gentoo.org>2016-07-05 17:34:49 +0200
commitd4e25b506f9ae6118e083fcd847605f00f4819ca (patch)
treefa5ec470081951e9800a8f8f14b1652a3634a967 /net-wireless/horst/horst-5.0.ebuild
parentwww-client/firefox: Drop unused patch. (diff)
downloadgentoo-d4e25b506f9ae6118e083fcd847605f00f4819ca.tar.gz
gentoo-d4e25b506f9ae6118e083fcd847605f00f4819ca.tar.bz2
gentoo-d4e25b506f9ae6118e083fcd847605f00f4819ca.zip
net-wireless/horst: Version bump (thanks Matthias Maier, bug 587790).
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-wireless/horst/horst-5.0.ebuild')
-rw-r--r--net-wireless/horst/horst-5.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-wireless/horst/horst-5.0.ebuild b/net-wireless/horst/horst-5.0.ebuild
new file mode 100644
index 000000000000..93b00c9f47ec
--- /dev/null
+++ b/net-wireless/horst/horst-5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs vcs-snapshot
+
+DESCRIPTION="Small 802.11 wireless LAN analyzer"
+HOMEPAGE="http://br1.einfach.org/tech/horst/"
+SRC_URI="https://github.com/br101/${PN}/archive/version-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +pcap test"
+
+RDEPEND="sys-libs/ncurses:0
+ pcap? ( net-libs/libpcap )"
+DEPEND="${RDEPEND}
+ test? ( sys-devel/sparse )"
+
+#just semantic tests, no functional tests
+RESTRICT=test
+
+src_compile() {
+ tc-export CC
+ emake PCAP=$(usex pcap 1 0) DEBUG=$(usex debug 1 0)
+}
+
+src_install() {
+ dosbin ${PN}{,.sh}
+ dodoc README.md
+ doman ${PN}.1
+}