summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2019-09-24 10:30:29 -0500
committerBen Kohler <bkohler@gentoo.org>2019-09-24 10:31:23 -0500
commit8728d4c5ee2991eca35d949f52fb9d32ab6dce9a (patch)
treeeda34c41c6a98e40dcd2089af00e74dfaffa70be /net-wireless/iwd/iwd-9999.ebuild
parentwww-servers/nginx: bump v1.17.4 (diff)
downloadgentoo-8728d4c5ee2991eca35d949f52fb9d32ab6dce9a.tar.gz
gentoo-8728d4c5ee2991eca35d949f52fb9d32ab6dce9a.tar.bz2
gentoo-8728d4c5ee2991eca35d949f52fb9d32ab6dce9a.zip
net-wireless/iwd: live ebuild tweaks
Added new dep on docutils for man page generation. Changed all 9999 conditionals to *9999* for future-proofing and consistency. Introduced COMMON_DEPEND & reorganized deps. Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-wireless/iwd/iwd-9999.ebuild')
-rw-r--r--net-wireless/iwd/iwd-9999.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/net-wireless/iwd/iwd-9999.ebuild b/net-wireless/iwd/iwd-9999.ebuild
index bed12522f623..e1dc339b4d2c 100644
--- a/net-wireless/iwd/iwd-9999.ebuild
+++ b/net-wireless/iwd/iwd-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=6
inherit autotools flag-o-matic linux-info systemd
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/wireless/iwd.git"
inherit git-r3
else
@@ -19,15 +19,19 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="+client +crda +monitor ofono wired cpu_flags_x86_aes cpu_flags_x86_ssse3"
-RDEPEND=">=dev-libs/ell-0.21
- net-wireless/wireless-regdb
+COMMON_DEPEND=">=dev-libs/ell-0.21
sys-apps/dbus
- client? ( sys-libs/readline:0= )
+ client? ( sys-libs/readline:0= )"
+
+RDEPEND="${COMMON_DEPEND}
+ net-wireless/wireless-regdb
crda? ( net-wireless/crda )"
-DEPEND="${RDEPEND}
+DEPEND="${COMMON_DEPEND}
virtual/pkgconfig"
+[[ ${PV} == *9999* ]] && DEPEND+=" dev-python/docutils"
+
pkg_pretend() {
CONFIG_CHECK="
~ASYMMETRIC_KEY_TYPE
@@ -96,7 +100,7 @@ pkg_pretend() {
}
src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
+ if [[ ${PV} == *9999* ]] ; then
git-r3_src_unpack
git clone git://git.kernel.org/pub/scm/libs/ell/ell.git "${WORKDIR}"/ell
else
@@ -132,7 +136,7 @@ src_install() {
newinitd "${FILESDIR}/ead.initd" ead
fi
- if [[ ${PV} == "9999" ]] ; then
+ if [[ ${PV} == *9999* ]] ; then
exeinto /usr/share/iwd/scripts/
doexe test/*
fi