summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2019-02-23 11:40:20 -0600
committerBen Kohler <bkohler@gentoo.org>2019-02-23 11:40:43 -0600
commit899128a1dfe2c21fa99d28d542fb4a97a6fc81a1 (patch)
tree8dfd70f37914722e5c71dc01934ed7938f061081 /net-wireless/iwd/iwd-9999.ebuild
parentgnome-extra/gnome-tweak-tool: drop unnecessary subslot operator dep (diff)
downloadgentoo-899128a1dfe2c21fa99d28d542fb4a97a6fc81a1.tar.gz
gentoo-899128a1dfe2c21fa99d28d542fb4a97a6fc81a1.tar.bz2
gentoo-899128a1dfe2c21fa99d28d542fb4a97a6fc81a1.zip
net-wireless/iwd: revbump to add -fsigned-char
Upstream recommends this compiler option and is default-enabling it when CFLAGS is unset. This commit will keep it enabled even when we set CFLAGS. This fixes a test on ppc (and maybe other arches). Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-wireless/iwd/iwd-9999.ebuild')
-rw-r--r--net-wireless/iwd/iwd-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/net-wireless/iwd/iwd-9999.ebuild b/net-wireless/iwd/iwd-9999.ebuild
index 542d347128bc..b037416528c5 100644
--- a/net-wireless/iwd/iwd-9999.ebuild
+++ b/net-wireless/iwd/iwd-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools linux-info systemd
+inherit autotools flag-o-matic linux-info systemd
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/wireless/iwd.git"
@@ -88,6 +88,7 @@ src_prepare() {
}
src_configure() {
+ append-cflags "-fsigned-char"
econf --sysconfdir=/etc/iwd --localstatedir=/var \
$(use_enable client) \
$(use_enable monitor) \