summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-11-01 11:15:50 -0400
committerBen Kohler <bkohler@gentoo.org>2019-11-01 11:22:55 -0500
commita6d9d4fb599177e4e935a0b935d525c512d1c418 (patch)
tree4fbc238c19973c65194a74fc4407edcd4eda78a9 /net-wireless/iwd/iwd-9999.ebuild
parentnet-wireless/iwd: pass EPREFIX where appropriate (diff)
downloadgentoo-a6d9d4fb599177e4e935a0b935d525c512d1c418.tar.gz
gentoo-a6d9d4fb599177e4e935a0b935d525c512d1c418.tar.bz2
gentoo-a6d9d4fb599177e4e935a0b935d525c512d1c418.zip
net-wireless/iwd: fetch ell.git using git-r3
Bug: https://bugs.gentoo.org/699042 Package-Manager: Portage-2.3.78_p4, Repoman-2.3.17_p100 Signed-off-by: Mike Gilbert <floppym@gentoo.org> Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-wireless/iwd/iwd-9999.ebuild')
-rw-r--r--net-wireless/iwd/iwd-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-wireless/iwd/iwd-9999.ebuild b/net-wireless/iwd/iwd-9999.ebuild
index bcf7602ab7a9..32c1b7fd134e 100644
--- a/net-wireless/iwd/iwd-9999.ebuild
+++ b/net-wireless/iwd/iwd-9999.ebuild
@@ -5,8 +5,9 @@ EAPI=6
inherit flag-o-matic linux-info systemd
if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/wireless/iwd.git"
inherit autotools git-r3
+ IWD_EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/wireless/iwd.git"
+ ELL_EGIT_REPO_URI="https://git.kernel.org/pub/scm/libs/ell/ell.git"
else
SRC_URI="https://www.kernel.org/pub/linux/network/wireless/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~sparc ~x86"
@@ -101,8 +102,8 @@ pkg_pretend() {
src_unpack() {
if [[ ${PV} == *9999* ]] ; then
- git-r3_src_unpack
- git clone git://git.kernel.org/pub/scm/libs/ell/ell.git "${WORKDIR}"/ell
+ EGIT_REPO_URI=${IWD_EGIT_REPO_URI} git-r3_src_unpack
+ EGIT_REPO_URI=${ELL_EGIT_REPO_URI} EGIT_CHECKOUT_DIR=${S}/ell git-r3_src_unpack
else
default
fi