summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2019-12-19 11:17:49 -0500
committerRick Farina <zerochaos@gentoo.org>2019-12-19 11:18:11 -0500
commit00a53abc26b46c478ad775760d2c5a87e540e749 (patch)
tree63c89c35a0f5f1c0754e515282b3154a4ba8cdfc /net-wireless/kismet
parentwww-apps/mediawiki: bump to 1.34.0 (diff)
downloadgentoo-00a53abc26b46c478ad775760d2c5a87e540e749.tar.gz
gentoo-00a53abc26b46c478ad775760d2c5a87e540e749.tar.bz2
gentoo-00a53abc26b46c478ad775760d2c5a87e540e749.zip
net-wireless/kismet: live updates
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/kismet')
-rw-r--r--net-wireless/kismet/kismet-9999.ebuild16
-rw-r--r--net-wireless/kismet/metadata.xml3
2 files changed, 13 insertions, 6 deletions
diff --git a/net-wireless/kismet/kismet-9999.ebuild b/net-wireless/kismet/kismet-9999.ebuild
index 01ac8b25a826..3438a10b65cd 100644
--- a/net-wireless/kismet/kismet-9999.ebuild
+++ b/net-wireless/kismet/kismet-9999.ebuild
@@ -33,8 +33,8 @@ HOMEPAGE="https://www.kismetwireless.net"
LICENSE="GPL-2"
SLOT="0/${PV}"
-IUSE="lm-sensors mousejack networkmanager +pcre selinux +suid"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
+IUSE="libusb lm-sensors networkmanager +pcre rtlsdr selinux +suid ubertooth"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
CDEPEND="
${PYTHON_DEPS}
@@ -48,7 +48,7 @@ CDEPEND="
dev-libs/libnl:3
net-libs/libpcap
)
- mousejack? ( virtual/libusb:1 )
+ libusb? ( virtual/libusb:1 )
dev-libs/protobuf-c:=
dev-libs/protobuf:=
dev-python/protobuf-python[${PYTHON_USEDEP}]
@@ -56,6 +56,7 @@ CDEPEND="
lm-sensors? ( sys-apps/lm-sensors )
pcre? ( dev-libs/libpcre )
suid? ( sys-libs/libcap )
+ ubertooth? ( net-wireless/ubertooth:= )
"
DEPEND="${CDEPEND}
@@ -66,6 +67,8 @@ RDEPEND="${CDEPEND}
dev-python/pyserial[${PYTHON_USEDEP}]
selinux? ( sec-policy/selinux-kismet )
"
+PDEPEND="rtlsdr? ( dev-python/numpy[${PYTHON_USEDEP}]
+ net-wireless/rtl-sdr )"
src_prepare() {
sed -i -e "s:^\(logtemplate\)=\(.*\):\1=/tmp/\2:" \
@@ -88,10 +91,11 @@ src_prepare() {
src_configure() {
econf \
+ $(use_enable libusb libusb) \
$(use_enable pcre) \
$(use_enable lm-sensors lmsensors) \
- $(use_enable mousejack libusb) \
$(use_enable networkmanager libnm) \
+ $(use_enable ubertooth) \
--sysconfdir=/etc/kismet \
--disable-optimization
}
@@ -133,9 +137,9 @@ pkg_preinst() {
migrate_config() {
einfo "Kismet Configuration files are now read from /etc/kismet/"
- if [ -n "$(ls ${EROOT}/etc/kismet_*.conf)" ]; then
+ ewarn "Please keep user specific settings in /etc/kismet/kismet_site.conf"
+ if [ -n "$(ls ${EROOT}/etc/kismet_*.conf 2> /dev/null)" ]; then
ewarn "Files at /etc/kismet_*.conf will not be read and should be removed"
- ewarn "Please keep user specific settings in /etc/kismet/kismet_site.conf"
fi
if [ -f "${EROOT}/etc/kismet_site.conf" ] && [ ! -f "${EROOT}/etc/kismet/kismet_site.conf" ]; then
mv /etc/kismet_site.conf /etc/kismet/kismet_site.conf || die "Failed to migrate kismet_site.conf to new location"
diff --git a/net-wireless/kismet/metadata.xml b/net-wireless/kismet/metadata.xml
index e5158f5c107b..db93b745df76 100644
--- a/net-wireless/kismet/metadata.xml
+++ b/net-wireless/kismet/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="client">Build the ncurses-based user interface</flag>
+ <flag name="libusb">Support libusb based capture sources such as mousejack, cc2540(ble), and nrf51822(ble)</flag>
<flag name="suid">
Install a setuid root helper binary with limited functionality;
this allows running kismet as a normal user, significantly
@@ -21,6 +22,8 @@
<flag name="plugin-ptw">Build the ptw plugin</flag>
<flag name="plugin-spectools">Build the spectools plugin. This uses <pkg>net-wireless/spectools</pkg></flag>
<flag name="plugin-syslog">Build the syslog plugin.</flag>
+ <flag name="rtlsdr">Enable rtlsdr based kismet capture sources</flag>
<flag name="ruby">Build extras which are written in ruby, example plugins and the like.</flag>
+ <flag name="ubertooth">Enable capture source for ubertooth to sniff bluetooth low energy</flag>
</use>
</pkgmetadata>