summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-08-20 21:47:59 +0200
committerHans de Graaff <graaff@gentoo.org>2017-08-20 21:48:42 +0200
commit080ee7087ff8e8ce4b53d36294b5f657381c9e59 (patch)
treeb0670affdce56c06988bbf7a6d369a1a719dad21 /net-wireless/lorcon
parentapp-misc/linuxspa: remove old (diff)
downloadgentoo-080ee7087ff8e8ce4b53d36294b5f657381c9e59.tar.gz
gentoo-080ee7087ff8e8ce4b53d36294b5f657381c9e59.tar.bz2
gentoo-080ee7087ff8e8ce4b53d36294b5f657381c9e59.zip
net-wireless/lorcon: drop ruby USE flag, bug 620400
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-wireless/lorcon')
-rw-r--r--net-wireless/lorcon/lorcon-0.0_p20150109.ebuild35
-rw-r--r--net-wireless/lorcon/lorcon-9999.ebuild35
2 files changed, 8 insertions, 62 deletions
diff --git a/net-wireless/lorcon/lorcon-0.0_p20150109.ebuild b/net-wireless/lorcon/lorcon-0.0_p20150109.ebuild
index a77f0e64a77b..c10482d2cdfb 100644
--- a/net-wireless/lorcon/lorcon-0.0_p20150109.ebuild
+++ b/net-wireless/lorcon/lorcon-0.0_p20150109.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -6,10 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python2_7 )
DISTUTILS_OPTIONAL=1
-USE_RUBY="ruby20 ruby21"
-RUBY_OPTIONAL=yes
-
-inherit distutils-r1 ruby-ng
+inherit distutils-r1
DESCRIPTION="A generic library for injecting 802.11 frames"
HOMEPAGE="http://802.11ninja.net/lorcon"
@@ -25,9 +22,9 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="python ruby"
+IUSE="python"
-DEPEND="ruby? ( $(ruby_implementations_depend) )
+DEPEND="
python? ( ${PYTHON_DEPS} )
dev-libs/libnl:3=
net-libs/libpcap"
@@ -37,26 +34,17 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
S="${WORKDIR}"/${P}
-pkg_setup() {
- use ruby && ruby-ng_pkg_setup
-}
-
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
git-r3_src_unpack
cp -R "${S}/" "${WORKDIR}/all"
fi
default_src_unpack
- #ruby-ng_src_unpack doesn't seem to like mixing with git so we just copy things above
- use ruby && ruby-ng_src_unpack
}
src_prepare() {
sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' pylorcon2/PyLorcon2.c
- sed -i 's#find_library("orcon2", "lorcon_list_drivers", "lorcon2/lorcon.h") and ##' ruby-lorcon/extconf.rb
- sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' ruby-lorcon/Lorcon2.h
use python && distutils-r1_src_prepare
- use ruby && ruby-ng_src_prepare
}
src_configure() {
@@ -65,7 +53,6 @@ src_configure() {
src_compile() {
default_src_compile
- use ruby && ruby-ng_src_compile
if use python; then
LDFLAGS+=" -L${S}/.libs/"
cd pylorcon2 || die
@@ -75,7 +62,6 @@ src_compile() {
src_install() {
emake DESTDIR="${ED}" install
- use ruby && ruby-ng_src_install
if use python; then
cd pylorcon2 || die
distutils-r1_src_install
@@ -85,16 +71,3 @@ src_install() {
src_test() {
:
}
-
-each_ruby_compile() {
- sed -i "s#-I/usr/include/lorcon2#-I${WORKDIR}/${P}/ruby-lorcon -L${WORKDIR}/${P}/.libs#" ruby-lorcon/extconf.rb
- "${RUBY}" -C ruby-lorcon extconf.rb || die
- sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' ruby-lorcon/Lorcon2.h
- sed -i -e "s#-L\.#-L. -L${WORKDIR}/${P}/.libs -lorcon2 #g" \
- -e "s#-Wl,--no-undefined##" ruby-lorcon/Makefile || die
- emake V=1 -C ruby-lorcon
-}
-
-each_ruby_install() {
- DESTDIR="${ED}" emake -C ruby-lorcon install
-}
diff --git a/net-wireless/lorcon/lorcon-9999.ebuild b/net-wireless/lorcon/lorcon-9999.ebuild
index c25009b8693a..f0502097ecd1 100644
--- a/net-wireless/lorcon/lorcon-9999.ebuild
+++ b/net-wireless/lorcon/lorcon-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -6,10 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python2_7 )
DISTUTILS_OPTIONAL=1
-USE_RUBY="ruby20 ruby21"
-RUBY_OPTIONAL=yes
-
-inherit distutils-r1 ruby-ng
+inherit distutils-r1
DESCRIPTION="A generic library for injecting 802.11 frames"
HOMEPAGE="http://802.11ninja.net/lorcon"
@@ -25,9 +22,9 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="python ruby"
+IUSE="python"
-DEPEND="ruby? ( $(ruby_implementations_depend) )
+DEPEND="
python? ( ${PYTHON_DEPS} )
dev-libs/libnl:3=
net-libs/libpcap"
@@ -37,26 +34,17 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
S="${WORKDIR}"/${P}
-pkg_setup() {
- use ruby && ruby-ng_pkg_setup
-}
-
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
git-r3_src_unpack
cp -R "${S}/" "${WORKDIR}/all"
fi
default_src_unpack
- #ruby-ng_src_unpack doesn't seem to like mixing with git so we just copy things above
- use ruby && ruby-ng_src_unpack
}
src_prepare() {
sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' pylorcon2/PyLorcon2.c
- sed -i 's#find_library("orcon2", "lorcon_list_drivers", "lorcon2/lorcon.h") and ##' ruby-lorcon/extconf.rb
- sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' ruby-lorcon/Lorcon2.h
use python && distutils-r1_src_prepare
- use ruby && ruby-ng_src_prepare
}
src_configure() {
@@ -65,7 +53,6 @@ src_configure() {
src_compile() {
default_src_compile
- use ruby && ruby-ng_src_compile
if use python; then
LDFLAGS+=" -L${S}/.libs/"
cd pylorcon2 || die
@@ -75,7 +62,6 @@ src_compile() {
src_install() {
emake DESTDIR="${ED}" install
- use ruby && ruby-ng_src_install
if use python; then
cd pylorcon2 || die
distutils-r1_src_install
@@ -85,16 +71,3 @@ src_install() {
src_test() {
:
}
-
-each_ruby_compile() {
- sed -i "s#-I/usr/include/lorcon2#-I${WORKDIR}/${P}/ruby-lorcon -L${WORKDIR}/${P}/.libs#" ruby-lorcon/extconf.rb
- "${RUBY}" -C ruby-lorcon extconf.rb || die
- sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' ruby-lorcon/Lorcon2.h
- sed -i -e "s#-L\.#-L. -L${WORKDIR}/${P}/.libs -lorcon2 #g" \
- -e "s#-Wl,--no-undefined##" ruby-lorcon/Makefile || die
- emake V=1 -C ruby-lorcon
-}
-
-each_ruby_install() {
- DESTDIR="${ED}" emake -C ruby-lorcon install
-}